Options

help with PPP

exkor5000exkor5000 Member Posts: 54 ■■□□□□□□□□
i was playing around with PPP and for some unkown to me reason the ping doesnt go through

config on R1:
interface Bri0
 ip address 192.168.2.1 255.255.255.0
 no ip directed-broadcast
 ip ospf cost 1500
 ip ospf priority 0
 encapsulation ppp
 ppp authentication chap
!
!
router ospf 1
 network 192.168.1.0 0.0.0.255 area 1
 network 192.168.2.0 0.0.0.255 area 2
 network 192.168.3.0 0.0.0.255 area 3
!

config on R2:
interface Bri0
 ip address 192.168.2.2 255.255.255.0
 no ip directed-broadcast
 ip ospf cost 1500
 ip ospf priority 0
 encapsulation ppp
 ppp authentication chap
!
!
router ospf 1
 network 192.168.2.0 0.0.0.255 area 2

on both routers i created usernames with passwords so that they can login to each other with PPP.

I also issues the "no login" command from the line configuration command.

NOTE: while i was writing this the line and link just went up icon_eek.gif >> Cisco magic... my original problem was bringing the link up
R1#sh ip interface bri
Interface              IP-Address      OK? Method Status                Protocol
Serial0                192.168.3.1     YES unset  up                    down
Serial1                192.168.1.1     YES unset  up                    up
Ethernet0              160.10.1.1      YES unset  up                    up
Bri0                   192.168.2.1     YES unset  up                    up
Bri0:1                 unassigned      YES unset  down                  down
Bri0:2                 unassigned      YES unset  down                  down

however why doesnt ping go through???
R1#ping 192.168.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5), round-trip min/avg/max = 1/2/4 ms

Thanks

Comments

  • Options
    HumperHumper Member Posts: 647
    bri0 is ISDN....how are you connecting the two together? you will need to configure ISDN on the routers.
    Now working full time!
  • Options
    exkor5000exkor5000 Member Posts: 54 ■■□□□□□□□□
    bri0 is ISDN....how are you connecting the two together? you will need to configure ISDN on the routers.

    interesting... the book im using to study (Exam Scram) does not point that out, it just lists PPP and ISDN under different section in the chapter on WAN Area Networks. So it seemed to me that PPP and ISDN are not realated.

    I wanted to use PPP, do I have to configure ISDN for bri0?
  • Options
    Danman32Danman32 Member Posts: 1,243
    PPP is a link protocol, as in layer 2. ISDN is more on the lines of layer 1. In other words PPP would go over ISDN. It can also go over dialup, or straight serial.
  • Options
    exkor5000exkor5000 Member Posts: 54 ■■□□□□□□□□
    ok got the point.

    Thanks
  • Options
    Danman32Danman32 Member Posts: 1,243
    Also, did you set up your Chap authentication password? I don't see that anywhere in what you showed, though it may be elsewhere in your config.
  • Options
    exkor5000exkor5000 Member Posts: 54 ■■□□□□□□□□
    Also, did you set up your Chap authentication password? I don't see that anywhere in what you showed, though it may be elsewhere in your config.

    Yes I did, I also created usernames for both routers to login to each other.
  • Options
    mwgoodmwgood Member Posts: 293
    A good way to play with PPP is by using your serial interfaces - if you have them.

    You can link them together by using a crossover serial cable - or a DCE & DTE cable.
  • Options
    exkor5000exkor5000 Member Posts: 54 ■■□□□□□□□□
    this data is actually from a Boson CCNP simulator.
    It's pretty nice to practice actually.

    I will try that.

    Thanks
  • Options
    hectorjhrdzhectorjhrdz Member Posts: 127
    .........check out the routing statements....
Sign In or Register to comment.