unable to telnet into 2500 router

kadshahkadshah Senior MemberFrom NYC but currently living in ThailandPosts: 385Member ■■■□□□□□□□
I'm trying to telnet into my router from my PC. When I ping i'm able to get a reply but also get destination net unreachable message. When I telnet i get "could not open connection to the host, on port 23 connect failed" message.
I already added the line vty 0 4 and the login command and then set the password.
Is there anything else I forgot to add? I'm wondering if the software or hardware firewall might be preventing me from logging in haven't check that yet. Any suggestions?


-kaj

Comments

  • mwgoodmwgood Posts: 293Member
    The destination unreachable is suspicious.

    I would investigate why you are not able to ping the router.

    Are you using a crossover ethernet cable between PC & router?
  • marlon23marlon23 Posts: 164Member
    first you'll have to check L2 connectivity, after your ping command (no matter result) check output of "arp -a" command (command promt in WinXP).
    if you are alble to optain router mac address.

    Check your IP addressing, router and PC should be on same subnet (for home purpose and simplicity) if not, be sure you have correct gateway configured on the PC/NIC/TCP&IP, and a correct route to pc from router (if not on same subnet)

    Network unreachable means that there is no route to that subnet. I would suspect incorrect IP adressing.


    Provide more details. (physical connection, ip addresses...)
    LAB: 7609-S, 7606-S, 10008, 2x 7301, 7204, 7201 + bunch of ISRs & CAT switches
  • hectorjhrdzhectorjhrdz Posts: 127Member
    check in the router:

    line vty 0 4
    pass xxxxxx
    login

    check in your pc

    firewall config

    Ipsec features
    ip addressing (subnet masks epecially)

    layer 1 problem
    >cross over cable
  • kadshahkadshah Senior Member From NYC but currently living in ThailandPosts: 385Member ■■■□□□□□□□
    here's my setup.

    PC1 (192.168.1.10icon_cool.gif is connected to my 1900 switch.
    (192.168.1.9)
    My 1900 switch is connected to my Linksys router (192.168.1.1)

    Both routers are connected to my switch.

    Router 1 ethernet 0 has the ip address 192.168.1.11 255.255.255.0
    Serial 0 has ip address 192.168.10.2 255.255.255.0

    Router 2 E 0 has ip address 192.168.1.12 255.255.255.0
    Serial 0 192.168.10.3 255.255.255.0

    I already configured line vty with login and password.

    is it an incorrect ip address?

    -k
  • hectorjhrdzhectorjhrdz Posts: 127Member
    what is the ip of your default gw set in your pc?

    check that carefuly and perform the traceroute command to know where you get stoped

    and i recommend you to check your ip addressing scheme
  • Danman32Danman32 Posts: 1,243Member
    The redundant paths between the two routers bothers me a little. Shouldn't cause problems for straight pings/telnet though, since the PCs are directly attached (network-wise, not ohysically)
  • YankeeYankee Posts: 157Member
    which address are you trying to telnet to? My guess is the serial and it is probably up/down. Telnet to the ethernet address of either router (provided they are up/up) and that should work. If not it would be a host problem.


    Yankee
  • kadshahkadshah Senior Member From NYC but currently living in ThailandPosts: 385Member ■■■□□□□□□□
    it's working now. I wish I could say what the problem was but I can't.
    What I did was first to bypass the switch and linksys router and plug in the cable directly from my PC to my router. From there I was able to telnet.
    So the router is configure correctly for telnet connectivity. Then I unplugged the cable from the back of the router and plugged it into the switch the original setup I had and everything worked. Maybe the cable was loose don't know. Thanks anyway for your input.
  • kadshahkadshah Senior Member From NYC but currently living in ThailandPosts: 385Member ■■■□□□□□□□
    i guess it couldn't be a loose cable as i thought cause i wouldn't have got the message "destination unreachable". What do you think?
  • Danman32Danman32 Posts: 1,243Member
    You would probably get a different error in your pings, but 'destination unreachable' is possible, especially if the wiring error is between the router and the switch.
  • kadshahkadshah Senior Member From NYC but currently living in ThailandPosts: 385Member ■■■□□□□□□□
    k thanks again.
  • david_rdavid_r Posts: 112Member
    kaj,
    Something to think about: How many replies did you get to your pings when you originally had the problem?

    I'll disagree with Danman. It takes a L3 device receiving an ICMP packet to send back a destination unreachable reply.
  • Danman32Danman32 Posts: 1,243Member
    And you will get that L3 device if the break between the host and the router is from the switch and the router.

    I experimented by disconnecting my PC and trying to ping. I got 'hardware error'. Fair enough, even the OS is smart enough to tell you the cable is unplugged.
    So I plugged it back in and it took quite a few seconds for it to get an IP. I tried a ping during that time, and got a couple 'destination unreachable's until the IP was aquired.
  • kadshahkadshah Senior Member From NYC but currently living in ThailandPosts: 385Member ■■■□□□□□□□
    I'm trying to recreate the problem by pinging first to my serial port ip address (router A turned on) it's possible that by mistake i could have first ping to my serial ip instead of my ethernet ip. I got "reply from 10.32.41.1: Destination net unreachable" with 4 replies. This was the original message on my first post but curiously I also got the same message from (router B turned off).
    Then i ping my ethernet ip address (router A turned on) and got 4 replies.
    So i'm assuming that the problem was i had telneted to my serial ip address by mistake instead of my ethernet ip address. I couldn't recreate the "could not open connection to the host, on port 23 connect failed" message.
Sign In or Register to comment.