Options

Router Config Question

leilani07leilani07 Member Posts: 6 ■□□□□□□□□□
There are 3 Routers(A, B, and C) each at their own site. RIP is the routing protocol. Clocking is provided on the S0 interface. Subnet mask is the default subnet mask.

Router IP address are:

A
E0 192.168.3.1
SO 192.168.5.1

B
E0 192.168.8.1
SO 192.168.11.1
S1 192.168.5.2

C
E0 192.168.13.2
S1 192.168.11.2

There are no connectivity between each router. Must reconfigure each router. The answer is below.
Config on Router A

enable
password
config terminal
interface ethernet 0
ip address 192.168.3.1 255.255.255.0
no shutdown
exit
interface serial 0
ip address 192.168.5.1 255.255.255.0
no shutdown
exit
router rip
network 192.168.3.1
network 192.168.5.1
Ctrl-Z
copy run start


Config on Router B

enable
password
config t
interface ethernet 0
ip address 192.168.8.1 255.255.255.0
no shutdown
exit
interface serial 0
ip address 192.168.11.1 255.255.255.0
clock rate 64000
no shutdown
exit
interface serial 1
ip address 192.168.5.2 255.255.255.0
no shutdown
exit
router rip
network 192.168.8.0
network 192.168.11.0
network 192.168.5.0
Ctrl-Z
copy run start


Configuration for Router C

enable
password
config t
interface ethernet 0
ip address 192.168.13.2 255.255.255.0
no shutdown
exit
interface seriel 1
ip address 192.168.11.2 255.255.255.0
no shutdown
exit
router rip
network 192.168.13.0
network 192.168.11.0
Ctrl-Z
copy run start


My questions is:

I don't understand what you advertise when configuring the RIP protocol. Router A is advertising it's own ip's but B and C looks like it is advertising its network address. Also how do you know which router you configure the clock rate?

Thanks

Comments

  • Options
    mwgoodmwgood Member Posts: 293
    leilani07 wrote:
    I don't understand what you advertise when configuring the RIP protocol. Router A is advertising it's own ip's but B and C looks like it is advertising its network address. Also how do you know which router you configure the clock rate?

    Advertise the connected networks for each router. Router A should also be advertising its 2 Class C networks.

    Clock rate is configured on the DCE.
  • Options
    david_rdavid_r Member Posts: 112
    You are advertising the classful network. That's a typo on router A -- actually not a typo as you can enter your network that way. However, if you had a real router in front of you, you would see that whatever you type in with the network xxx.xxx.xxx.xxx command, the router will show the command as the classful network for the IP you entered.

    In otherwords, you can type "network 192.168.2.10" but if you look at the running config, you will see the command as "network 192.168.2.0."

    Something of note that seems to be glossed over in routing protocol explanations is that with the network command not only are you telling the router to advertise that network via the routing protocol but you are also telling the router to use whatever interface is in that network to do the advertising.

    In your example, you could have the following configuration for rip
    router rip
    network 192.168.3.1
    ctrl-Z
    and the B and C routers would never know about that network because A would only be sending RIP multicasts out of ethernet 0 and not out serial 0.


    DCE ports supply clocking. If you issue show controllers serial X you will see this on the router that needs to be supplying clockrate info.

    buffer size 1524 HD unit 0, V.35 DCE cable, clockrate 4000000

    The other router will have a DTE connection.
    buffer size 1524 HD unit 1, V.35 DTE cable
  • Options
    leilani07leilani07 Member Posts: 6 ■□□□□□□□□□
    So even though router A advertised network as network 192.168.3.1 and
    network 192.168.5.1 they will still only see it as a classfull address? So could I just use the commands:
    network 192.168.5.0 instead of .1
    and
    network 192.168.3.0 instead of .1

    Is that correct?

    You also said the clocking is provided on the DCE.....well with this example it says that clocking is provided on the S0 interface. I have an S0 interface on both router A and router B. Why do I just add clocking on router B and why not router A. Or why not router A and not router B?

    Thanks
  • Options
    Danman32Danman32 Member Posts: 1,243
    Depends in your configuration which is set as the DCE in HW, and which is set as DCE. With a serial crossover, the crossover would set one as DCE and one as DTE.
  • Options
    leilani07leilani07 Member Posts: 6 ■□□□□□□□□□
    That makes sense...what about the advertising question?
  • Options
    EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    The cable will dictate which side is DTE and which is DCE.You can type the following command on each router to find out which side is the dce and once you know that you can set the clock on that side.
    Router#show controller s 0 , the output will say either DCE,DTE or no cable.
    then on the dce side do
    router(config-if)#clock rate 64000
    router(config-if)#bandwidth 64

    Try and get into the habit of setting the bandwidth of the interface when you setup the clockrate.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • Options
    pr3d4t0rpr3d4t0r Member Posts: 173
    First of all. U always advertise class C network in rip, not specific ip address. Read david_r's post carefully. RIP is a classfull routing protocol.

    Because Router's A s0 is connected with Router B s1 not s0.

    Router's B s0 is connected with Router's C s1.

    So u need to issue clock rate 64000 in router's B s0.

    I think the bandwith command is used only in igrp-eigrp not in rip.
  • Options
    EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    pr3d4t0r wrote:
    I think the bandwith command is used only in igrp-eigrp not in rip.

    Yes, rip uses hop count.But bandwidth can come into play with other config options outside of routing protocols.Its a good idea to set bandwidth at the same time when setting clocking so you dont forget about it later.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • Options
    david_rdavid_r Member Posts: 112
    leilani07 wrote:
    So even though router A advertised network as network 192.168.3.1 and
    network 192.168.5.1 they will still only see it as a classfull address? So could I just use the commands:
    network 192.168.5.0 instead of .1
    and
    network 192.168.3.0 instead of .1

    Is that correct?
    You can type whatever you want. The command that will be put into the config will be network xxx.xxx.xxx.0 for a class C, network xxx.xxx.0.0 for a class B and network xxx.0.0.0 for a class A.
    You also said the clocking is provided on the DCE.....well with this example it says that clocking is provided on the S0 interface. I have an S0 interface on both router A and router B. Why do I just add clocking on router B and why not router A. Or why not router A and not router B
    Because it is plain wrong. Nice eye for detail. You need one end of a serial connection to provide clocking. On a WAN, this is normally provided by the telco gear. In your example, whichever port has the DCE connection (either S0 on router A or S1 on router B) needs to provide clocking.

    Like was said previously, issue the show controllers command on your connected serial interfaces to determine which one has the DCE connection. That'll be the one that needs the clock rate command.

    If you are using DCE/DTE cables on synchronous serial ports, put a ? after clock rate to see what the maximum is. Mine will run at 4000000. It's a real bummer to tftp an IOS at 64000.
  • Options
    leilani07leilani07 Member Posts: 6 ■□□□□□□□□□
    First, In regards to the DCE/DTE. This came from a simulator. It did not state which side was the DTE or which was the DCE. It had a picture with all three routers and in parenthesis was DCE on both routers on the S0 interface. So for testing purposes, how should I tackle this?


    Second, for advertising, I do understand now that they advertise classful addresses. However router A advertised the full address of 192.168.3.1 Is this wrong since the subnet is 255.255.255.0. Should it have just advertised 192.168.3.0?

    sorry for all the questions....but I just was to make sure I understand this....and thanks for all the replys
  • Options
    david_rdavid_r Member Posts: 112
    leilani07 wrote:
    So for testing purposes, how should I tackle this?
    Buy some routers :D The ports that were labeled DCE would need the clock rate command in order for communication to happen between the routers.

    Second, for advertising, I do understand now that they advertise classful addresses. However router A advertised the full address of 192.168.3.1 Is this wrong since the subnet is 255.255.255.0. Should it have just advertised 192.168.3.0?
    The joy of simulators. A real router would have shown "network 192.168.3.0" in the config and that is what would be advertised.

    Here's debug output from a real router as I add the network into RIP

    Router(config)#do debug ip rip data
    RIP database events debugging is on
    Router(config)#router rip
    Router(config-router)#network 192.168.3.1
    Router(config-router)#
    *Mar 7 05:10:57.390: RIP-DB: redist 192.168.3.0/24(metric 0, last interface Loopback2) to RIP
    *Mar 7 05:10:57.394: RIP-DB: Get redist for network 192.168.3.0
    *Mar 7 05:10:57.398: RIP-DB: adding 192.168.3.0/24 (metric 0) via 0.0.0.0 on Loopback2 to RIP database
    *Mar 7 05:10:57.402: RIP-DB: add 192.168.3.0/24 (metric 0) via 0.0.0.0 on Loopback2 (donot_age)


    and here is what the config looks like
    router rip
    version 2
    network 172.16.0.0
    network 192.168.1.0
    network 192.168.2.0
    network 192.168.3.0
    no auto-summary


    Keep asking questions if it still isn't clear.
Sign In or Register to comment.