Options

the route question.

the_return_of_the_Ringthe_return_of_the_Ring Member Posts: 119
frame_relay.JPG

above is my lab. the following is the "sh ip route" result on middle2520. the last part would be all configurations for each device in the lab.

the lab works fine. my question is about the route.

see I already define a P-to-P from middle2520 to c2620, why the routes(on middle2520) to my vlans must go through bottom2520, then to c2620?

the last question is about optimization. I know i'm new, I just put all the possible command together to make the network work. give me some advises to let the commands look professional.

middle2520#sh ip route
save some space here.....

Gateway of last resort is 192.168.0.1 to network 0.0.0.0

172.18.0.0/16 is variably subnetted, 7 subnets, 2 masks
O 172.18.40.0/24 [110/129] via 172.18.1.2, 00:54:21, Serial1.1
O 172.18.30.0/24 [110/129] via 172.18.1.2, 00:54:21, Serial1.1
C 172.18.20.0/30 is directly connected, Serial0
O 172.18.10.0/24 [110/129] via 172.18.1.2, 00:54:21, Serial1.1
C 172.18.2.0/24 is directly connected, Serial1.2
O 172.18.3.0/24 [110/128] via 172.18.1.2, 00:54:21, Serial1.1
C 172.18.1.0/24 is directly connected, Serial1.1
C 192.168.0.0/24 is directly connected, Ethernet0
S* 0.0.0.0/0 [1/0] via 192.168.0.1


middle2520
save some space.....
!
no aaa new-model
ip subnet-zero
ip host c2620 172.18.3.2
ip host bottom2520 172.18.1.2
ip host top2924 172.18.10.2
ip host top2520 172.18.20.1
!
!
!
!
interface Ethernet0
ip address dhcp
ip nat outside
no ip route-cache
!
interface Serial0
ip address 172.18.20.2 255.255.255.252
ip nat inside
no ip route-cache
!
interface Serial1
no ip address
encapsulation frame-relay
no ip route-cache
frame-relay lmi-type cisco
!
interface Serial1.1 point-to-point
ip address 172.18.1.1 255.255.255.0
ip nat inside
no ip route-cache
frame-relay interface-dlci 100
!
interface Serial1.2 point-to-point
ip address 172.18.2.1 255.255.255.0
ip nat inside
no ip route-cache
frame-relay interface-dlci 101
!
interface Serial2
no ip address
shutdown
!
router ospf 10
log-adjacency-changes
network 172.18.0.0 0.0.255.255 area 0
network 192.168.0.0 0.0.0.255 area 0
!
ip nat inside source list 2 interface Ethernet0 overload
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.1
!
!
access-list 2 permit 172.18.0.0 0.0.255.255
!

bottom2520
!
no aaa new-model
ip subnet-zero
ip host c2620 172.18.3.2
ip name-server 192.168.0.1
!
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
no ip address
shutdown
no fair-queue
!
interface Serial1
no ip address
encapsulation frame-relay
frame-relay lmi-type cisco
!
interface Serial1.1 point-to-point
ip address 172.18.1.2 255.255.255.0
frame-relay interface-dlci 120
!
interface Serial1.3 point-to-point
ip address 172.18.3.1 255.255.255.0
frame-relay interface-dlci 122
!
interface Serial2
no ip address
shutdown
!
interface Serial3
no ip address
shutdown
!
interface BRI0
no ip address
shutdown
!
router ospf 3
log-adjacency-changes
network 172.18.0.0 0.0.255.255 area 0
!
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 172.18.1.1
!

c2620
!
ip subnet-zero
!
!
ip name-server 192.168.0.1
ip dhcp excluded-address 172.18.10.1 172.18.10.50
ip dhcp excluded-address 172.18.30.1 172.18.30.50
ip dhcp excluded-address 172.18.40.1 172.18.40.50
!
ip dhcp pool 172.18.10.0/24
network 172.18.10.0 255.255.255.0
dns-server 192.168.0.1
default-router 172.18.10.1
!
ip dhcp pool 172.18.30.0/24
network 172.18.30.0 255.255.255.0
default-router 172.18.30.1
dns-server 192.168.0.1
!
ip dhcp pool 172.18.40.0/24
network 172.18.40.0 255.255.255.0
dns-server 192.168.0.1
default-router 172.18.40.1
!
call rsvp-sync
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation isl 1
ip address 172.18.10.1 255.255.255.0
no ip redirects
!
interface FastEthernet0/0.3
encapsulation isl 3
ip address 172.18.30.1 255.255.255.0
no ip redirects
!
interface FastEthernet0/0.4
encapsulation isl 5
ip address 172.18.40.1 255.255.255.0
no ip redirects
!
interface Serial0/0
no ip address
encapsulation frame-relay
frame-relay lmi-type cisco
!
interface Serial0/0.1 point-to-point
ip address 172.18.2.2 255.255.255.0
frame-relay interface-dlci 150
!
interface Serial0/0.3 point-to-point
ip address 172.18.3.2 255.255.255.0
frame-relay interface-dlci 152
!
router ospf 5
log-adjacency-changes
network 172.18.0.0 0.0.255.255 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0.3
ip http server
!
!
!
dial-peer cor custom
!
!

top2520
!
no aaa new-model
ip subnet-zero
ip name-server 192.168.0.1
!
frame-relay switching
!
!
!
interface Ethernet0
no ip address
no ip route-cache
shutdown
!
interface Serial0
no ip address
encapsulation frame-relay
no ip route-cache
clockrate 64000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 120 interface Serial1 100
frame-relay route 122 interface Serial2 152
!
interface Serial1
no ip address
encapsulation frame-relay
no ip route-cache
clockrate 64000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 100 interface Serial0 120
frame-relay route 101 interface Serial2 150
!
interface Serial2
no ip address
encapsulation frame-relay
clockrate 64000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 150 interface Serial1 100
frame-relay route 152 interface Serial0 122
!
interface Serial3
ip address 172.18.20.1 255.255.255.252
clockrate 64000
!
interface BRI0
no ip address
no ip route-cache
shutdown
!
router ospf 8
log-adjacency-changes
network 172.18.0.0 0.0.255.255 area 0
!
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 Serial3
!

Comments

  • Options
    EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    Because you FR mappings are all over the place.Trace the Ip addresses through the FR switch and see where they end up.Its better to keep the source and destination dlcis the same to make it easier to troubleshoot.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • Options
    Danman32Danman32 Member Posts: 1,243
    When making diagrams, please put IP's at the associated interfaces. At least put the network IP on the link, then the unique host octets by the interfaces. Otherwise, we all have to do that ourselves to make sense of it all, by going through your configs and obtaining the interface information.
  • Options
    sorry, dan, the diagram updated.

    ps: i did trace from middle2520 to one vlan, the route is middle2520 - bottom2520 - c2620 - the vlan.
  • Options
    Danman32Danman32 Member Posts: 1,243
    Probably not related to your problem, but your diagram has a duplicate network.
    Network from S0 of middle (with no IP listed) to S3 of Top has network 18.10.0, as does netowork from F0/0 of C2620

    Diagram should show network coming out of S0 to be 18.20.0 with S0 having IP of .20.2
  • Options
    Danman32 wrote:
    Probably not related to your problem, but your diagram has a duplicate network.
    Network from S0 of middle (with no IP listed) to S3 of Top has network 18.10.0, as does netowork from F0/0 of C2620

    Diagram should show network coming out of S0 to be 18.20.0 with S0 having IP of .20.2

    my bad, sorry. it's updated now.
  • Options
    Danman32Danman32 Member Posts: 1,243
    Is Middle-S0/Top-S3 link strictly for purpose of managing the frame switch?
  • Options
    no, that link is just for telnetting the F.R. switch.

    i guess the link between middles0 and tops3 has nothing to do with the F.R network. What confused me is, when i "trace" any vlan from middle2520, the route will alway go through bottom2520 to c2620, then the vlan. If middle2520 has a pvc directly to c2620(see middle2520's route table), why bother going to bottom2520?
  • Options
    lwwarnerlwwarner Member Posts: 147 ■■■□□□□□□□
    madonion wrote:
    If middle2520 has a pvc directly to c2620(see middle2520's route table), why bother going to bottom2520?
    Because you don't actually have a valid pvc between middle2520 & c2620. Hint: use these commands to troubleshoot your FR setup...
    show frame-relay map
    show frame-relay pvc
    show frame-relay route
    
    ...and don't assume you have a routing problem when you haven't verified data link/network layer connectivity.
  • Options
    Danman32Danman32 Member Posts: 1,243
    I'm not very experienced with frame relay, especially frame relay switching but:

    interface Serial1
    no ip address
    encapsulation frame-relay
    no ip route-cache
    clockrate 64000
    frame-relay lmi-type cisco
    frame-relay intf-type dce
    frame-relay route 100 interface Serial0 120
    frame-relay route 101 interface Serial2 150
    !
    interface Serial2
    no ip address
    encapsulation frame-relay
    clockrate 64000
    frame-relay lmi-type cisco
    frame-relay intf-type dce
    frame-relay route 150 interface Serial1 100
    frame-relay route 152 interface Serial0 122

    Shouldn't the bold items match? S2 seems to have the wrong destination DLCI.
  • Options
    lwwarnerlwwarner Member Posts: 147 ■■■□□□□□□□
    Danman32 wrote:
    Shouldn't the bold items match? S2 seems to have the wrong destination DLCI.
    Exactly! Which means that madonion never had a working pvc between middle2520 & c2620. This illustrates the importance of actually verifying layer 1/2/3 connectivity before wasting time troubleshooting routing issues.

    As ed_the_lad mentioned above, it also shows that using a more reasonable dlci scheme can help prevent this type of mistake.
  • Options
    Danman32Danman32 Member Posts: 1,243
    Well, he had it in one direction, but not the other. Or does the mismatch break it completely for frames in both directions?
  • Options
    sorry, just came back.

    u guys are right. I mis-typed the dlci #. whew, my bad. Now it's going right. Thanks guys!
Sign In or Register to comment.