Options

simple rip question

hankooknarahankooknara Inactive Imported Users Posts: 24 ■□□□□□□□□□
in ccna icnd book page 163, ther is a example of rip

interface ethernet 0
ip address 10.1.2.3 255.255.255.0
interface ethernet 1
ip address 172.16.1.1 255.255.255.0
interface tokenring 0
ip address 10.1.3.3 255.255.255.0
interface serial 0
ip address 199.1.1.1 255.255.255.0
interface serial 1
ip address 199.1.2.1 255.255.255.0
!
router rip
network 10.0.0.0
network 199.1.1.0


book say that command(under router rip)

network 10.0.0.0

will cover token0 and ethernet0

Can someone tell me why 10.0.0.0 will cover 10.1.2 and 10.1.3 on 255.255.255.0 ??

Big thanks in advance.

Comments

  • Options
    hankooknarahankooknara Inactive Imported Users Posts: 24 ■□□□□□□□□□
    I guess I will just answer my own question as I see that books says

    the network command requires a network number, not a subnet number...

    which means

    10.0.0.0 is for network A

    and 10.1.2.3 255.255.255.0

    and 10.1.3.3 255.255.255.0's both network portion is still 10(network A)

    someone can correct me if I was wrong.. tx.
  • Options
    dmafteidmaftei Member Posts: 83 ■■□□□□□□□□
    someone can correct me if I was wrong..
    You were not wrong.
    BSEE, MSCS
    www.maftei.net
  • Options
    david_rdavid_r Member Posts: 112
    Do you know why it is that way? You aren't studying to pass a test, you are studying to build a foundation.

    If you had the foundation, you'd know that RIP is a classful protocol and that classful protocols <fill in the blank>.
  • Options
    EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    david_r wrote:
    If you had the foundation, you'd know that RIP is a classful protocol and that classful protocols <fill in the blank>.

    If you had the foundation, you'd know that RIP is a classful protocol and that classful protocols are nice but not as nice as classless protocols.

    Ripv2 is classless and is advertised using the major classful network.Eigrp is
    classless and can be specified using the major network,so not really a good
    explanation as to why.Just remember that for distance vector type protocols you advertise using the classful network number.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • Options
    hankooknarahankooknara Inactive Imported Users Posts: 24 ■□□□□□□□□□
    thank u all for your help~~
  • Options
    david_rdavid_r Member Posts: 112
    oddly enough, I don't see either RIPV2 or EIGRP in his config or his question. But thanks for playing.
  • Options
    LorisLoris Member Posts: 1 ■□□□□□□□□□
    david_r wrote:
    Do you know why it is that way? You aren't studying to pass a test, you are studying to build a foundation.

    If you had the foundation, you'd know that RIP is a classful protocol and that classful protocols <fill in the blank>.

    Your reasoning is flawed. network statements are always classed as is the case with RIPv2 & EIGRP... it has nothing to do with the routing protocol itself.
Sign In or Register to comment.