Options

RIPv1 Advertising Question

mzinzmzinz Member Posts: 328
One question had me pretty confused. It was asking how to specify some networks through RIP v1.

There were a few options on how to advertise the two addresses. They were something like:
10.33.0.1
10.65.0.1

A.
router rip
network 10.0.0.0

B.
router rip
network 10.33.0.0
network 10.65.0.0

C.
router rip
network 10.33.0.1 255.0.0.0
network 10.65.0.1 255.0.0.0

Right when I read the question I was like "oh, ok, I'll just select 10.0.0.0 because we all know that RIP is classful". But then I read further, and it wanted me to SELECT 2.

I can't remember all of the options. But what other options ARE THERE other than just 'network 10.0.0.0' for advertising 2 Class A addresses?
_______LAB________
2x 2950
2x 3550
2x 2650XM
2x 3640
1x 2801

Comments

  • Options
    Danman32Danman32 Member Posts: 1,243
    You can use B. It's a bit redundant I agree, but it will work, and may be clearer to someone reading the config.
  • Options
    mzinzmzinz Member Posts: 328
    What a retarded question.

    I knew that, and its so simple, but the question started making me think that you could advertise the two as seperate networks or something. I wasn't even thinking redundant.. all that came to my head was "Why would someone advertise both of them"
    _______LAB________
    2x 2950
    2x 3550
    2x 2650XM
    2x 3640
    1x 2801
  • Options
    mp3spymp3spy Member Posts: 86 ■■□□□□□□□□
    Yea I think b too. RIP does not advertise the MASK either.....So B would fall into that category..
    Ok CCNA BREAK IS OVER, TIME FOR CCSP!!!
  • Options
    david_rdavid_r Member Posts: 112
    2501R2(config)#router rip
    2501R2(config-router)#network 10.0.0.0
    2501R2(config-router)#
    RIP: sending general request on Loopback2 to 255.255.255.255
    RIP: sending general request on Loopback3 to 255.255.255.255
    RIP: sending v1 update to 255.255.255.255 via Loopback2 (10.33.0.1)
         subnet  10.65.0.0, metric 1
    RIP: Update contains 1 routes
    RIP: Update queued
    RIP: Update sent via Loopback2
    RIP: sending v1 update to 255.255.255.255 via Loopback3 (10.65.0.1)
         subnet  10.33.0.0, metric 1
    RIP: Update contains 1 routes
    RIP: Update queued
    RIP: Update sent via Loopback3
    
  • Options
    EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    The only correct answer here is A, Rip is advertised by using the "network"command followed by the classful major network.
    In your case all examples include a 10.x.x.x major network so all interfaces that have 10 in the first octet will enable rip and advertise all 10.x.x.x subnets, except the local interface subnet.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • Options
    david_rdavid_r Member Posts: 112
    ed, Danman,
    Can you explain that again? If I enter the following code,
    2501R2(config)#router rip
    2501R2(config-router)#no network 10.0.0.0
    2501R2(config-router)#network 10.33.0.0
    2501R2(config-router)#network 10.65.0.0
    
    My config will be:
    router rip
     network 10.0.0.0
    
  • Options
    EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    A value of 10 in the first octet indicates a class A network, therefore the classful network address for a class A network is the number in the first octet followed by 0's in the last 3 octets.
    Rip,Ripv2 and IGRP are classified using the classful network address.So if you have afew interfaces with 10.x.x.x addresses you just have to specify the 10.0.0.0 classful address.If there are some interfaces you dont want the routing protocol enabled on you can use the "passive-interface" command, but these interfaces will still have their ip addresses included in the updates.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • Options
    zero-g-smithzero-g-smith Member Posts: 41 ■■□□□□□□□□
    I think Ed_the_lad meant the correct answer was A. Not B.
    Correct me if Im wrong.
  • Options
    EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    I think Ed_the_lad meant the correct answer was A. Not B.
    Correct me if Im wrong.
    Yep, i didnt see that icon_smile.gif, i'll do a quick edit!
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
Sign In or Register to comment.