Dialer Profiles
Am i missing something here?
I have 2 routers A and B connected via a bri interface.
On rA i have created 2 dialer interfaces,dialer1 and dialer2.
On rB i have also created 2 dialer interfaces dialer1 and dialer2.On rtb dialer1 is in dialer pool 1 and dialer2 is in dialer pool 2.If i config the bri on Rb in dialer pool 1, i can successfull ping from rA using dialer int 1. Likewise if i configure dialer pool 2 on rB's bri, i can ping from rA's dialer 2 interface.
Now,if i configure the bri on rB to be in both dialer pool 1 and dialer pool 2 simultaneously, no pings are successful.
How do i get the receiver Rb to differentiate between the incoming calls, i would like bri 0/0:0 to use int dialer1 and bri0/0:1 to use int dialer2?
Is this possible? i thaught "dialer remote-hostname" would do the trick but it still doesnt work!
There is no problem with the dialer interfaces in the outgoing direction as the routes are mapped to the specific dialer interface.
I have 2 routers A and B connected via a bri interface.
On rA i have created 2 dialer interfaces,dialer1 and dialer2.
On rB i have also created 2 dialer interfaces dialer1 and dialer2.On rtb dialer1 is in dialer pool 1 and dialer2 is in dialer pool 2.If i config the bri on Rb in dialer pool 1, i can successfull ping from rA using dialer int 1. Likewise if i configure dialer pool 2 on rB's bri, i can ping from rA's dialer 2 interface.
Now,if i configure the bri on rB to be in both dialer pool 1 and dialer pool 2 simultaneously, no pings are successful.
How do i get the receiver Rb to differentiate between the incoming calls, i would like bri 0/0:0 to use int dialer1 and bri0/0:1 to use int dialer2?
Is this possible? i thaught "dialer remote-hostname" would do the trick but it still doesnt work!
There is no problem with the dialer interfaces in the outgoing direction as the routes are mapped to the specific dialer interface.
Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
Comments
-
EdTheLad Member Posts: 2,111 ■■■■□□□□□□Below are the configs, if i remove the a dialer pool statement from RouteC a ping from RouterB will succeed.If left as is, ping fails and the call gets disconnected by RouterB.
This is doing my head in!
RouterB#show runn
Building configuration...
Current configuration : 1705 bytes
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$xdAH$lzIwa9MIK6tqFib3Bew6l/
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
isdn switch-type basic-net3
!
!
username Microsoft password 0 cisco
username Siemens password 0 cisco
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Ethernet0/0
no ip address
no ip mroute-cache
shutdown
half-duplex
!
interface BRI0/0
no ip address
encapsulation ppp
dialer pool-member 1 priority 200
dialer pool-member 2 priority 200
isdn switch-type basic-net3
isdn point-to-point-setup
ppp authentication chap
!
interface Serial1/0
no ip address
!
interface Serial1/1
ip address 150.5.6.22 255.255.255.252
clock rate 64000
!
interface Serial1/2
no ip address
shutdown
!
interface Serial1/3
ip address 150.5.6.13 255.255.255.252
!
interface Dialer1
description Microsoft
ip address 13.0.0.1 255.255.255.252
encapsulation ppp
dialer pool 1
dialer remote-name Microsoft
dialer idle-timeout 40
dialer string 21
dialer-group 1
ppp authentication chap
!
interface Dialer2
description Siemens
ip address 14.0.0.1 255.255.255.252
encapsulation ppp
dialer pool 2
dialer remote-name Siemens
dialer idle-timeout 40
dialer string 21
dialer-group 1
ppp authentication chap
!
ip http server
ip classless
ip route 120.0.0.0 255.255.255.0 Dialer2
ip route 180.0.0.0 255.255.255.252 Dialer1
!
!
dialer-list 1 protocol ip permit
!
!
dial-peer cor custom
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
RouterB#
RouterC#show runn
Building configuration...
Current configuration : 1478 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterC
!
enable secret 5 $1$.WPi$ZOMYxK5qbMUApu3CVEssN/
!
username RouterB password 0 cisco
ip subnet-zero
!
!
no ip domain-lookup
!
ip audit notify log
ip audit po max-events 100
!
isdn switch-type basic-net3
call rsvp-sync
!
!
interface Loopback0
ip address 180.0.0.1 255.255.255.255
!
interface Loopback11
ip address 120.0.0.1 255.255.255.255
!
interface Ethernet0/0
no ip address
half-duplex
!
interface Serial0/0
no ip address
shutdown
!
interface BRI0/0
no ip address
encapsulation ppp
dialer pool-member 1 priority 100
dialer pool-member 2 priority 50
isdn switch-type basic-net3
ppp authentication chap
!
interface Serial0/1
ip address 15.0.0.2 255.255.255.252
clockrate 64000
!
interface Dialer1
description Microsoft
ip address 13.0.0.2 255.255.255.252
encapsulation ppp
dialer pool 1
ppp authentication chap
ppp chap hostname Microsoft
!
interface Dialer2
description Siemens
ip address 14.0.0.2 255.255.255.252
encapsulation ppp
dialer pool 2
ppp authentication chap
ppp chap hostname Siemens
!
ip classless
ip http server
!
dialer-list 1 protocol ip permit
!
!
dial-peer cor custom
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
exec-timeout 0 0
logging synchronous
no login
!
endNetworking, sometimes i love it, mostly i hate it.Its all about the $$$$ -
mikej412 Member Posts: 10,086 ■■■■■■■■■■Have you tried the debug dialer events command? packets?
Lets see -- you should have the directly connect subnets when you show the routing table.... interesting traffic... isdn status active.... sounds like the interfaces are up...
Yep, sounds like time for a debug. dialer first, then maybe q931... and then q921 as a last resort.
Looking at the config makes me happy I don't have to deal with ISDN for the R&S CCIE Lab.:mike: Cisco Certifications -- Collect the Entire Set! -
EdTheLad Member Posts: 2,111 ■■■■□□□□□□I've done all the debugs q931,q921,dialer but no useful info, just tells me normal disconnect.The call goes through perfectly, ppp establishes, isdn comes up i.e. setup,call proceeding,connect,connect ack and straight away the call gets disconnected.
Funny, i've now got what i wanted working from RouterC to RouterB so i know its possible.Now i'm just gonna have to compare and see where the problem is.
Both routers have identical configs, RouterB is on Rel12.3 ,RouterC Rel12.2, i'm putting this one down to ios bug.Only about 5 hrs wasted!Networking, sometimes i love it, mostly i hate it.Its all about the $$$$ -
cisco_trouble Inactive Imported Users Posts: 78 ■■□□□□□□□□ok ed_the_lad. Look hard at your config, only thing thats missing is the "max-link minimum" or "max-link maximum" command. The maximum default is set at 255 and minimum is set at 0. I'm not sure if the default is "max-link minimum". This commands sets the minimum and maximum B channels to be used in a dialer pool. Check it out if it works."To strive, to seek, to find, and not to yield."
-
Yankee Member Posts: 157yes, try putting both in same pool and look at using max-links 1 command. While you won't control which channel connects where you should get one call on each
Yankee -
EdTheLad Member Posts: 2,111 ■■■■□□□□□□Yankee wrote:yes, try putting both in same pool and look at using max-links 1 command. While you won't control which channel connects where you should get one call on each
Yankee
Yes, i tryed alot of things yesterday switching pools etc but still didnt work.Since it worked in the other direction i know what i wanted to implement is possible so i've moved on to other things at the moment.I will revisit this again in afew days.Maybe its down to not doing clear dialer int, but ill check it later.Networking, sometimes i love it, mostly i hate it.Its all about the $$$$