HSRP Problems

HumperHumper Member Posts: 647
Ok so here are some hsrp problems i am having

Here is my setup,

2 - Cisco 1721 routers (RouterA and RouterB)
1 - Cisco 2924 (Hostname SwitchB)
1 - Cisco 3550 (Hostname SwitchA)

Diagram:
RouterA           RouterB
   |                |
   |                |
SwitchA -------- SwitchB
Router A is connected via trunk (with logical subinterfaces) to SwitchA by straight through. RouterA f0 -> f0/1 on Switch A

Switch A and Switch B are connected via trunk on port f0/2 (both sides) by crossover.

SwitchB has a trunk to RouterB (same as RouterA)

There are two VLAN's 1 & 2. RouterA is the HSRP active for VLAN 1 and standby for VLAN 2. RouterB is HSRP standby for VLAN 1 and active for VLAN 2.

Here is configs:

RouterA
!
!
interface FastEthernet0
 no ip address
 speed auto
!
interface FastEthernet0.1
 encapsulation dot1Q 1 native
 ip address 10.0.0.2 255.255.255.0
 standby 1 ip 10.0.0.1
 standby 1 priority 120
 standby 1 preempt
!
interface FastEthernet0.2
 encapsulation dot1Q 2
 ip address 10.0.2.2 255.255.255.0
 standby 2 ip 10.0.2.1
 standby 2 priority 100
 standby 2 preempt
!
interface Serial0
 no ip address
 no fair-queue
!
ip classless

SwitchA:
hostname SwitchA
!
!
ip subnet-zero
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk


SwitchB: Same thing as above


RouterB
hostname RouterB
!
!
ip subnet-zero
!
!
!
!
interface FastEthernet0
 no ip address
 speed auto
 full-duplex
!
interface FastEthernet0.1
 encapsulation dot1Q 1 native
 ip address 10.0.0.3 255.255.255.0
 standby 1 ip 10.0.0.1
 standby 1 priority 100
 standby 1 preempt
!
interface FastEthernet0.2
 encapsulation dot1Q 2
 ip address 10.0.2.3 255.255.255.0
 standby 2 ip 10.0.2.1
 standby 2 priority 120
 standby 2 preempt
 standby 2 track Serial0 40
!
interface Serial0
 no ip address
 shutdown
 no fair-queue
!
ip classless
no ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end


Here is some debug from RouterB
RouterB#
00:19:38: HSRP: Fa0.2 Grp 2 Hello  out 10.0.2.3 Active  pri 80 vIP 10.0.2.1
00:19:39: HSRP: Fa0.1 Grp 1 Hello  out 10.0.0.3 Active  pri 100 vIP 10.0.0.1
00:19:39: HSRP: Fa0.1 Grp 1 Coup   in  10.0.0.2 Active  pri 120 vIP 10.0.0.1
00:19:39: HSRP: Fa0.1 Grp 1 Active: j/Coup rcvd from higher pri router (120/10.0.0.2)
00:19:39: HSRP: Fa0.1 Grp 1 Active router is 10.0.0.2, was local
00:19:39: HSRP: Fa0.1 Grp 1 Active -> Speak
00:19:39: %HSRP-6-STATECHANGE: FastEthernet0.1 Grp 1 state Active -> Speak
00:19:39: HSRP: Fa0.1 Redirect adv out, Passive, active 0 passive 1
00:19:39: HSRP: Fa0.1 API MAC address update
00:19:39: HSRP: Fa0.2 API MAC address update
00:19:39: HSRP: Fa0.1 API MAC address update
00:19:39: HSRP: Fa0.2 API MAC address update
00:19:39: HSRP: Fa0.1 Grp 1 Hello  out 10.0.0.3 Speak   pri 100 vIP 10.0.0.1
00:19:39: HSRP: Fa0.1 Grp 1 Hello  in  10.0.0.2 Active  pri 120 vIP 10.0.0.1
00:19:41: HSRP: Fa0.2 Grp 2 Hello  out 10.0.2.3 Active  pri 80 vIP 10.0.2.1
00:19:42: HSRP: Fa0.1 Grp 1 Hello  out 10.0.0.3 Speak   pri 100 vIP 10.0.0.1
00:19:44: HSRP: Fa0.2 Grp 2 Hello  out 10.0.2.3 Active  pri 80 vIP 10.0.2.1
00:19:45: HSRP: Fa0.1 Grp 1 Hello  out 10.0.0.3 Speak   pri 100 vIP 10.0.0.1
00:19:47: HSRP: Fa0.2 Grp 2 Hello  out 10.0.2.3 Active  pri 80 vIP 10.0.2.1
00:19:48: HSRP: Fa0.1 Grp 1 Hello  out 10.0.0.3 Speak   pri 100 vIP 10.0.0.1
00:19:49: HSRP: Fa0.1 Grp 1 Speak: d/Standby timer expired (unknown)
00:19:49: HSRP: Fa0.1 Grp 1 Standby router is local
00:19:49: HSRP: Fa0.1 Grp 1 Speak -> Standby
00:19:49: HSRP: Fa0.1 Grp 1 Hello  out 10.0.0.3 Standby pri 100 vIP 10.0.0.1
00:19:49: HSRP: Fa0.1 Grp 1 Standby: c/Active timer expired (10.0.0.2)
00:19:49: HSRP: Fa0.1 Grp 1 Active router is local, was 10.0.0.2
00:19:49: HSRP: Fa0.1 Grp 1 Standby router is unknown, was local
00:19:49: HSRP: Fa0.1 Grp 1 Standby -> Active
00:19:49: %HSRP-6-STATECHANGE: FastEthernet0.1 Grp 1 state Standby -> Active
00:19:49: HSRP: Fa0.1 Redirect adv out, Active, active 1 passive 1
00:19:49: HSRP: Fa0.1 Grp 1 Hello  out 10.0.0.3 Active  pri 100 vIP 10.0.0.1
00:19:50: HSRP: Fa0.2 Grp 2 Hello  out 10.0.2.3 Active  pri 80 vIP 10.0.2.1
00:19:52: HSRP: Fa0.1 Grp 1 Hello  out 10.0.0.3 Active  pri 100 vIP 10.0.0.1
00:19:53: HSRP: Fa0.2 Grp 2 Hello  out 10.0.2.3 Active  pri 80 vIP 10.0.2.1unde
00:19:55: HSRP: Fa0.1 Grp 1 Hello  out 10.0.0.3 Active  pri 100 vIP 10.0.0.1
00:19:56: HSRP: Fa0.2 Grp 2 Hello  out 10.0.2.3 Active  pri 80 vIP 10.0.2.1

This happens on both RouterA and RouterB. Ive tried changing timers, shut / no shut, Ive checked my configs, ran debug..etc I have no idea what is wrong? Can someone shed light?
Now working full time!

Comments

  • mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    What's the problem? Is router B staying active for standbye group 2 when the serial 0 is shut down? Is neither router seeing hellos from the other router in standbye group 2?

    Not sure what you mean by the same thing happens on Router A -- does it think it's active for both standby groups?

    Are both routers losing hello packets from the other router?

    After the MAC address update, it looks like B got one last hello from A.... and then that was it -- KaBlewy!



    When you have only one standby group, does it work?

    If you take the 2924 out and just use the 3550, does it work?

    If the answer to those 2 questions is yes, then the 2924 is the problem (it can only support one standby group).

    Token-Ring on different rings and Ethernet on "low-end" switches had some problems with HSRP that the use-bia command was introduced to fix.

    The other option -- get rid of Token-Ring and low-end Ethernet switches is my preferred solution (if that was the problem).
    :mike: Cisco Certifications -- Collect the Entire Set!
  • EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    Here is some debug from RouterB
    00:19:39: HSRP: Fa0.1 Grp 1 Hello  out 10.0.0.3 Speak   pri 100 vIP 10.0.0.1
    00:19:39: HSRP: Fa0.1 Grp 1 Hello  in  10.0.0.2 Active  pri 120 vIP 10.0.0.1
    00:19:41: HSRP: Fa0.2 Grp 2 Hello  out 10.0.2.3 Active  pri 80 vIP 10.0.2.1
    00:19:42: HSRP: Fa0.1 Grp 1 Hello  out 10.0.0.3 Speak   pri 100 vIP 10.0.0.1
    00:19:44: HSRP: Fa0.2 Grp 2 Hello  out 10.0.2.3 Active  pri 80 vIP 10.0.2.1
    00:19:45: HSRP: Fa0.1 Grp 1 Hello  out 10.0.0.3 Speak   pri 100 vIP 10.0.0.1
    00:19:47: HSRP: Fa0.2 Grp 2 Hello  out 10.0.2.3 Active  pri 80 vIP 10.0.2.1
    00:19:48: HSRP: Fa0.1 Grp 1 Hello  out 10.0.0.3 Speak   pri 100 vIP 
    

    This happens on both RouterA and RouterB. Ive tried changing timers, shut / no shut, Ive checked my configs, ran debug..etc I have no idea what is wrong? Can someone shed light?

    Really you should ask a question aswell as providing the info icon_smile.gif
    Anyway i'm assuming the problem you have is RB is going active for group 1 ? From the debug output you can see that RB has stopped receiving hellos from RA for grp1.It seems you have lost communications to RA altogether, why? i dont know.Place a pc on switch B and continuously ping RA, see what happens.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • HumperHumper Member Posts: 647
    I will answer the questions above when I get home tonight, thanks for the help so far
    Now working full time!
Sign In or Register to comment.