GLBP
Couple questions regarding the weighting in GLBP.
When you want to configure tracking for an interface, you use the following command:
Now the object number, is that the same as the group number or just a locally significant unrelated value? From what I understand this command set the interface you want to track and what you want it to track (line protocol / ip routing) correct??
Now to setup the weighting value on the interface you use the
So this command sets the initial weighting value and the upper and lower thresholds? I am confused what they mean by upper and lower. Can someone elaborate for me?
The next command is
This specifies the object / interface to be tracked? The decrement means to decrement the weighting value we set above? So if the initial weighting was 100 and we said to decrement by 5 if there was a problem with the interface/routing it would drop to 95? How does this work with the upper and lower thresholds?
What I just read in another document is that there are 4 ways to load balance (none,weighted,host dependent, round-robin)..So I guess what I am discussing above is the weighted way of load balancing.
Here are the documents I was referencing:
http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a008042fb97.html
http://www.cisco.com/en/US/products/ps6600/products_data_sheet0900aecd803a546c.html
When you want to configure tracking for an interface, you use the following command:
track <object-number> interface <type & #> {line protocol | ip routing}
Now the object number, is that the same as the group number or just a locally significant unrelated value? From what I understand this command set the interface you want to track and what you want it to track (line protocol / ip routing) correct??
Now to setup the weighting value on the interface you use the
glbp <group #> weighting <maximum> [lower <value>] [upper <upper>]
So this command sets the initial weighting value and the upper and lower thresholds? I am confused what they mean by upper and lower. Can someone elaborate for me?
The next command is
glbp <group#> weighting track <object#> decrement <value>
This specifies the object / interface to be tracked? The decrement means to decrement the weighting value we set above? So if the initial weighting was 100 and we said to decrement by 5 if there was a problem with the interface/routing it would drop to 95? How does this work with the upper and lower thresholds?
What I just read in another document is that there are 4 ways to load balance (none,weighted,host dependent, round-robin)..So I guess what I am discussing above is the weighted way of load balancing.
Here are the documents I was referencing:
http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a008042fb97.html
http://www.cisco.com/en/US/products/ps6600/products_data_sheet0900aecd803a546c.html
Now working full time!
Comments
-
HELLZxPHADER Member Posts: 74 ■■□□□□□□□□heres my glbp configuration from a while back, its better to keep glbp simple, it works well as long as u got preempt enabled, i think lol.
2620(cable), 2621(dsl) both are connected to the switch(3550) on vlan4 and below are the cfg for each.
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname 2620
!
no aaa new-model
ip subnet-zero
ip cef
!
!
ip dhcp pool cable
import all
network 10.6.6.0 255.255.255.0
default-router 10.6.6.253
dns-server 4.2.2.2 4.2.2.3
!
!
!
!
track 30 interface Ethernet1/0 line-protocol
delay up 30
!
!
interface FastEthernet0/0
description to 3550 vlan4
ip address 10.6.6.253 255.255.255.0
ip nat inside
duplex auto
speed auto
glbp 1 ip 10.6.6.254
glbp 1 priority 105
glbp 1 weighting 200
glbp 1 weighting track 30
glbp 1 forwarder preempt delay minimum 0
!
interface Serial0/2
ip address 20.20.20.1 255.255.255.252
clock rate 4000000
!
interface Ethernet1/0
description cable
ip address xx.xx.xx.70 255.255.255.0
ip nat outside
half-duplex
!
!
ip nat pool cable xx.xx.xx.70 xx.xx.xx.70 netmask 255.255.255.0
ip nat inside source static tcp 10.6.6.16 3389 interface Ethernet1/0 3389
ip nat inside source route-map cable pool cable overload
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 xx.xx.xx.1
!
!
access-list 1 permit 10.6.6.0 0.0.0.255
route-map cable permit 10
match ip address 1
match interface Ethernet1/0
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
password 7 11011C091B08
login
!
!
end
___________________________________________________________
version 12.3
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname 2621
!
enable password 7 030C5E070A15
!
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
no ip dhcp conflict logging
!
ip dhcp pool dsl
import all
network 10.6.6.0 255.255.255.0
default-router 10.6.6.252
dns-server 4.2.2.2 4.2.2.3
!
!
!
!
track 30 interface FastEthernet0/0 line-protocol
!
!
interface FastEthernet0/0
description dsl
ip address 192.168.1.97 255.255.255.0
ip nat outside
duplex auto
speed auto
!
interface Serial0/0
ip address 20.20.20.2 255.255.255.252
!
interface FastEthernet0/1
description to 3550 vlan4
ip address 10.6.6.252 255.255.255.0
ip nat inside
duplex auto
speed auto
glbp 1 ip 10.6.6.254
glbp 1 weighting 110
glbp 1 weighting track 30
glbp 1 forwarder preempt delay minimum 0
!
!
ip nat pool dsl 192.168.1.97 192.168.1.97 netmask 255.255.255.0
ip nat inside source static tcp 10.6.6.1 3389 interface FastEthernet0/0 3389
ip nat inside source route-map dsl pool dsl overload
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
!
access-list 1 permit 10.6.6.0 0.0.0.255
route-map dsl permit 10
match ip address 1
match interface FastEthernet0/0
!
!
line con 0
line aux 0
line vty 0 4
exec-timeout 16 0
privilege level 15
password 7 1211001B1E11
login
!
!
end
___________________________________________________________
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname 3550
!
!
no aaa new-model
ip subnet-zero
ip routing
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
interface FastEthernet0/1
switchport mode dynamic desirable
!
interface FastEthernet0/25
switchport access vlan 4
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/26
switchport access vlan 4
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/27
switchport access vlan 4
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/28
switchport access vlan 4
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/29
switchport access vlan 4
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/30
switchport access vlan 4
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/31
switchport access vlan 4
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/32
switchport access vlan 4
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/48
no switchport
no ip address
!
interface GigabitEthernet0/1
switchport mode dynamic desirable
!
interface GigabitEthernet0/2
switchport mode dynamic desirable
!
interface Vlan1
no ip address
!
interface Vlan2
no ip address
!
interface Vlan3
no ip address
!
interface Vlan4
ip address dhcp
!
interface Vlan5
no ip address
!
ip classless
ip http server
ip http secure-server
!
!
!
control-plane
!
!
line con 0
line vty 0 4
privilege level 15
password 7 060E0A2D4054
login
line vty 5 15
privilege level 15
password 7 10460C15090D
login
!
end -
HELLZxPHADER Member Posts: 74 ■■□□□□□□□□And herez the show glbp from both routers.
2620#show glbp
FastEthernet0/0 - Group 1
State is Active
8 state changes, last state change 1d12h
Virtual IP address is 10.6.6.254
Hello time 3 sec, hold time 10 sec
Next hello sent in 0.876 secs
Redirect time 600 sec, forwarder time-out 14400 sec
Preemption disabled
Active is local
Standby is 10.6.6.252, priority 100 (expires in 8.568 sec)
Priority 105 (configured)
Weighting 200 (configured 200), thresholds: lower 1, upper 200
Track object 30 state Up decrement 10
Load balancing: round-robin
There are 2 forwarders (1 active)
Forwarder 1
State is Active
7 state changes, last state change 13:52:33
MAC address is 0007.b400.0101 (default)
Owner ID is 00d0.5861.5920
Redirection enabled
Preemption enabled, min delay 0 sec
Active is local, weighting 200
Arp replies sent: 17
Forwarder 2
State is Listen
4 state changes, last state change 14:15:19
MAC address is 0007.b400.0102 (learnt)
Owner ID is 0002.fd94.63c1
Redirection enabled, 597.348 sec remaining (maximum 600 sec)
Time to live: 14397.348 sec (maximum 14400 sec)
Preemption enabled, min delay 0 sec
Active is 10.6.6.252 (primary), weighting 110 (expires in 7.344 sec)
Arp replies sent: 12
2620#20.20.20.2
Trying 20.20.20.2 ... Open
___________________________________________________________
User Access Verification
Password:
2621#show glbp
FastEthernet0/1 - Group 1
State is Standby
1 state change, last state change 14:15:20
Virtual IP address is 10.6.6.254
Hello time 3 sec, hold time 10 sec
Next hello sent in 1.692 secs
Redirect time 600 sec, forwarder time-out 14400 sec
Preemption disabled
Active is 10.6.6.253, priority 105 (expires in 7.996 sec)
Standby is local
Priority 100 (default)
Weighting 110 (configured 110), thresholds: lower 1, upper 110
Track object 30 state Up decrement 10
Load balancing: round-robin
There are 2 forwarders (1 active)
Forwarder 1
State is Listen
2 state changes, last state change 13:52:44
MAC address is 0007.b400.0101 (learnt)
Owner ID is 00d0.5861.5920
Time to live: 14397.992 sec (maximum 14400 sec)
Preemption enabled, min delay 0 sec
Active is 10.6.6.253 (primary), weighting 200 (expires in 7.988 sec)
Forwarder 2
State is Active
1 state change, last state change 14:15:30
MAC address is 0007.b400.0102 (default)
Owner ID is 0002.fd94.63c1
Preemption enabled, min delay 0 sec
Active is local, weighting 110
2621#exit -
mikej412 Member Posts: 10,086 ■■■■■■■■■■ModemHumper wrote:Is there something I am missing in my post?
No -- it just brings back bad memories....
If you talk about "luck of the draw" on questions -- I was very unlucky with this blueprint topic. Someone else who took the exam not long after me was lucky.
# Describe and configure gateway redundancy protocols (e.g. HSRP and GLBP)
This could be a topic to double check your troubleshooting techniques.... and maybe pay extra attention to debug commands.:mike: Cisco Certifications -- Collect the Entire Set!