Options

EIGRP & no auto-summary

J2tehkJ2tehk Member Posts: 24 ■□□□□□□□□□
Here is my lab.

PC1---->Router1=S0/0====S0/0=Router2<----PC2

I am running EIRGP and have a discontiguous network.

PC's are in a 10.1.0.0/24 network
Router Serial 0/0 are in a 192.168.2.148/30 network

Problem: I cannot get PC1 to ping to PC2.

My configs below:
hostname R1
!
!
ip subnet-zero
!
!
no ip domain-lookup
!
ip dhcp pool fccu2
network 10.1.1.0 255.255.255.0
default-router 10.1.1.1
lease 15 15 1
!
!
!
!
interface Ethernet0/0
ip address 10.1.1.1 255.255.255.0
ip nat inside
half-duplex
!
interface Serial0/0
ip address 192.168.2.149 255.255.255.252
ip nat outside
no fair-queue
clockrate 64000
!
router eigrp 10
network 10.1.0.0 0.0.255.255
network 192.168.0.0 0.0.255.255
no auto-summary
no eigrp log-neighbor-changes
!
ip nat inside source list 10 interface Serial0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0
ip http server
ip pim bidir-enable
!
access-list 10 permit any log
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end

*****************

hostname R2
!
!
ip subnet-zero
!
!
no ip domain-lookup
!
ip dhcp pool fccu1
network 10.1.2.0 255.255.255.0
default-router 10.1.2.1
lease 15 15 1
!
!
!
!
interface Ethernet0/0
ip address 10.1.2.1 255.255.255.0
ip nat inside
half-duplex
!
interface Serial0/0
ip address 192.168.2.150 255.255.255.252
ip nat outside
no fair-queue
!
router eigrp 10
network 10.1.0.0 0.0.255.255
network 192.168.0.0 0.0.255.255
no auto-summary
no eigrp log-neighbor-changes
!
ip nat inside source list 10 interface Serial0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0
ip http server
ip pim bidir-enable
!
access-list 10 permit any log
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end

Comments

  • Options
    EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    Since you have no auto-summary, eigrp will support discontiguous networks so there is no need for nat.Also since you are natting the 10.x.x.x network you dont need to advertise it in eigrp.
    The problem you have is with your access-list,change it to
    access-list 10 permit 10.1.0.0 0.0.255.255
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • Options
    J2tehkJ2tehk Member Posts: 24 ■□□□□□□□□□
    Thanks! That took care of the problem.
Sign In or Register to comment.