Options

Lab problem - ADSL Router - Static Routing SOLVED

cambeicambei Member Posts: 62 ■■■□□□□□□□
Ok, I am trying to connect to the internet as follows:

Will post image of setup once moved to my other pc.
EDIT: DONE
poss-setup.gif


I am trying to connect to the internet from PC1, via R3, R2, R1 and the rubbish Safecom ADSL router.

Problem is that I can ping outside addresses from R1, which I am guessing is because the ADSL router can forward the packets to R1's e0 interface because it is just seen as a host on the same network.

However, trying to ping an internet side IP from any of the other routers or hosts, it times out and a traceroute stops at the ADSL router. I have tried putting in static routes in the ADSL router, but they don't seem to do anything. The Safecom does not support any routing protocols, just static routing (from the user manual, it looks like it has to have an entry per host, not per network).

Here are the configs:

R1:
Current configuration : 714 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
enable secret 5 $1$6PKp$94mQAsa5ajeaS1dsPzchw/
!
ip subnet-zero
no ip domain-lookup
ip host R2 172.16.10.2
ip host R3 172.16.20.1
!
!
!
!
!
interface Ethernet0
 ip address 192.168.123.1 255.255.255.0
!
interface Serial0
 ip address 172.16.10.1 255.255.255.0
 clock rate 72000
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
router rip
 version 2
 network 172.16.0.0
 network 192.168.123.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.123.254
ip http server
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

R2
Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname R2
!
enable secret 5 $1$poL1$5u1Jk6aXroPlj0.1o8srN0
!
no ip domain-lookup
ip host R1 172.16.10.1
ip host R3 172.16.20.1
!
interface Ethernet0
 ip address 192.168.0.1 255.255.255.0
!
interface Serial0
 ip address 172.16.10.2 255.255.255.0
!
interface Serial1
 ip address 172.16.20.2 255.255.255.0
!
interface BRI0
 no ip address
 shutdown
!
router rip
 version 2
 network 172.16.0.0
 network 192.168.0.0
!
no ip classless
ip route 0.0.0.0 0.0.0.0 172.16.10.1
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end


R3
Current configuration : 813 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$MOmo$86tGwGUXeZaLv6xucTBKt/
!
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
ip host R2 172.16.20.2
ip host R1 172.16.10.1
!
!
!
!
!
interface Ethernet0/0
 ip address 192.168.1.1 255.255.255.0
 half-duplex
!
interface Serial0/0
 ip address 172.16.20.1 255.255.255.0
 clock rate 72000
!
interface BRI0/0
 no ip address
 encapsulation hdlc
 shutdown
!
interface Serial0/1
 no ip address
 shutdown
!
router rip
 version 2
 network 172.16.0.0
 network 192.168.1.0
!
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.123.254
!
!
!
line con 0
line aux 0
line vty 0 5
 password cisco
 login
!
!
end


Safecom Adsl routing table:
ID 	Destination 	Subnet Mask 	Gateway 	Hop 	Enable
1 	192.168.0.2	255.255.255.0	192.168.123.1  2	   T
2 	192.168.1.2     255.255.255.0   192.168.123.1  3           T


Any help would be much appreciated![/img]

Comments

  • Options
    loboernestoloboernesto Member Posts: 94 ■■□□□□□□□□
    Hi cambei, can you post your safecom model so I can have a look at the manual?.
    Remember that this adsl routers usually are firewall aswell so there maybe some filtering aswell.
    What I can see from your post is that safecom doesn't know about R2 and R3 networks. Once the ping gets to safecom it doesn't know where to route it back to.
    The configuration of your static routes in the safecom router sounds a bit weird... You should be able to use some dynamic routing protocol, every router supports RIPv1 at least...
    If you post your model name maybe I can have a look at the manual and find something you are missing.

    I would configure RIP in your cisco routers anyway and have a default route in R1 poiting to 192.168.123.254 which would then be distributed to R2 and R3 if you can then enable RIP in your safecom router it should be up and running.

    cheers
  • Options
    EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    I'm assuming your internal routing is correct as you didnt provide any "show ip route" info.If i were you i would setup nat overload on the R1 interface facing the adsl router.Probably the isp has an access-list blocking traffic from every source other than the 192.168.0.1 address.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • Options
    cambeicambei Member Posts: 62 ■■■□□□□□□□
    Thanks for the replies guys. I know some info that was needed was lacking but I was at the end of my tether and just wanted to switch everything off.

    The Safecom model is SWBR5400 and everything I have read about it, including the user manual states that it only supports Static Routing and it only has a web configuration interface which only has the option for a static routing table.

    I will include that output of sh ip route later as I am currently at work (came in an hour early ebcause my clock was set wrong icon_evil.gif ) and don't have remote access to my lab.

    Just to clarify, the Safecom router is connect to an ADSL modem and it has an IP on the WAN side of 80.*.*.* (can't remember exactly) so I don't think my ISP does filter anything other 192.168.0.* traffic or whatever.

    I was thinking this might be a NAT/PAT problem more than just a routing problem.
  • Options
    NetwurkNetwurk Member Posts: 1,155 ■■■■■□□□□□
    I know this doesn't solve your immediate problem, but at some point you may want to use a Cisco router in place of your Safecom.

    I use a Cisco 2514 as my ASDL router (using IOS 12.3 IP Plus). Works perfectly.
  • Options
    cambeicambei Member Posts: 62 ■■■□□□□□□□
    Yeah the thought has crossed my mind, however, I live in a rental house with 4 other people. The Safecom router is in one of the other person's room.

    The safecom router is roughly hand-sized, whereas to use a 2514 I would need a seperate switch as well which is a lot of noise and space to ask someone to put up with so I can study the CCNA. hehe.

    I may upgrade to a better Home router though, one that at least support RIP.
  • Options
    cambeicambei Member Posts: 62 ■■■□□□□□□□
    Sorted.

    It was a NAT issue. The Safecom router only provides NAT for the 255.255.255.0 network it is configured to run on, so I think subnetting it would work also, but for now I am using PAT overload to connect.
Sign In or Register to comment.