A 2 Switch Scenario

thesemantheseman Posts: 230Member
Hello everyone, was hoping someone has run into this before (or at least has heard of it)

The Setup:
-Two 2950 Switches (both with IOS 12.1 or later) (I'll call them S1 and S2)
-Switches are connected by two crossover cables for redundancy (S1 FA2--S2 FA2 and S1 FA3 - S2 FA3).
-Spanning tree is set to default mode (pvst)
-Left priorty to defaults, so lowest mac was selected as root (S1)

So heres the problem: Using the sh spanning-tree command on S1 - all ports fwding (as expected). Using the command on S2, FA3 was set to alternate - blocking (also as expected). However, link light does not change to amber. Using a 2950 and an older switch, same results, only the light goes amber. Is this expected?

Comments

  • bmaurobmauro Posts: 307Member
    I *believe* that on my switches ports that were in blocking mode were still green. I can't be 100% sure, but I did spend quite a bit of time on STP and that is the best I can remember.
  • thesemantheseman Posts: 230Member
    Thanks for the reply, what model of switch did you use?
  • bmaurobmauro Posts: 307Member
    (2) 2950
    (1) 3550

    I can test this tonight if no one else answers - but to the best of my memory my blocking ports were still green.
  • thesemantheseman Posts: 230Member
    You don't have to go out of your way to test it out for me!! But thank you all the same!! I am going to try a bit bigger setup today, with a couple more switches to see if I can figure it out.
  • pr3d4t0rpr3d4t0r Posts: 173Member
    icon_rolleyes.gif
  • thesemantheseman Posts: 230Member
    Well today I tried a 4 2950 switch setup, redundant paths et all. While some ports are classified as blocking in a sh spanning-tree, the LEDs stayed green.

    Once again, I switched one of the 2950s for a 2820 and the LEDs on the blocking ports turned amber.

    Who knows!
  • NetwurkNetwurk Posts: 1,155Member
    On some models, the ports will go amber with a 10Mbps link and green with a 100Mbps link. The 2820 is an old model with 10Mbps ports, so that may be your answer
  • thesemantheseman Posts: 230Member
    Netwurk-

    That is not an answer I had really considered!! I tried different STP modes, redundant paths like you wouldn't believe, among other things. I did quite a bit of searching on the issue and had yet to come up with a reasonable cause.

    Thanks for easing my mind, issues like that are ones that I need an answer to! lol
Sign In or Register to comment.