Timeout expired

mario.peischlmario.peischl Member Posts: 1 ■□□□□□□□□□

My problem is, that I'm starting a script that changes columntypes of a huge data base. After a little time, I'm getting an error message "Timeout expired", after that a rollback happens.

What's the matter. I tried to manipulate the Lock time (SET LOCK_TIMEOUT 10000000) with same result.

Please help!

(sorry for my english, I'm a german nativ speaker)

nice wishes


  • 2lazybutsmart2lazybutsmart Member Posts: 1,119
    Mario, the error you're getting isn't a deadlock timeout error, it's a Query timeout error. This, you've probably guessed when nothing happened after you changed the LOCK_TIMEOUT to 1000000.

    You might be getting a deadlock timeout, which is not lilkely, but if you are indeed being thrown off the deadlock stack as a victim, then, give you transaction a HIGH priority. which means, when a victim is choesn, it'll be the other person. kinda funny.

    If you're problem is a Quer Timeout, on the other hand, try increasing the query timeout value. the defualt is 0, which means no timeout. but if the value has been altered by another person, you should check it out and alter it back to zero. You can do that by going to tools in the query analyzer, then options, then connections. you;ll see a textbox for the query timeout property.

    lemme know if you're still stuck. and BTW, why are u altering column definitions through a query? a transactional query, i reckon?

    Exquisite as a lily, illustrious as a full moon,
    Magnanimous as the ocean, persistent as time.
Sign In or Register to comment.