rip v2 and subnets
oliverw
Member Posts: 64 ■■□□□□□□□□
in CCNA & CCENT
Hi People,
I'm trying to connect two router together using a back to back cable. Both serial interfaces show as being up but i am unable to ping. I know i'm wasting ip addresses using these subnets but its bugging me now. Any hints would be appreciated.
hostname CoCC-2523
!
enable secret 5 $1$C3EC$4e4i3wBdtsqMeG7KNIKan.
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Serial0
description Connected to Orchard House Router
ip address 192.168.1.33 255.255.255.240
encapsulation ppp
no fair-queue
clockrate 64000
!
!
Code taken out
!
interface Serial9
no ip address
shutdown
!
interface TokenRing0
no ip address
shutdown
!
interface BRI0
no ip address
shutdown
!
router rip
version 2
network 192.168.1.0
!
ip classless
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
password 7 110E100B1017195D5679
login
!
end
hostname Orchard
!
enable secret 5 $1$y08S$XY03fvZ9Oi0MesYZQXTan/
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Ethernet0
ip address 192.168.1.10 255.255.255.240
!
interface Serial0
description DTE end Orchard - Boston
ip address 192.168.1.17 255.255.255.240
encapsulation ppp
!
interface BRI0
no ip address
shutdown
!
router rip
version 2
network 192.168.1.0
!
ip classless
no ip http server
ip pim bidir-enable
!
!
!
line con 0
line vty 0 4
password 7 03035205010A33181B5F
login
!
end
I'm trying to connect two router together using a back to back cable. Both serial interfaces show as being up but i am unable to ping. I know i'm wasting ip addresses using these subnets but its bugging me now. Any hints would be appreciated.
hostname CoCC-2523
!
enable secret 5 $1$C3EC$4e4i3wBdtsqMeG7KNIKan.
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Serial0
description Connected to Orchard House Router
ip address 192.168.1.33 255.255.255.240
encapsulation ppp
no fair-queue
clockrate 64000
!
!
Code taken out
!
interface Serial9
no ip address
shutdown
!
interface TokenRing0
no ip address
shutdown
!
interface BRI0
no ip address
shutdown
!
router rip
version 2
network 192.168.1.0
!
ip classless
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
password 7 110E100B1017195D5679
login
!
end
hostname Orchard
!
enable secret 5 $1$y08S$XY03fvZ9Oi0MesYZQXTan/
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Ethernet0
ip address 192.168.1.10 255.255.255.240
!
interface Serial0
description DTE end Orchard - Boston
ip address 192.168.1.17 255.255.255.240
encapsulation ppp
!
interface BRI0
no ip address
shutdown
!
router rip
version 2
network 192.168.1.0
!
ip classless
no ip http server
ip pim bidir-enable
!
!
!
line con 0
line vty 0 4
password 7 03035205010A33181B5F
login
!
end
Comments
-
james_ Member Posts: 97 ■■□□□□□□□□Looks like your routers serial interfaces are not n the same subnet, they need to be. Your first router is in the 32 subnet, the second one is in the 16 subnet. Try changing the second router to an IP address of something like 192.168.1.34
-
oliverw Member Posts: 64 ■■□□□□□□□□Ah it comes together now, i think i was just reading the books wrong. Thanks for your help guys as always.
-
Kaminsky Member Posts: 1,235Also, from my studies, isn't it better to use /30 subnet so you get 4 ip addresses and 2 usable for serial - one for each end? Or are you doing classfull?
Not trying to be a smart@$$ but from the prep questions I have seen for sim questions on serial, it's usually the /30 stated which is why I ask.Kam. -
Humper Member Posts: 647Kaminsky wrote:Also, from my studies, isn't it better to use /30 subnet so you get 4 ip addresses and 2 usable for serial - one for each end? Or are you doing classfull?
Not trying to be a smart@$$ but from the prep questions I have seen for sim questions on serial, it's usually the /30 stated which is why I ask.
/30's are used for serial P2P interfaces. It is good practice but not absolutely necessary. You could use a /8 if you really wanted too.Now working full time! -
DirtySouth Member Posts: 314 ■□□□□□□□□□/30 would be the most efficient, but not absolutely necessary.
-
Kaminsky Member Posts: 1,235DirtySouth wrote:/30 would be the most efficient, but not absolutely necessary.
Aye but I'm never going to be the same person I was before finally learning subnetting and those weeks spent on subnetquestions.com when bored at work...
I've been mentally scarred !!!!Kam.