Options

Setting encapsulation on Trunks?

davetuckdavetuck Member Posts: 15 ■□□□□□□□□□
Hi there, wonder if someone could shed some light on this...

I have a 2600 router connected to a 2900 switch, I'm trying to set up 'Router on a Stick' to route between Vlans with subinterfaces but get the following:

**********************************************************
RouterA(config)#
RouterA(config)#int fa0/0.1
RouterA(config-subif)#ip address 192.168.11.1 255.255.255.0

% Configuring IP routing on a LAN subinterface is only allowed if that
subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q,
or ISL vLAN.

RouterA(config-subif)#encap?
% Unrecognized command

**********************************************************

Its really strange, I've tried preconfiguring the switch end as a trunk port but to no avail. As you can see I can t change the encapsulation type at all.

Thanks for any suggestions as to why this wont work.

Dave

Comments

  • Options
    WebmasterWebmaster Admin Posts: 10,292 Admin
    Probably because you don't have an IOS with IPplus on the router.
  • Options
    sexion8sexion8 Member Posts: 242
    show your vlan config on the switch
    "Everything we hear is an opinion, not a fact. Everything we see is a perspective, not the truth." - Marcus Aurelius
  • Options
    ~Scott~~Scott~ Member Posts: 19 ■□□□□□□□□□
    Try this:


    RouterA(config)#int fa0/0
    RouterA(config-subif)# no ip address
    RouterA(config-subif)#no shutdown
    RouterA(config-subif)#exit

    RouterA(config)#
    RouterA(config)#int fa0/0.1
    RouterA(config-subif)# encapsulation dot1q 1 (the number 1 represents the VLAN number)
    RouterA(config-subif)#ip address 192.168.11.1 255.255.255.0

    I just got back from an INTRO/ICND Bootcamp... this is how we configured Router on a Stick......

    Good luck!
  • Options
    davetuckdavetuck Member Posts: 15 ■□□□□□□□□□
    sexion8 wrote:
    show your vlan config on the switch

    Thaks for your help guys, I still cant get it to work, I was trying to get fa0/1 to be the trunk port, when I set it using 'switchport mode trunk' it disappears from vlan 1, although I'm fairly sure its got to be set to trunking mode, I can also set the encapsulation to dot1q on the switch, but not on the router subinterface.

    Here is the vlan config on the switch:

    witch01#sh vlan
    VLAN Name Status Ports
    ----


    1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4,
    Fa0/5, Fa0/6, Fa0/7, Fa0/8,
    Fa0/9, Fa0/10, Fa0/11, Fa0/12,
    Fa0/13, Fa0/14, Fa0/15, Fa0/16,
    Fa0/17, Fa0/18, Fa0/19, Fa0/20,
    Fa0/21, Fa0/22, Fa0/23, Fa0/24
    2 sales active
    3 marketing active
    4 accounting active
    1002 fddi-default active
    1003 token-ring-default active
    1004 fddinet-default active
    1005 trnet-default active

    VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
    ----





    ----


    1 enet 100001 1500 - - - - - 1002 1003
    2 enet 100002 1500 - - - - - 0 0
    3 enet 100003 1500 - - - - - 0 0
    4 enet 100004 1500 - - - - - 0 0
    1002 fddi 101002 1500 - - - - - 1 1003
    1003 tr 101003 1500 1005 - - - srb 1 1002
    1004 fdnet 101004 1500 - - 1 ibm - 0 0
    1005 trnet 101005 1500 - - 1 ibm - 0 0
    Switch01#

    Here is the running config, still on the switch:

    Switch01#sh run
    Building configuration...

    Current configuration:
    !
    version 12.0
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Switch01
    !
    enable secret 5 $1$a30s$hBqeXiE4aG1izavi6lCcg0
    !
    !
    !
    !
    !
    !
    ip subnet-zero
    ip host switch02 192.168.11.60
    ip host routerb 192.168.22.6
    ip host routera 192.168.22.5
    !
    !
    !
    interface FastEthernet0/1
    switchport trunk encapsulation dot1q
    !
    interface FastEthernet0/2
    !
    interface FastEthernet0/3
    !
    interface FastEthernet0/4
    !
    interface FastEthernet0/5
    !
    interface FastEthernet0/6
    !
    interface FastEthernet0/7
    !
    interface FastEthernet0/8
    !
    interface FastEthernet0/9
    !
    interface FastEthernet0/10
    !
    interface FastEthernet0/11
    !
    interface FastEthernet0/12
    !
    interface FastEthernet0/13
    !
    interface FastEthernet0/14
    !
    interface FastEthernet0/15
    !
    interface FastEthernet0/16
    !
    interface FastEthernet0/17
    !
    interface FastEthernet0/18
    !
    interface FastEthernet0/19
    !
    interface FastEthernet0/20
    !
    interface FastEthernet0/21
    !
    interface FastEthernet0/22
    !
    interface FastEthernet0/23
    !
    interface FastEthernet0/24
    !
    interface VLAN1
    ip address 192.168.11.50 255.255.255.0
    no ip directed-broadcast
    no ip route-cache
    !
    ip default-gateway 192.168.11.1
    !
    line con 0
    transport input none
    stopbits 1
    line vty 0 4
    password cisco
    login
    line vty 5 15
    password cisco
    login
    !
    end

    Switch01#

    ********************************************************
  • Options
    davetuckdavetuck Member Posts: 15 ■□□□□□□□□□
    ~Scott~ wrote:
    Try this:


    RouterA(config)#int fa0/0
    RouterA(config-subif)# no ip address
    RouterA(config-subif)#no shutdown
    RouterA(config-subif)#exit

    RouterA(config)#
    RouterA(config)#int fa0/0.1
    RouterA(config-subif)# encapsulation dot1q 1 (the number 1 represents the VLAN number)
    RouterA(config-subif)#ip address 192.168.11.1 255.255.255.0

    I just got back from an INTRO/ICND Bootcamp... this is how we configured Router on a Stick......

    Good luck!

    Thanks for that, but I cant get the encapsulation to change, I've managed to get a *slightly* newer IOS:

    outerA#sh ver
    Cisco Internetwork Operating System Software
    IOS (tm) C2600 Software (C2600-IO3-M), Version 12.3(3), RELEASE SOFTWARE (fc2)
    Copyright (c) 1986-2003 by cisco Systems, Inc.
    Compiled Tue 19-Aug-03 16:32 by dchih
    Image text-base: 0x80008098, data-base: 0x80D11A24

    ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)

    RouterA uptime is 25 minutes
    System returned to ROM by reload
    System image file is "flash:c2600-io3-mz.123-3.bin"

    cisco 2620 (MPC860) processor (revision 0x200) with 28672K/4096K bytes of memory
    .
    Processor board ID JAD05030OH3 (3224234162)
    M860 processor: part number 0, mask 49
    Bridging software.
    X.25 software, Version 3.0.0.
    1 FastEthernet/IEEE 802.3 interface(s)
    1 Serial network interface(s)
    32K bytes of non-volatile configuration memory.
    8192K bytes of processor board System flash (Read/Write)

    Configuration register is 0x2102

    RouterA#

    ********************************************

    As you can see though its a few years old, I'm trying to find an IOS that definately supports IPPlus, as Webmaster kindly suggested above, but no luck finding one yet.

    Again, many thanks for the suggestions guys.

    Dave
Sign In or Register to comment.