Getting Annoyed - Suse 10.2 Atheros/LAN-Expres WLAN install!

malcyboodmalcybood Senior MemberMember Posts: 900 ■■■□□□□□□□
Dear all,

I have been trying to get my Sony Vaio laptop LAN-Express AS 802.11g PCI WLAN card installed on Suse 10.2 to no evail! It uses the Atheros chipset but can apparently be used with the orinoco_pci chipset.....I have tried both without any success.

I have tried using both the Windows driver through ndiswrapper, adding the line modprobe orinoco_pci into the boot.local file (no rc.local in suse 10.2) and installing the card through madwifi. When I installed madwifi, I have got the "WLAN bus" to be recognised in Yast - Network Devices - Network card as AMBIT Microsystem WLAN controller but when I check if any packets are being sent or do an ifconfig in the shell there is still only an entry for the loopback and ethernet 0.

This is really grinding on me as I've done everything I can find on the web in regard to this and wonder wether or not just to buy a broadcom PCMCIA wireless card as I know it is compatible. I would rather work out how to resolve this issue but as a newbie to Linux I'm running short of ideas.

From what I read Atheros chipsets were dropped since Suse 10.0 but should still work with ndiswrapper or Madwifi.

Can anyone help me out with this?

Regards

Malc

Comments

  • mrvainmrvain Junior Member Member Posts: 1 ■□□□□□□□□□
    I found this post through Google.

    I believe I have the same problem with Suse 10.2, but my card is a Cisco Aironet AIR-CB21AG-A-K9.

    I have installed Madwifi through Yast, and the card is now being recognized in the network configuration (which wasn't happening before). And when I right-click the network icon in the system tray, I also have a new Wireless checkbox.

    However, I can't get the card to actually start working and come to life.

    I also do not have any packet or status information other than loopback and ethernet in the network information section.


    I am going to keep at it. If I find any success I'll be sure to post.
Sign In or Register to comment.