Can someone explain this to me?

jrmcentjrmcent Member Posts: 51 ■■□□□□□□□□
So I was just playing around with my lab, setting up static routes, and I noticed something again that has been bugging me. This is my ip route:

C 192.168.40.0/24 is directly connected, Ethernet0
192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.20.0/24 is directly connected, Serial0
C 192.168.20.1/32 is directly connected, Serial0

Now the serial 0 interface is 192.168.20.2 255.255.255.0, the ethernet 0 is 192.168.40.1 255.255.255.0. Now obviously my serial 0 is connected to my other router, which has a serial 0 interface ip of 192.168.20.1 255.255.255.0. I dont understand why it is showing that my 192.168.20.0 network is subnetted twice. And then it says that my 20.1 is a /32, which it is not, its a /24. I have no idea why it happens, but this is before I even added any kind of ip routing. It happens everytime I use any type of routing too, whether it be rip, ripv2, igrp, or static. I just dont understand why its always changing my masks and saying that its subnetted when its not. If anyone can explain this that would be great.

Comments

  • EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    You have created a static route pointing to S0.
    ip route 192.168.20.1 255.255.255.255 serial 0
    If you delete this route you will see 192.168.20.0 is no longer variably subnetted.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • jrmcentjrmcent Member Posts: 51 ■■□□□□□□□□
    See thats the thing, i never created a static route to anywhere, this happens right after a assign the ip address 192.168.20.2 255.255.255.0 to serial 0. I tried deleting the route anyway but it says no matching route to delete, which kinda makes sense cause i never assign a mask of /32, only the /24. But I dont understand why its showing a /32
  • jrmcentjrmcent Member Posts: 51 ■■□□□□□□□□
    sorry forgot to add that when i do this on a simulator, the same exact process, the variably subnetted doesnt show up, everything appears exactly how i entered it
  • spicc7spicc7 Member Posts: 47 ■■□□□□□□□□
    Can you do a "show run" to show us your config?
    __________________________________________
    CCNA, CCNA Security, MCSA, MCP, A+, Network+
  • jrmcentjrmcent Member Posts: 51 ■■□□□□□□□□
    sure can:


    Router#show run
    Building configuration...

    Current configuration : 555 bytes
    !
    version 12.1
    no service single-slot-reload-enable
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Router
    !
    enable secret 5 $1$EBkM$xuam5h6H7mj1YqrG.48Yw1
    !
    !
    !
    !
    !
    ip subnet-zero
    no ip domain-lookup
    !
    !
    !
    !
    interface Ethernet0
    ip address 192.168.40.1 255.255.255.0
    !
    interface Serial0
    ip address 192.168.20.2 255.255.255.0
    encapsulation ppp
    no fair-queue
    clockrate 64000
    !
    interface Serial1
    no ip address
    shutdown
    !
    ip classless
    ip http server
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    !
    end


    as you can see I have no ip routing enabled, I only assigned the interfaces their addresses. Yet my show ip route still reads:

    Gateway of last resort is not set

    C 192.168.40.0/24 is directly connected, Ethernet0
    192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks
    C 192.168.20.0/24 is directly connected, Serial0
    C 192.168.20.1/32 is directly connected, Serial0

    Just for clarification, the other router is set up the same way, but its serial 0 ip is 192.168.20.1 255.255.255.0, no ip routing at all.
  • iprouteiproute Member Posts: 269
    This isn't an answer to your question, but hopefully it'll help a more experienced person help you.

    I was able to duplicate your issue between my Router_B(2600) and Router_C(2500).

    Here's how it's setup now (correctly):

    Router_A (S0/0): 172.28.28.1 255.255.255.240
    Router_B (S0/1): 172.28.28.2 255.255.255.240

    Router_B (S0/0): 172.28.28.49 255.255.255.240
    Router_C (S1): 172.28.28.50 255.255.255.240

    Here's how I had it configured when the problem was produced.

    Router_A (S0/0): 172.28.28.1 255.255.255.240
    Router_B (S0/1): 172.28.28.2 255.255.255.240

    Router_B (S0/0): 172.28.28.3 255.255.255.240
    Router_C (S1): 172.28.28.4 255.255.255.240

    By that logic, the reason I was having connectivity problems (and the anomaly that you posted) is because from Router_B, Router_C was configured to be on the same subnet as Router_A, so it was using the interface connected to Router_A to try and get to Router_C. But since Router_B is between Router_A and _C, it wasn't finding _C.

    Once I returned to the correct config above, the anomaly and my connectivity issues vanished.

    This doesn't fully apply, as your subnetting appears to be correct (where mine wasn't to produce the anomaly).

    I use OSPF as well, so that may affect the equation as well.

    Also, the routers may be mis-interpreting something since you have ip classless enabled don't appear to be using it.

    Edit: Added more blabber.
    CCNP Progress
    ROUTE [X] :: SWITCH [X] :: TSHOOT [X]
  • EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    jrmcent wrote:
    sorry forgot to add that when i do this on a simulator, the same exact process, the variably subnetted doesnt show up, everything appears exactly how i entered it

    Yes, you should have mentioned it was a simulator.I cant quite grasp the logic behind using these crappy simulators now that dynamips is freely available.With my old laptop with a 750Mhz processor i can run 3 router instances, what else is needed routing wise for the ccna?
    So to answer your original question the problem is your SIM!
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • jrmcentjrmcent Member Posts: 51 ■■□□□□□□□□
    lol no im sorry, this is done on real routers, but when i reproduce it on a sim, it works, sorry for the confusion
  • rossonieri#1rossonieri#1 Member Posts: 799 ■■■□□□□□□□
    hello,

    dont worry,
    that was a normal behaviour stating that you have a .20.x subnet,
    and your interface is up with ip configured.
    not neccessarily a static route -- it has nothing to do with it.

    cheers...
    the More I know, that is more and More I dont know.
Sign In or Register to comment.