OSPF an RIP over Frame Relay

sqdmzsqdmz Posts: 6Member ■□□□□□□□□□
Hello everybody,

this is my first post in this forum so forgive me if i'm posting in wrong place,

my problem is the fallowing:

I have configured two routers lets say R1 and R2:

The R1 have OSPF and RIP v2 configured and R2 only have RIP v2.
The R1 is Redistributing the RIP v2.

My routers aren't exchanging RIP v2 packets (tables) between R1 and R2 because they are connected via Frame-Relay.

so How can make the frame-Relay let flow RIP and OSPF routing tables over the cloud???

i have tested the Frame-relay connectivity and it is OK, because i Can ping the interfaces of R1 and R2 connected via F-R
Just Tell me how to once. and i will do the it must be.

Peace for everyone here

Comments

  • EdTheLadEdTheLad Posts: 2,112Member
    Ripv2 sends updates to the multicast address 224.0.0.9 so you need to allow broadcast traffic propagate over the dlci.When you create the map add broadcast to the end i.e.
    "frame-relay map ip 10.0.0.1 500 broadcast"
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • sqdmzsqdmz Posts: 6Member ■□□□□□□□□□
    EdTheLad wrote:
    Ripv2 sends updates to the multicast address 224.0.0.9 so you need to allow broadcast traffic propagate over the dlci.When you create the map add broadcast to the end i.e.
    "frame-relay map ip 10.0.0.1 500 broadcast"

    Thanks for your attention but i already tried this and it is not working.

    my real IPs are from 172.16.255.252 /30 sub net.

    this is what i did:

    On R1: frame-relay map ip 172.16.255.254 100 broadcast

    and On R2: frame-relay map ip 172.16.255.253 200 broadcast

    but, wen make "sh ip route" on the R2 the other routes on the R1 did not appear.

    if want i can post my configs here.
    Just Tell me how to once. and i will do the it must be.

    Peace for everyone here
  • EdTheLadEdTheLad Posts: 2,112Member
    I persume you have another router configured to act as a FR switch?
    If yes, post the configs including the FR switch config, if no,disable the keepalive on both serial links and map the ip addresses to the same dlci on each side.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • sqdmzsqdmz Posts: 6Member ■□□□□□□□□□
    EdTheLad wrote:
    I persume you have another router configured to act as a FR switch?
    If yes, post the configs including the FR switch config, if no,disable the keepalive on both serial links and map the ip addresses to the same dlci on each side.

    here you have the configurations:

    Frame-Relay Switch
    version:
    Cisco Internetwork Operating System Software
    IOS (tm) C2600 Software (C2600-BIN-M), Version 12.2(13)T1, RELEASE SOFTWARE (fc1)

    enable
    conf t
    host switch-fr

    frame-relay switching

    int s0/0
    no shut
    encapsulation frame-relay ietf
    clock rate 64000
    frame-relay intf-type dce
    frame-relay route 21 interface serial 0/1 20

    int s0/1
    no shut
    encapsulation frame-relay ietf
    clock rate 64000
    frame-relay intf-dce
    frame-relay route 20 interface serial 0/0 21
    End of Frame-Relay Switch


    Router R1
    R1:
    version:
    Cisco Internetwork Operating System Software
    IOS (tm) C2600 Software (C2600-BIN-M), Version 12.2(13)T1, RELEASE SOFTWARE (fc1)

    hostname R1
    !
    interface fastethernet 0/0
    description (connect to R1-LAN)
    no shut
    ip add 172.16.0.1 255.255.252.0
    !
    interface serial 0/0
    no shut
    description (Connect to Frame Cloud DLCI-20)
    ip address 172.16.255.253 255.255.255.252
    encapsulation frame-relay
    frame-relay lmi-type ansi
    frame-relay map ip 172.16.255.254 20 broadcast
    !
    int s0/1
    description (connect to router R0-Using OSPF)
    no shut
    ip add 172.16.255.246 255.255.255.252
    !
    router ospf 100
    redistribute rip subnets
    network 172.16.255.252 0.0.0.3 area 0
    network 172.16.255.244 0.0.0.3 area 0
    network 172.16.0.0 0.0.3.255 area 0
    !
    conf t
    router rip
    version 2
    network 172.16.0.0
    !
    end of R1

    R2
    version:
    Cisco Internetwork Operating System Software
    IOS (tm) C2600 Software (C2600-BIN-M), Version 12.2(13)T1, RELEASE SOFTWARE (fc1)
    hostname R2
    !
    interface serial 0/0
    no shut
    description (Connect to Frame Cloud DLCI-21)
    ip address 172.16.255.254 255.255.255.252
    encapsulation frame-relay
    frame-relay lmi-type ansi
    frame-relay map ip 172.16.255.253 21 broadcast
    !
    router rip
    version 2
    network 172.16.0.0
    end of R2
    Just Tell me how to once. and i will do the it must be.

    Peace for everyone here
  • NightShade1NightShade1 Posts: 431Member
    Okay hold on a sec... let me see if i understand your problem....

    you got R1 with rip and OSPF and you redistributing Rip on OSPF ok

    Now on R2 when you do sh ip route, you cant SEE the networks that belongs to the OSPF....but you SEE The networks that belongs to the RIP
    That is what i understand when you said "but, wen make "sh ip route" on the R2 the other routes on the R1 did not appear"


    is that your problem?



    Or you cannot even see the networks for example 172.16.255.244 which Still belongs to the RIP process because its inside the 172.16.0.0 that you configured on rip which is telling that all the interfaces in the 172.16.0.0 network participate in the rip process...


    Which of those is your problem?

    Are you doing a lab to practice?
    Product Manager - ArubaNetworks
    Alternetworks Corp
  • DW [banned]DW [banned] Posts: 240Inactive Imported Users
    Thanks
  • rossonieri#1rossonieri#1 Posts: 800Member
    sqdmz wrote:
    router rip
    version 2
    network 172.16.0.0
    end of R2

    both on the router,

    where is "no auto-summ"?

    darby has explained all,

    why would you redistribute the same network?
    the router will see a split-horizon.

    do like rip 172.16.1 and 172.16.2 - so both routers see the function of routing.

    cheers.
    the More I know, that is more and More I dont know.
  • NightShade1NightShade1 Posts: 431Member
    " Redistribution of the OSPF Routes into RIP so that the other RIP Router can see those OSPF routes in the routing table. "

    I think he miss this 3rd option thtas why i asked him if he just couldnt see the routes that OSPF had.... because he didnt redistribute OSPF routes into rip... he just redistributed rip into OSPF....

    In that config he will see it as RIP i mean all the networks he has there because the 172.16.0.0 covers all the interfaces of the R1
    Product Manager - ArubaNetworks
    Alternetworks Corp
  • NightShade1NightShade1 Posts: 431Member
    sqdmz wrote:
    router rip
    version 2
    network 172.16.0.0
    end of R2

    both on the router,

    where is "no auto-summ"?

    darby has explained all,

    why would you redistribute the same network?
    the router will see a split-horizon.

    do like rip 172.16.1 and 172.16.2 - so both routers see the function of routing.

    cheers.

    He doesnt need to no auto summ there... he isnt crossing any major network boundary.... so it wont autsumarize....

    As for split horizon he wont have any problem here either... its by default off in cisco devices since version 12 for frame relay encapsulation i think... and even if its on he wont deal any problem with it he is not point multipointing with the same network here...

    i think he cant see other networks in the router R0 he had connected to Router 1 because he didnt redistribute ospf into rip but let see what he says
    Product Manager - ArubaNetworks
    Alternetworks Corp
  • rossonieri#1rossonieri#1 Posts: 800Member
    I think he miss this 3rd option thtas why i asked him if he just couldnt see the routes that OSPF had.... because he didnt redistribute OSPF routes into rip... he just redistributed rip into OSPF....

    there is no wrong of doing it.

    pls explain why he cant do that? just corious ;)
    the More I know, that is more and More I dont know.
  • NightShade1NightShade1 Posts: 431Member
    I dont understand your question ... lol
    Product Manager - ArubaNetworks
    Alternetworks Corp
  • rossonieri#1rossonieri#1 Posts: 800Member
    sqdmz wrote:
    int s0/1
    description (connect to router R0-Using OSPF)
    no shut
    ip add 172.16.255.246 255.255.255.252
    !
    router ospf 100
    redistribute rip subnets
    network 172.16.255.252 0.0.0.3 area 0
    network 172.16.255.244 0.0.0.3 area 0
    network 172.16.0.0 0.0.3.255 area 0
    !
    conf t
    router rip
    version 2
    network 172.16.0.0
    !
    end of R1

    nightshade1,

    from that - the person is trying to redistribute RIP over OSPF. i dont see why he cant do that.
    why the router decline the advertised RIP is becaused it has the same network.
    thats why i ask the person to change the advertised rip subnet to different subnet,
    just like darby said.

    and, pls be polite when posting.

    regards.
    the More I know, that is more and More I dont know.
  • NightShade1NightShade1 Posts: 431Member
    lol i have been unpolite posting in this tread????

    I do get your point its kinda messy because for example he is putting network 172.16.255.252 0.0.0.3 area 0 when he doesnt need to do that... he also missing some passive interfaces... he is sending broadcast updates trhough the fastethernet and the serial 1/0 when he doenst need to do that... i mean he is sending rip updates to the ospf domain?

    You can actually have it configured like he did and works... well the only different think i did was that i mutual redistribution and it was all cool.... and i had other network on the OSPF domain.

    If i didnt answer your question sorry my english doesnt help :/ just tell me that i didnt asnwer your question and ill try and re read it
    Product Manager - ArubaNetworks
    Alternetworks Corp
  • EdTheLadEdTheLad Posts: 2,112Member
    There will be no routes learned via rip on R1 so therefore the redistribution into ospf is pointless as the local interface is already applied to ospf.Split-horizon is not an issue as there are only 2 routers connected.Auto-summary is not an issue as the major network is constant.R2 should have rip learned routes as the configuration is correct.Show ip route on R1 will show connect routes only as nothing is being learned via a routing protocol.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • NightShade1NightShade1 Posts: 431Member
    Yeah hehe thats why i added other major networks in R1 when i did this

    anyways i still wanna see what are the networks that he cant see...
    My guess is that he has other major networks on R0 that is connected to R1 and he cant see them because he didnt did mutual redistribution....
    Product Manager - ArubaNetworks
    Alternetworks Corp
  • rossonieri#1rossonieri#1 Posts: 800Member
    I do get your point its kinda messy because for example he is putting network 172.16.255.252 0.0.0.3 area 0 when he doesnt need to do that...

    what the person trying to do is that he wants to create OSPF in per interface basis - not per network.
    he also missing some passive interfaces... he is sending broadcast updates trhough the fastethernet and the serial 1/0 when he doenst need to do that... i mean he is sending rip updates to the ospf domain?

    why should he do passive interface?,
    and whats wrong with sending broadcast over OSPF?
    pls kindly explain.
    the More I know, that is more and More I dont know.
  • EdTheLadEdTheLad Posts: 2,112Member
    I do get your point its kinda messy because for example he is putting network 172.16.255.252 0.0.0.3 area 0 when he doesnt need to do that...

    what the person trying to do is that he wants to create OSPF in per interface basis - not per network.
    network 172.16.255.253 0.0.0.0 area 0
    he also missing some passive interfaces... he is sending broadcast updates trhough the fastethernet and the serial 1/0 when he doenst need to do that... i mean he is sending rip updates to the ospf domain?

    why should he do passive interface?,
    and whats wrong with sending broadcast over OSPF?
    pls kindly explain.
    To stop multicasting ospf hellos out the interface,security and processor issue.
    To stop multicasting rip routes over the ospf backbone, bandwidth,security,processor.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • rossonieri#1rossonieri#1 Posts: 800Member
    ed,

    i know what the passive interface purpose for,
    but as long there are lower metric the router will process the lowest one,
    thats why under certain condition we need to create redistribution.

    and, from the persons picture : i get that
    he has configured OSPF which has lower metric over RIP.
    he cant see other RIP network (R2 (from R1) or R1 plus that Rn behind R1(from R2)) unless redistribute it - although he did not limit the RIP interface.

    and still he got a split horizon.

    cheers.
    the More I know, that is more and More I dont know.
  • sqdmzsqdmz Posts: 6Member ■□□□□□□□□□
    dear all,
    1st i have to say thanks for all.

    My problem is:

    The R1 cannot see the routes from R2, it only see the directly connected, i add a subnet to the fa0/0 of the R2 to test if the RIP is working.
    Just Tell me how to once. and i will do the it must be.

    Peace for everyone here
  • EdTheLadEdTheLad Posts: 2,112Member
    sqdmz wrote:
    dear all,
    1st i have to say thanks for all.

    My problem is:

    The R1 cannot see the routes from R2, it only see the directly connected, i add a subnet to the fa0/0 of the R2 to test if the RIP is working.

    A tip, when you have a problem try and give as much info as you can, if the problem is regarding a route not being learned on R1 from R2 you should have said that.You also should have provided the configuration of the problem, as i dont see fa0/0 in the config supplied.Secondly when you follow up to give more information, try and give the detailed information, since were dealing with routing and routing is based on ip addresses it would be a good idea to give us the ip address of the network on fa0/0, it would also be good to provide the configs, show ip route on both R1 and R2 etc. If you are trying to learn this stuff you need to know how to go about troubleshooting a problem for yourself,first thing i would have done in your shoes is delete all the unnecessary config like the redistribution the ospf etc,get the config as small as possible and work from there.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • iprouteiproute Posts: 269Member
    Is this on the test?






    I couldn't help it hahaha :P
    CCNP Progress
    ROUTE [X] :: SWITCH [X] :: TSHOOT [X]
  • markzabmarkzab Posts: 619Member
    sqdmz wrote:


    Frame-Relay Switch


    enable
    conf t
    host switch-fr

    frame-relay switching

    int s0/0
    no shut
    encapsulation frame-relay ietf
    clock rate 64000
    frame-relay intf-type dce
    frame-relay route 21 interface serial 0/1 20

    int s0/1
    no shut
    encapsulation frame-relay ietf
    clock rate 64000
    frame-relay intf-dce
    frame-relay route 20 interface serial 0/0 21



    Router R1


    hostname R1
    !
    interface fastethernet 0/0
    description (connect to R1-LAN)
    no shut
    ip add 172.16.0.1 255.255.252.0
    !
    interface serial 0/0
    no shut
    description (Connect to Frame Cloud DLCI-20)
    ip address 172.16.255.253 255.255.255.252
    encapsulation frame-relay
    frame-relay lmi-type ansi
    frame-relay map ip 172.16.255.254 20 broadcast
    !
    int s0/1
    description (connect to router R0-Using OSPF)
    no shut
    ip add 172.16.255.246 255.255.255.252
    !
    router ospf 100
    redistribute rip subnets
    network 172.16.255.252 0.0.0.3 area 0
    network 172.16.255.244 0.0.0.3 area 0
    network 172.16.0.0 0.0.3.255 area 0
    !
    conf t
    router rip
    version 2
    network 172.16.0.0
    !


    R2


    hostname R2
    !
    interface serial 0/0
    no shut
    description (Connect to Frame Cloud DLCI-21)
    ip address 172.16.255.254 255.255.255.252
    encapsulation frame-relay
    frame-relay lmi-type ansi
    frame-relay map ip 172.16.255.253 21 broadcast
    !
    router rip
    version 2
    network 172.16.0.0
    end of R2

    To quote my homeboy Todd Lammle...

    "The default encapsulation is Cisco unless you manually type in ietf, and Cisco is the type you used when connecting two Cisco devices.......blah, blah, blah............Whichever you choose, make sure that the Fram Relay encapsulation is the same on both ends."

    Thank you, thank you, thank you. I'm here Monday through Friday, 10am - 5pm. icon_lol.gif :P
    "You, me, or nobody is gonna hit as hard as life. But it ain't how hard you hit; it's about how hard you can get hit, and keep moving forward. How much you can take, and keep moving forward. That's how winning is done!" - Rocky
  • markzabmarkzab Posts: 619Member
    My point is that the encapsulation is not the issue here, although I'll admit it does look suspicous. In fact our friend's config is quite correct and seems to me to have performed exactly as advertised.

    His config wasn't set up correctly. Look below. You probably missed my post earlier because it was right as you started working up the lab. His original configuration had incorrect encapsulation types on both ends of each link coming out of the frame-switch...
    Hmm... So let's sum this one up to the fact that the end-points must match in order to function properly.

    It must have been his encapsulating ietf on the frame switch ends and then default cisco on the spokes WAN links....or are you talking about something completely different that I missed.
    markzab wrote:
    sqdmz wrote:


    Frame-Relay Switch


    enable
    conf t
    host switch-fr

    frame-relay switching

    int s0/0
    no shut
    encapsulation frame-relay ietf
    clock rate 64000
    frame-relay intf-type dce
    frame-relay route 21 interface serial 0/1 20

    int s0/1
    no shut
    encapsulation frame-relay ietf
    clock rate 64000
    frame-relay intf-dce
    frame-relay route 20 interface serial 0/0 21



    Router R1


    hostname R1
    !
    interface fastethernet 0/0
    description (connect to R1-LAN)
    no shut
    ip add 172.16.0.1 255.255.252.0
    !
    interface serial 0/0
    no shut
    description (Connect to Frame Cloud DLCI-20)
    ip address 172.16.255.253 255.255.255.252
    encapsulation frame-relay
    frame-relay lmi-type ansi
    frame-relay map ip 172.16.255.254 20 broadcast
    !
    int s0/1
    description (connect to router R0-Using OSPF)
    no shut
    ip add 172.16.255.246 255.255.255.252
    !
    router ospf 100
    redistribute rip subnets
    network 172.16.255.252 0.0.0.3 area 0
    network 172.16.255.244 0.0.0.3 area 0
    network 172.16.0.0 0.0.3.255 area 0
    !
    conf t
    router rip
    version 2
    network 172.16.0.0
    !


    R2


    hostname R2
    !
    interface serial 0/0
    no shut
    description (Connect to Frame Cloud DLCI-21)
    ip address 172.16.255.254 255.255.255.252
    encapsulation frame-relay
    frame-relay lmi-type ansi
    frame-relay map ip 172.16.255.253 21 broadcast
    !
    router rip
    version 2
    network 172.16.0.0
    end of R2

    To quote my homeboy Todd Lammle...

    "The default encapsulation is Cisco unless you manually type in ietf, and Cisco is the type you used when connecting two Cisco devices.......blah, blah, blah............Whichever you choose, make sure that the Fram Relay encapsulation is the same on both ends."
    "You, me, or nobody is gonna hit as hard as life. But it ain't how hard you hit; it's about how hard you can get hit, and keep moving forward. How much you can take, and keep moving forward. That's how winning is done!" - Rocky
  • markzabmarkzab Posts: 619Member
    I think all your configs and lab outputs just threw me off there. That's why the "huh" popped up. icon_wink.gif
    "You, me, or nobody is gonna hit as hard as life. But it ain't how hard you hit; it's about how hard you can get hit, and keep moving forward. How much you can take, and keep moving forward. That's how winning is done!" - Rocky
  • sqdmzsqdmz Posts: 6Member ■□□□□□□□□□
    hello everybody

    Now everything is working like this:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/60 ms

    and I'm sorry if i was confused in the explanation of my problem.

    I'm very happy with this forum, because I'm in Africa and here is not ease to find people that can exchange experiences with us.

    so wait for me because i will never leave in peace. Many thanks
    Just Tell me how to once. and i will do the it must be.

    Peace for everyone here
  • langejlangej Posts: 1Member ■□□□□□□□□□
    Question here, don't you have to apply the command:
    R1(config-if) frame-relay interface-dlci dlci-number?

    Also, you might think about elliminating the rip updates (excessive traffic) from going over the cloud by creating an default route to the rip router and placing the "default-information originate" in your ospf settings. The rip router doesn't need to see the ospf routes, just create the default "ip route 0.0.0.0 0.0.0.0 s0" on the rip router.
  • sqdmzsqdmz Posts: 6Member ■□□□□□□□□□
    langej wrote:
    Question here, don't you have to apply the command:
    R1(config-if) frame-relay interface-dlci dlci-number?

    Also, you might think about elliminating the rip updates (excessive traffic) from going over the cloud by creating an default route to the rip router and placing the "default-information originate" in your ospf settings. The rip router doesn't need to see the ospf routes, just create the default "ip route 0.0.0.0 0.0.0.0 s0" on the rip router.



    I will try what you said. and will post if it was OK or not.

    Peace 4 ALL once again.
    Just Tell me how to once. and i will do the it must be.

    Peace for everyone here
  • mikej412mikej412 Posts: 10,090Member
    Been busy, tried it.... but never got around to asking -- is this real hardware or Dynamips?

    Since the 2600 support in Dynamips was new (and still buggy -- haven't upgraded to the latest yet), I tried it with Dynamips using 3620 routers (and the fake frame-relay cloud configuration) -- and it worked as expected. When I added a loopback on R2 the route made it to R1 and was redistributed into OSPF.

    You can use the show ip rip database command "to see what rip is thinking."
    :mike: Cisco Certifications -- Collect the Entire Set!
  • markzabmarkzab Posts: 619Member
    What the heck are you 2 still doing up? I thought I was the only insomniac hitting refresh on this site every 3 minutes at 3am. icon_lol.gif
    "You, me, or nobody is gonna hit as hard as life. But it ain't how hard you hit; it's about how hard you can get hit, and keep moving forward. How much you can take, and keep moving forward. That's how winning is done!" - Rocky
Sign In or Register to comment.