Need an XP guru - Windows explorer hanging

malcyboodmalcybood Senior MemberMember Posts: 900 ■■■□□□□□□□
Is there any way to "reinstall" Windows explorer on an XP Pro box without having to rebuild the machine?

When I launch My Computer on this machine you get the Windows "torch" searching to pick up C and shared drives indefinately and it eventually hangs the machine.

I've tried

- tested under a different workstation profile (admin)
- system restore to a previous date last week

As a workaround, I've created shortcuts on his desktop directly to his C:\, and network drives H: and L: which he can then browse without any issues. The problem is that if he creates a new document he can't browse where to save it as I'm guessing it links to explorer. Also once browsing the drives if he goes back up to "My computer" it will hang.

Can anyone help me out here?

Thanks

Malc

Comments

  • Ricka182Ricka182 Ancient Relic....... Member Posts: 3,359
    Sounds like something is corrupt. I don't think you can install just Explorer. Try running sfc /scannow. That will check all the core system files, and replace those which may be corrupt. You will the need the original CD, or a network share that has the files. Also, do a virus and ad scan just in case......
    i remain, he who remains to be....
  • malcyboodmalcybood Senior Member Member Posts: 900 ■■■□□□□□□□
    Ricka thanks, I'll give it a try icon_cool.gif
  • sprkymrksprkymrk mikej412's caddy Member Posts: 4,884 ■■■□□□□□□□
    Try clearing your Recent Documents on the Start menu, make sure there are no CD's or floppies in the drives, and make sure all your drives (optical, like CD/DVD) are working. Disconnect them one by one to see if the problem goes away.
    All things are possible, only believe.
  • mrhaun03mrhaun03 Senior Member Member Posts: 359
    Does he have any network drives mapped that aren't available anymore?

    I've seen a few instances where users had network drives mapped that pointed to our old server. When browsing where to save and in Explorer, windows would hang. Sometimes it would just take a few minutes, but most of the time it froze and I would have to end the explorer.exe process.
    Working on Linux+
  • JDMurrayJDMurray Certification Invigilator Surf City, USAAdmin Posts: 12,845 Admin
    mrhaun03 wrote:
    Does he have any network drives mapped that aren't available anymore?
    Yeah, it's most likely network connections to mapped drives that are taking their sweet time in timing-out. If you want to do a quick test, try starting in Safe Mode without networking and see if Windows Explorer comes up quickly. If so, remove all of the mapped drives, network folders, etc. that's displayed by Windows Explorer. One or more of them will be invalid and causing your slow start-up problem.
  • malcyboodmalcybood Senior Member Member Posts: 900 ■■■□□□□□□□
    JD/mrhuan,

    I'm just about to go and try a few bits and bobs, but it's not the network drives that are causing the problem.

    The first thing I tried was logging in as workstation only administrator to count out the network drives causing the issues. Then I mapped direct shortcuts to the C:\ L:\ and H:\ by right clicking on the desktop and creating new shortcut.

    This way he accesses the drives and the data on all drives but it is only a workaround, you just can't browse My computer in windows explorer.

    All drives are available accessing them this way and these are the only drives he has mapped according to his netware account/container. Other people have exactly the same access as him and their machine is fine so isolated to this machine

    We run a novell network, is it worth reinstalling the netware client on the machine? I can't see how this would link to explorer but can anyone advise if it does?

    I did go into safe mode but didn't launch my computer i just ran system restore which didn't work. Pretty sure it's to do with something corrupt in explorer thpough. I'll try what mark suggested about disconnecting optical drives 1 by 1 etc and post back.

    Thanks

    Malc
  • malcyboodmalcybood Senior Member Member Posts: 900 ■■■□□□□□□□
    sparkymrk,

    Cheers, it is a faulty FDD or FDD cable. I've just unplugged the cable and disabled the FDD in the BIOS until I can get back on his machine. He needed on it and doesn't use floppy discs so that's him back up and running and will test if it is cable, drive or even board when he is out of the office/in a meeting.

    thanks everyone else for suggestions

    malc
Sign In or Register to comment.