DNS problem

tel_s1234tel_s1234 Member Posts: 24 ■□□□□□□□□□
I have a dns problem in one of my labs that hopefully someone might have an answer to. I have one root domain and two child domains in my lab. After a dc/dns server crashed in the root domain, I moved the fsmo roles onto the second root dc/dns server, now one of my child domains (A) is working fine, it's dns is managed by the root dc server, but the second child domain (B), who's dns is delegated from the root dc/dns won't replicate with the root dc/dns.

The child dns has forwarders onto the root dns server and ip dns config is configured as The child domain itself works fine. I've run dcdiag /test:registerindns /dnsdomain:domainname and it returned a dnsupdatetest 1460 message saying the A record test is inconclusive.

I ran dnslint against the root dc/dns from the child domain dc/dns, and it reported 3 missing CNAME records for forest guids for each dc in domain, 2 child domains. When I run dnslint from the root dc/dns, it passes the root dc/dns and reports two missing glue (A) records are missing for the child domain B dns server, the records for the root dc/dns and child domain A dc/dns.

I can ping between all DC fine.

I'm sure I'm missing something simple, but does anyone know what that might be ?



  • royalroyal Member Posts: 3,352 ■■■■□□□□□□
    First, make sure both sides are resolvable by dns. Then try the following on both the root dc and the problematic child dns server with the support tools installed. If either side cannot resolve the other side, get that fixed, reboot, then do the following. If both sides are resolvable, still do the following.

    nltest /dsregdns
    dcdiag /fix
    netdiag /fix

    Give it 10 minutes or so then do repadmin /syncall.
    “For success, attitude is equally as important as ability.” - Harry F. Banks
  • tel_s1234tel_s1234 Member Posts: 24 ■□□□□□□□□□
    To my eternal embarrassment, I have discovered the problem. The forwarding ip address was 6 instead of 60.... changed that everything works fine now....

    Lesson learned I think, at least I learned more about various diagnostic tools...

    Thanks for your help anyway Royal.
  • tel_s1234tel_s1234 Member Posts: 24 ■□□□□□□□□□
    Wasn't there a completely different answer there a minute ago ?
  • royalroyal Member Posts: 3,352 ■■■■□□□□□□
    Ya, before I was saying to just create conditional forwarders to make sure both sides are resolving. I realized that the delegation will be resolving the child and you already had a forwarder going to the root. That's why I changed my post to basically just say, "Make sure that you are able to resolve both sides and things are configured correctly." I kinda figured there was a configuration issue since both sides should have been resolving each other just fine with the delegation and forwarder which should have made replication work just fine. Then you can get the records properly registered and can get replication going through repadmin. But glad you got it working through the ip fix! :)
    “For success, attitude is equally as important as ability.” - Harry F. Banks
  • tel_s1234tel_s1234 Member Posts: 24 ■□□□□□□□□□
    Actually a quick question. The CNAME records in the _msdcs zone, where are the A records that they glue to located ? There would be the A records in each zone ? If you had to create them manually where would you put them ?
  • tel_s1234tel_s1234 Member Posts: 24 ■□□□□□□□□□
    No problems, found this out.
Sign In or Register to comment.