Options

Need a little bit of help..DR/BDR elections/NBMA

NetstudentNetstudent Member Posts: 1,693 ■■■□□□□□□□
Alright so I have a full mesh Frame-relay network with 3 endpoints A, B, C. This is a inverse-arp method of mapping. All routers can ping the other router's serial interface. Somehow I have 2 routers saying they are the DR and one router as the BDR. All 3 routers are in the same subnet, have the same hello interval, dead interval, same area. But one router has an ethernet int configured and I'm trying to get the updates to propogate that subnet. One router has the learned ospf route but the other hasn't. RouterC is where the subnet is, RouterB knows about it but RouterA doesn't know about it. RouterA is saying it is a DR, Router B is saying it is a DR, RouterC is saying it is BDR.

ROUTERC#show run
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterC
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Ethernet0/0
 ip address 10.45.21.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial0/0
 no ip address
no ip mroute-cache
 shutdown
 no fair-queue
!
interface Serial0/1
 ip address 192.168.1.3 255.255.255.248
 no ip directed-broadcast
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
router ospf 1
 network 10.45.21.0 0.0.0.255 area 0
 network 192.168.1.3 0.0.0.0 area 0
!
ip classless
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4

RouterC#show ip ospf int s0/1
Serial0/1 is up, line protocol is up
  Internet Address 192.168.1.3/29, Area 0
  Process ID 1, Router ID 192.168.1.3, Network Type NON_BROADCAST, Cost: 64
  Transmit Delay is 1 sec, State BDR, Priority 1
  Designated Router (ID) 192.168.1.2, Interface address 192.168.1.2
  Backup Designated router (ID) 192.168.1.3, Interface address 192.168.1.3
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    Hello due in 00:00:27
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 2, Adjacent neighbor count is 2
    Adjacent with neighbor 192.168.1.1
    Adjacent with neighbor 192.168.1.2  (Designated Router)
  Suppress hello for 0 neighbor(s)
============================================================
RouterB#show run
interface Serial0/1
 ip address 192.168.1.2 255.255.255.248
 ip directed-broadcast
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
router ospf 1
 network 192.168.1.2 0.0.0.0 area 0
!
ip classless
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
no scheduler allocate
end

RouterB#show ip ospf int serial 0/1
Serial0/1 is up, line protocol is up
  Internet Address 192.168.1.2/29, Area 0
  Process ID 1, Router ID 192.168.1.2, Network Type NON_BROADCAST, Cost: 64
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 192.168.1.2, Interface address 192.168.1.2
  Backup Designated router (ID) 192.168.1.3, Interface address 192.168.1.3
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    Hello due in 00:00:24
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 2, maximum is 2
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 192.168.1.3  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
============================================================
RouterA#show run
interface Serial0/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface Serial0/1
 ip address 192.168.1.1 255.255.255.248
 no ip directed-broadcast
 encapsulation frame-relay
 logging event subif-link-status
 logging event dlci-status-change
 frame-relay lmi-type ansi
!
router ospf 1
 network 192.168.1.1 0.0.0.0 area 0
!
ip classless
!
!
line con 0
transport input none
line aux 0
line vty 0 4
 login

RouterA#show ip ospf int s0/1
Serial0/1 is up, line protocol is up
  Internet Address 192.168.1.1/29, Area 0
  Process ID 1, Router ID 192.168.1.1, Network Type NON_BROADCAST, Cost: 64
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 192.168.1.1, Interface address 192.168.1.1
  Backup Designated router (ID) 192.168.1.3, Interface address 192.168.1.3
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    Hello due in 00:00:03
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 192.168.1.3  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
============================================================
RouterA#show ip route
Gateway of last resort is not set

     192.168.1.0/29 is subnetted, 1 subnets
C       192.168.1.0 is directly connected, Serial0/1
========================================
RouterB#show ip route
Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
O       10.45.21.0 [110/74] via 192.168.1.3, Serial0/1
     192.168.1.0/29 is subnetted, 1 subnets
C       192.168.1.0 is directly connected, Serial0/1
========================================
I mean I guess I could change the priority to a higher number on one of the DR's. But it should elect only one DR right? So whats going on here? RouterC has the highest RID so it should be DR, routerB has 2nd highest RID, it should be BDR. It's all wrong...

Also check this output for RouterA
RouterA#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.1.3       1   FULL/BDR        00:01:59    192.168.1.3     Serial0/1
RouterA#show ip ospf data

       OSPF Router with ID (192.168.1.1) (Process ID 1)


                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
192.168.1.1     192.168.1.1     1233        0x80000004 0x61E1   1
192.168.1.2     192.168.1.2     1249        0x80000004 0x69D5   1
192.168.1.3     192.168.1.3     1240        0x80000007 0xFED3   2

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.1.1     192.168.1.1     1233        0x80000002 0x98F7
192.168.1.2     192.168.1.2     1250        0x80000002 0x92FA

So if routerA is a DR, shouldn't it be in the full state with two neighbors?
help please, i'm stuck.

if anyone needs anymore info, let me know and i'll post it. Thanks
There is no place like 127.0.0.1 BUT 209.62.5.3 is my 127.0.0.1 away from 127.0.0.1!

Comments

  • Options
    Paul BozPaul Boz Member Posts: 2,620 ■■■■■■■■□□
    OSPF doesn't like non broadcast environments. Can you do a debug ip ospf events and paste the output?

    If you notice, under your OSPF interface details it says:
    Network Type NON_BROADCAST
    

    You should configure the neighbor command to establish your router to router relationships. The neighbor command will tell OSPF where to unicast its packets, since multicast traffic won't work.
    ROUTERC (config-router)#neighbor 192.168.1.1 [priority]
    ROUTERC (config-router)#neighbor 192.168.1.2 [priority]
    

    The [priority] option lets you specify a priority value for DR/BDR election, since again, that process uses broadcast but you're using a NBMA network. Make sure the [priority] option matches the set values on the respective routers, else you should just omit the option.

    Also, I don't see where you have your PVC's configured. How is your frame network set up?
    CCNP | CCIP | CCDP | CCNA, CCDA
    CCNA Security | GSEC |GCFW | GCIH | GCIA
    pbosworth@gmail.com
    http://twitter.com/paul_bosworth
    Blog: http://www.infosiege.net/
  • Options
    NetstudentNetstudent Member Posts: 1,693 ■■■□□□□□□□
    okay thanks I'll try that and I'll post that output later today. So i guess there is a little more to OSPF and NBMA networks than just setting up the net and turning on OSPF. Would this be considered entry CCNP level? I had a feeling this was going to be a Multicast issue. So even though it is a non-broadcast network, it still can't Multicast 224.0.0.5 or 6????

    I didn't post my frame-switch config. It's just a standard frame-relay route with ANSI LMI's using inverse-arp to create the mappings and PVC's.

    Also when using the "neighbor 192.168.1.1 [priority]" command FROM routerC, I want routerC to become the DR.

    So From routerC I should issue that command, giving the other two routers a lower priority and then use the "ip ospf priority 10" on routerC to explicitly specify it as DR. I read somewhere about priority 0 for routers that arn't cool enough for the election process. Is it more common to use priority 0 in NBMA networks than broadcast?

    By the way, this is great stuff, I love it!
    There is no place like 127.0.0.1 BUT 209.62.5.3 is my 127.0.0.1 away from 127.0.0.1!
  • Options
    NetstudentNetstudent Member Posts: 1,693 ■■■□□□□□□□
    In case anyone is following along as a reference for their own OSPF in a NBMA labs. I found this article that explains what Paul said.

    http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/12cgcr/np1_c/1cprt1/1cospf.htm#wp4801

    Paul,
    That worked, I got that subnet to propogate to RouterA finally thanks...but I have one more little hiccup.

    Check it:
    RouterC#show ip ospf neighbor
    
    Neighbor ID     Pri   State           Dead Time   Address         Interface
    192.168.1.2       1   FULL/BDR        00:01:49    192.168.1.2     Serial0/1
    192.168.1.1       1   FULL/DROTHER    00:01:37    192.168.1.1     Serial0/1
    
    See here it says RouterA(192.168.1.1) is a Drother..that just means non-DR or non-BDR right?
    But when I go to RouterA and do a
    RouterA#show ip ospf int s0/1
    Serial0/1 is up, line protocol is up
      Internet Address 192.168.1.1/29, Area 0
      Process ID 1, Router ID 192.168.1.1, Network Type NON_BROADCAST, Cost: 64
      Transmit Delay is 1 sec, State BDR, Priority 1
      Designated Router (ID) 192.168.1.3, Interface address 192.168.1.3
      Backup Designated router (ID) 192.168.1.1, Interface address 192.168.1.1
      Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
        Hello due in 00:00:18
      Neighbor Count is 1, Adjacent neighbor count is 1
        Adjacent with neighbor 192.168.1.3  (Designated Router)
      Suppress hello for 0 neighbor(s)
    

    RouterA is saying it is a BDR...

    One last question...If I issue a "neighbor 192.168.1.1 priority 3" command FROM routerC, should I be able to go back to RouterA, do a show ip ospf int s0/1, and see the new priority of 3?

    OR is the command only in relation to RouterC and doesn't actually change the actual priority on RouterA??????
    There is no place like 127.0.0.1 BUT 209.62.5.3 is my 127.0.0.1 away from 127.0.0.1!
  • Options
    dtlokeedtlokee Member Posts: 2,378 ■■■■□□□□□□
    One additional problem you may run into with this configuration is that if one of the PVC's were to fail, you would lose the direct L2 connectivity that is assumed between each OSPF router and the DR/BDR on the multiaccess network. If this happens you could have a router that thinks it is the DR or BDR when it really isn't because there is already another DR/BDR on the segment. You should explore the "ip ospf network point-to-multipoint" command to solve this problem. There will be no DR/BDR and the network can survive PVC failures better than the current setup. Not that this design does not work in this case, it may be a better solution. Also if you choose to use non-broadcast with a hub and spoke design, ensure the DR is the hub and there are no BDR routers on the spokes (since there is no direct L2 connectivity between spokes)
    The only easy day was yesterday!
  • Options
    NetstudentNetstudent Member Posts: 1,693 ■■■□□□□□□□
    ya I thought about changing the network type, but wasn't sure what kind of affect it would have. I did see that point-to-multipoint network type in my ip ospf network ? command and thought about it.

    When you say "if one of the PVC's were to fail, you would lose the direct L2 connectivity that is assumed between each OSPF router and the DR/BDR on the multiaccess network"

    are you talking about the PVC between them or the adjacency between them. And would I lose this connectivity because there are only 3 endpoint routers?????

    So basically what your saying is, since I used the "ospf neighbor priority" command from RouterC TO routerA and TO routerB, that if a PVC failure occured, then it could not re-elect because of the static neighbor commands??? Then my network would go right back to the way it was before I issued the "ospf neighbor priority" commands in which I had 2 DR's and 1 router wasn't learning OSPF routes.

    sorry that kinda confused me but I want to understand the potential problem.

    So I have adjacencies between RouterC<---->RouterA AND between RouterC<
    >RouterB

    I don;t understand how losing the PVC between routerA and RouterB would affect antying since I have no adjacencies between them.

    SO the bottom line is, with this type of Frame-relay network, don't use a non-broadcast OSPF network type??????

    Also my routing tables just doubled in size because of the different OSPF network type. I changed it to point-to-multipoint and my neighboring IP's have become OSPF learned routes even though they are all in the same subnet.
    There is no place like 127.0.0.1 BUT 209.62.5.3 is my 127.0.0.1 away from 127.0.0.1!
  • Options
    Paul BozPaul Boz Member Posts: 2,620 ■■■■■■■■□□
    In NBMA environments I usually force one router to be the DR, force another to be the BDR, and set all other routers with a priority value of 0 to exclude them from the DR/BDR election. The DR and BDR almost always have access to the same routes, either via redundancy of hub/spoke or full mesh, so if the DR dies there won't be a contest to elect a new one, which can get nasty over frame relay.
    Netstudent wrote:
    So i guess there is a little more to OSPF and NBMA networks than just setting up the net and turning on OSPF. Would this be considered entry CCNP level?

    By the way, this is great stuff, I love it!

    Yeah, the CCNA OSPF requirements assume you're on a single area ethernet segment as far as I know. OSPF is pretty neat! If you like OSPF you should look into ISIS. I like it more.
    CCNP | CCIP | CCDP | CCNA, CCDA
    CCNA Security | GSEC |GCFW | GCIH | GCIA
    pbosworth@gmail.com
    http://twitter.com/paul_bosworth
    Blog: http://www.infosiege.net/
Sign In or Register to comment.