Help with LDIFDE

OkasonOkason Member Posts: 57 ■■□□□□□□□□
The 180 days evaluation period of the W2K3 I used for my Test Lab passed, so I exported my AD using ldifde -f output.ldf. Today I re-installed the OS and then ran dcpromo using the same domain name, then I tried to import the file output.ldf into my AD and got this error:

C:\Documents and Settings\Administrator.HQOKCSVR001>ldifde -i -f output.ldf -j log.txt
Connecting to ""
Logging in as current user using SSPI
Importing directory from file "output.ldf"
Loading entries.
Add error on line 2: Unwilling To Perform
The server side error is "The specified instance type is not valid."
0 entries modified successfully.
An error has occurred in the program

Here is the top part of this (output.ldf) file

dn: DC=okasonconcerns,DC=com
changetype: add
objectClass: top
objectClass: domain
objectClass: domainDNS
distinguishedName: DC=okasonconcerns,DC=com
instanceType: 5
whenCreated: 20061221194354.0Z
whenChanged: 20070130080637.0Z
subRefs: DC=ForestDnsZones,DC=okasonconcerns,DC=com
subRefs: DC=DomainDnsZones,DC=okasonconcerns,DC=com
subRefs: CN=Configuration,DC=okasonconcerns,DC=com
uSNCreated: 4098
uSNChanged: 135186
name: okasonconcerns
objectGUID:: YHu2DzsCyESWB8xNoy3Y6A==
creationTime: 128112044334843750
forceLogoff: -9223372036854775808
lockoutDuration: -18000000000
lockOutObservationWindow: -18000000000

Is there something I am doing wrong? is this possible at all? would this has been easier/possible with csvde instead?
Any thoughts/help would be so much appreciated.

Thank you
All things work together for them that believe..


  • sprkymrksprkymrk Member Posts: 4,884 ■■■□□□□□□□
    I'm not positive (ldifde is not something I use every day) but I would have specified a -d in the export command, like this:

    ldifde -f output.ldf -d "dc=okasonconcerns,dc=com"

    I'm not saying what you did was wrong, because based on the ldf file it looks okay to me. The only other thing I can think of is that you already created the new domain, and now you are trying to add it as well. Can you change the "changetype" line to something other than "Add"? maybe try "Modify" and see what happens?

    I would have used csvde for sure, much easier IMO.
    All things are possible, only believe.
  • OkasonOkason Member Posts: 57 ■■□□□□□□□□
    Thank you sprkymrk for your thoughts, I agree with you I should have used csvde. I have tried your suggestions and messed arround a little bit without success; I have begin to add objects again back to my AD---very time consuming but in the circumstance its my only option.

    Thank You again.
    All things work together for them that believe..
  • sprkymrksprkymrk Member Posts: 4,884 ■■■□□□□□□□
    Your very welcome, I'm just sorry it didn't work.
    Lesson learned I guess. I'm going to have to mess with ldifde in a lab setting.

    To me, csvde is best for importing new objects, while ldifde is best when you want to modify existing objects. That's not always true, just kind of a generalization I go by.
    All things are possible, only believe.
Sign In or Register to comment.