Help setting up WSUS Server

KhattabKhattab Member Posts: 97 ■■□□□□□□□□

I've been playing around at my lab at home - i set up a win2k3 server with IIS and WSUS, however once the installation has been completed i cant browse to the site (in IIS or otherwise). If i try browsing to the root default directory (which is where i installed it) it gives me one of the generic IIS error pages (i cant remember the exact error message). If i try browsing to the self update (or any other) folder under the root default website, it returns a page cannot be displaying and says 'the page requires you to log in' but it doesnt actually give me a prompt to log in.

I checked directory security - allow anonymous access is enabled and so is integrated windows authentication. I believe the correct permissions are also set on the directory level....

From within the WSUS Admin page, i am able to download all the updates without any problems... i just cant seem to get any clients to update because the web interface does not work.

I've got ASP.NET2 installed on the WSUS server - do i also need to install .NET1.1?

Any ideas?



  • sthomassthomas Member Posts: 1,240 ■■■□□□□□□□
    I am assuming the client computers you speak of are part of a domain? Did you create a GPO so the clients can download updates from the WSUS server? If they are not part of a domain you will have to configure the clients to connect to the WSUS server by editing the registry on the client PCs.
    Working on: MCSA 2012 R2
  • sprkymrksprkymrk Member Posts: 4,884 ■■■□□□□□□□
    You say you can't browse to the site, but then you say you can download the updates within the WSUS admin page. If you can get to the WSUS Admin page, what other site are you looking for?
    All things are possible, only believe.
  • royalroyal Member Posts: 3,352 ■■■■□□□□□□
    I know that with SUS, if you had anonymous turned on the administration page would not work. But once you turned off anonymous and turned on integrated authentication, the page would start working. I'm assuming it'll be the same for WSUS.
    “For success, attitude is equally as important as ability.” - Harry F. Banks
  • KhattabKhattab Member Posts: 97 ■■□□□□□□□□
    sprkymrky - I can see where my post is sounding a little confusing. Let me try to clarify...

    When i said that i am able to download the updates - i meant that my WSUS server is able to syncrhonize with (and download all the relevant updates i selected from) the Microsoft Update server from the administration console (under Administrative Tools -> WSUS Administration console). Thats what i meant by 'i am able to download the updates'.

    If i try to browse to the WSUS page however (http://WSUSServer) i cant browse to it and encounter the problems i spoke of in my initial post. Thats what i cant browse to... hope that clears it up?

    I am using a domain, and have made the GPO changes on the client machines and tried to manually force it to connect to the WSUS server using "wuauclt.exe /detectnow" command but no change.....

    I'll try royal's suggestion and see if that makes any difference, i.e removing anonymous access and keep it as integrated windows authentication.
  • sprkymrksprkymrk Member Posts: 4,884 ■■■□□□□□□□
    Hi Khattab,

    The only site available is the http://servername/wsusadmin. Are you looking for something else? If you simply try to go to the http://servername, you'll get an "unauthorized" message.
    So while clients only need to point to http://servername to get their updates, there is nothing there to browse to, it is simply what the client needs to know in order to use it's Automatic Updates software for your server. The only "site" is the administration page you can already access.

    I hope that helps, but maybe I still don't understand what you are trying to do. icon_confused.gif:
    All things are possible, only believe.
  • KhattabKhattab Member Posts: 97 ■■□□□□□□□□
    I ended up finding out why my WSUS installation was playing up on me.... icon_mad.gif

    Initially, i had SUS installed... then upgraded to WSUS... somehow though, the executable i was using (even though i d/l from the MS site) would not install all the components correctly. In IIS for example, there was no virtual directory for WSUSAdmin - which is why i couldnt browse to it. Other components were also missing.

    I downloaded a different (correct?) version from the MS site and all worked well first time around without any glitches!

    Thanks for all your help.... and apologising for being daft!
Sign In or Register to comment.