WSUS Download problem.

billybob01billybob01 Member Posts: 504
I have just noticed that i am receiving an error message in the Event Viewer Event ID 364. Stating that the WSUS Server cannot download the updates from Microsoft. It says: The server does not support the necessary HTTP protocol, Background Intelligent Transfer Service requires that the server support the range protocol header. ( this is followed by a long string of letters and numbers refering to the update and path)
I have checked BITS service is running and tried the advice from microsoft within the event viewer but still no joy. Has anyone any idea?


  • royalroyal Member Posts: 3,352 ■■■■□□□□□□
    “For success, attitude is equally as important as ability.” - Harry F. Banks
  • billybob01billybob01 Member Posts: 504
    Wow many thanks royal. What do you do to get those answers? i have been trying most of the day to find answers!
  • billybob01billybob01 Member Posts: 504
    mmmmm reading into this a bit further i have read that WebMarshal ( we have only recently installed this on our ISA 2004 Server) does not support HTTP v1.1?

    In order to allow all users to access Microsoft Windows Updates the following changes need to me made to the WebMarshal configuration:

    Create a new URL category called 'Software updates' and populate it with the list of URLs below:


    Create a new Site Rule that looks like below and place it above any blocking rules:
    Site Rule: Permit Software Updates
    When a web request is received
    For any User
    And where the URL is a member of 'Software Updates'

    Permit Access to this site
    And do not process any further site blocking rules
    Create a new Content Download Rules -> File Type Rule that looks like below and place it above any File Type blocking rules:

    FileType Rule: Permit Software Update files
    When a web request is received
    For any User
    And where the URL is a member of 'Software Updates'

    Permit Access to this file
    And do not process any further file type rules

    Be sure to reload the configuration after making these changes.

    Looks like it could be WebMarshal being the culprit. What do you think royal?
  • billybob01billybob01 Member Posts: 504
    I have just run the command that Microsoft reccomends if your using WSUS 3 which i am

    %programfiles%\Update Services\Setup\ExecuteSQL.exe -S %Computername%\MICROSOFT##SSEE -d "SUSDB" -Q "update tbConfigurationC set BitsDownloadPriorityForeground=1"

    I have checked and double checked the syntax but keep receiving this error message: ( not sure wether i should leave out the % when i type in the computer name)

    C:\Programs is not recognised as an internal or external command operable program or batch file.

    Any ideas would be most welcome guys.
  • sprkymrksprkymrk Member Posts: 4,884 ■■■□□□□□□□
    Enclose the path in quotes (").

    If that doesn't work simply execute the command directly from the directory so you don't have to enter the full path (in other words, from the cmd prompt go to the directory where ExecuteSQL.exe is located):

    C:\Program Files\Update Services\Setup>ExecuteSQL.exe -S (etc.)

    Also, you can substitute the %Computername% with the actual name of the computer.
    All things are possible, only believe.
  • billybob01billybob01 Member Posts: 504
    Now i am pulling my hair out!! I have WSUS 3 installed. Microsoft says if your running WSUS 3 then run this command prompt:

    %programfiles%\Update Services\Setup\ExecuteSQL.exe -S %Computername%\MICROSOFT##SSEE -d "SUSDB" -Q "update tbConfigurationC set BitsDownloadPriorityForeground=1"

    Problem is i dont have ExecuteSQL.exe!!! But i do have osql.exe. Now Microsoft says run this command if your using WSUS 2:

    %programfiles%\Update Services\tools\osql\osql.exe -S %Computername%\WSUS -E -b -n -Q "USE SUSDB update tbConfigurationC set BitsDownloadPriorityForeground=1"

    Tried this command prompt but still no downloading happens. This was working fine before, and after reading more about this problem, they recommend that i modify the proxy server settings to support HTTP 1.1 range requests. How do i do this with ISA 2004??
  • billybob01billybob01 Member Posts: 504
    Ok alls well. ran the command as posted and updates are comming down again. By the way has anyone heard of when there will be a SP for WSUS3?
Sign In or Register to comment.