Options

config problem on serial interfaces

tottstotts Member Posts: 117
Can anyone spot this problem I've created. The serial interfaces have been working ok then I tinkered... swapped the back-to-back cables around and changed the ip addresses... pretty innocent stuff. Basically the networks set up like this...

NY S0 LONDON S0
192.192.192.1/27 > 192.192.192.2/27
DCE


NY S1 LONDON S1
192.192.192.33/27 > 192.192.192.34/27
DCE


london#sh run
Building configuration...

Current configuration : 642 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname london
!
enable secret 5 $1$k51s$YhA1vPWxKjH6.IXEEPwZo1
!
!
!
!
!
ip subnet-zero
!
!
!
!
interface Ethernet0
ip address 172.16.4.1 255.255.252.0
!
interface Serial0
bandwidth 64000
ip address 192.192.192.2 255.255.255.224
!
interface Serial1
bandwidth 64000
ip address 192.192.192.34 255.255.255.224
!
router rip
network 192.192.192.0
!
ip classless
ip http server
!
!
!
line con 0
password sanfran
login
line aux 0
line vty 0
password london
login
line vty 1 4
login
!
end
......................................................................................................
london>show ip int brief
Interface IP-Address OK? Method Status Prot
ocol
Ethernet0 172.16.4.1 YES NVRAM up down

Serial0 192.192.192.2 YES manual up down

Serial1 192.192.192.34 YES manual up down
.............................................................................................................
NewYork#sh run
Building configuration...

Current configuration : 768 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname NewYork
!
enable secret 5 $1$99Xi$h8KrnU6Au4NOYAhHJdEPD/
!
!
!
!
!
ip subnet-zero
ip host GAD 172.16.0.1 172.17.0.1
!
!
!
!
interface Ethernet0
ip address 172.16.12.1 255.255.252.0
!
interface Serial0
bandwidth 64000
ip address 192.192.192.1 255.255.255.224
no fair-queue
!
interface Serial1
bandwidth 64000
ip address 192.192.192.33 255.255.255.224
!
router rip
network 172.17.0.0
network 172.18.0.0
network 192.192.192.0
!
ip classless
ip http server
!
!
!
line con 0
exec-timeout 0 0
password sanfran
login
line aux 0
line vty 0
password newyork
login
line vty 1 4
password cisco
login
!
end
.............................................................................................
NewYork#sh ip int brief
Interface IP-Address OK? Method Status Prot
ocol
Ethernet0 172.16.12.1 YES NVRAM up down

Serial0 192.192.192.1 YES manual up down

Serial1 192.192.192.33 YES manual up down
..............................................................................................

I've put the cables back, checked the ip addressing scheme, checked I've
set 'bandwidth 64000' on the correct DCE side, carried out 'no shutdown' on
the interfaces countless times, tried pinging, re-typed in the ip addresses on
the interfaces, reloaded the routers, configured ip routing (but don't think I
need to on back-to-back).

I know its probably something simple, but see what you think.
Cheers
totts from essex

Comments

  • Options
    LOkrasaLOkrasa Member Posts: 343 ■■■□□□□□□□
    I havent looked too deep into the show commands you posted but a quick thing to check is keepalives... make sure they are the same. Default is 10seconds.... I will keep looking at your config and post what I come up with... you can see the keepalives with "show interface serial #"
  • Options
    WebmasterWebmaster Admin Posts: 10,292 Admin
    You need to use the "clock rate" command on the DCE side instead of the "bandwidth" command.
  • Options
    LOkrasaLOkrasa Member Posts: 343 ■■■□□□□□□□
    ok the problem is you setup "bandwidth" instead of "clock rate" on your DCE end serial interfaces....


    Type "clock rate 64000" on your DCE side serial interfaces.

    EDIT: ugh... webmaster! Take all the joy out of it why dont ya! :D
  • Options
    StoticStotic Member Posts: 248
    The bandwidth command sets a bandwidth value for certain routing protocols to use in their metric. It doesn't do anything to the actual link like clock rate does.
  • Options
    tottstotts Member Posts: 117
    LOkrasa wrote:
    I havent looked too deep into the show commands you posted but a quick thing to check is keepalives... make sure they are the same. Default is 10seconds.... I will keep looking at your config and post what I come up with... you can see the keepalives with "show interface serial #"
    Brilliant stuff, I'll configure the 'clock rate' first thing in the morning. Incidently, I'm interested in the above 'keepalives'. I haven't seen much about this on my 'Intro' studies (even though I've looked). Would you mind elaborating a little.
    Many thanks, Totts
    totts from essex
  • Options
    LOkrasaLOkrasa Member Posts: 343 ■■■□□□□□□□
    Well I dont know too much, I am studying for my CCNA as well. I do know that they need to be set to exactly the same thing on the directly connected serial interfaces. They pretty much are meant to just detect connectivity between the two interfaces and to make sure it hasnt dropped. Hope that helps...
Sign In or Register to comment.