AS Number Question Revisited.

NetstudentNetstudent Member Posts: 1,693 ■■■□□□□□□□
Well this post sparked a good discussion on different ways to configure mutual redistribution. Using each method depends on what we want to accomplish.

AS a CCIE said, "If you need to have multiple EIGRP AS's in your environment, you need to determine where to place the point of redistributions and what routes to allow/deny between AS's. Actually, that's the main goal for having multiple ASes, that is granular management of the EIGRP topology within your network."

So I figured why not expand on this and lab it up to see the advantages of both ways.

ONe way is to have a 1 single border router that borders, and is part of, 2 autonomous systems. This single router mutually redestributes routes from one ASS to the other.

Another way is to have an intermediary Autonomous System the separates 2 AS's. Thus, configuring 3 AS's. With this method, we would have 2 routers, each router being part of 2 AS's. Whereas the other method we only have 1 router part of 2 AS's

I will give topologies and configs of both methods. This is beyond CCNA, but it's fun and the CCNP forum is dead anyways.
Mutdis.jpg
Here is a topology of a small campus network using redistribution between the AS's with a single router acting as a AS border.
ColofScience and biz routers are setup with EIGRP in a normal way. Just started the AS102 process and added the network.

SouthCampus was setup the same except it has a AS100. MainCampus is doing the redis. of course.
SouthCampus#show ip route
     65.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D EX    65.20.20.0/30 [170/2681856] via 192.168.1.1, 01:25:01, Serial0/1
D EX    65.20.20.2/32 [170/2681856] via 192.168.1.1, 01:25:01, Serial0/1
D EX    65.20.20.4/30 [170/2681856] via 192.168.1.1, 01:25:01, Serial0/1
D EX    65.20.20.6/32 [170/2681856] via 192.168.1.1, 01:25:01, Serial0/1
     10.0.0.0/27 is subnetted, 1 subnets
C       10.21.45.32 is directly connected, Ethernet0/0
     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.1.1/32 is directly connected, Serial0/1
C       192.168.1.0/30 is directly connected, Serial0/1

Notice here that we see the external routes to collegeofscience and biz which are in AS102
CollegeOfBusiness#show ip route
Gateway of last resort is not set

     65.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C       65.20.20.1/32 is directly connected, Serial0/1
C       65.20.20.0/30 is directly connected, Serial0/1
D       65.20.20.4/30 [90/2681856] via 65.20.20.1, Serial0/1
D       65.20.20.6/32 [90/2681856] via 65.20.20.1, Serial0/1
     10.0.0.0/27 is subnetted, 1 subnets
D EX    10.21.45.32 [170/2707456] via 65.20.20.1, Serial0/1
     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
D EX    192.168.1.0/30 [170/2681856] via 65.20.20.1, Serial0/1
D EX    192.168.1.2/32 [170/2681856] via 65.20.20.1, Serial0/1

And here at collegeofbiz we see EX. routes to SouthCampus which is in AS100
MainCampus#show ip prot
Routing Protocol is "eigrp 100"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 100, eigrp 102
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    192.168.1.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.1.2           90      01:53:18
  Distance: internal 90 external 170

Routing Protocol is "eigrp 102"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 100, eigrp 102
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    65.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    65.20.20.2            90      01:50:40
    65.20.20.6            90      01:50:40
  Distance: internal 90 external 170
Here we see that we are routing for 2 AS's and we are redistributing 102 and 100.
MainCampus#show run
Building configuration...


interface Serial1/0
 description T1 link to SouthCampus AS100
 bandwidth 1544
 ip address 192.168.1.1 255.255.255.252
 encapsulation ppp
 clock rate 64000
!
interface Serial1/1
 description T1 link to College Of Business AS102
 bandwidth 1544
 ip address 65.20.20.1 255.255.255.252
 encapsulation ppp
 clock rate 64000
!
interface Serial1/2
 description T1 link to College of Science AS102
 bandwidth 1544
 ip address 65.20.20.5 255.255.255.252
 encapsulation ppp
 clock rate 64000
!

!
router eigrp 100
 redistribute eigrp 102 route-map into-100
 network 192.168.1.0
 no auto-summary
!
router eigrp 102
 redistribute eigrp 100 route-map into-102
 network 65.0.0.0
 auto-summary
!
ip classless
ip http server
!
route-map into-100 deny 10
 match tag 100
!
route-map into-100 permit 20
 set tag 102
!
route-map into-102 deny 10
 match tag 102
!
route-map into-102 permit 20
 set tag 100
!
end
here is the config with redistribution in play. Notice we have route-maps to control what routes come and go from one AS to the other.

See when a route from AS100 goes over "INTO"-AS102 it gets tagged with 100.(route-map into-102 permit 20 set tag 100).

Then when AS102 sends an update back "INTO"-100, if one of the routes in the update has a 100tag, it gets denied to prevent an invalid routing table.(route-map into-100 deny 10 match tag 100). I think this is almost like manually creating split-horizon between AS's.

_______________________________________________________________________________

mutdis2.jpg
OKay here is a sample topology for redistributing with 3 aAS's.
RouterA#show run
Building configuration...


interface Ethernet0/0
 ip address 10.45.21.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial0/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface Serial0/1
 ip address 10.10.10.2 255.255.255.252
 no ip directed-broadcast
!
router eigrp 102
 redistribute eigrp 103
 network 10.0.0.0
!
router eigrp 103
 redistribute eigrp 102
 network 10.0.0.0
!
Notice ROuterA has two AS's on it and the redistribution commands. 103 is the intermediary AS. We redistribute 102 into 103 and 103 into 102.
RouterA#show ip route
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.10.10.0/30 is directly connected, Serial0/1
C       10.45.21.0/24 is directly connected, Ethernet0/0
     12.0.0.0/24 is subnetted, 1 subnets
D EX    12.45.21.0 [170/2169856] via 10.10.10.1, Serial0/1

Here we see the external route to routerB's ethernet network.
RouterB#show run
Building configuration...

interface Ethernet0/0
 ip address 12.45.21.1 255.255.255.0
 no ip directed-broadcast
 no keepalive
!
interface Serial0/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
!
interface Serial0/1
 ip address 10.10.10.1 255.255.255.252
 no ip directed-broadcast
 clockrate 64000
!
router eigrp 104
 redistribute eigrp 103
 network 12.0.0.0
 no auto-summary
!
router eigrp 103
 redistribute eigrp 104
 network 10.0.0.0
 no auto-summary
RouterB#show ip route
Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.10.10.0/30 is directly connected, Serial0/1
D       10.45.21.0/24 [90/2195456] via 10.10.10.2, Serial0/1
     12.0.0.0/24 is subnetted, 1 subnets
C       12.45.21.0 is directly connected, Ethernet0/0

Now the only thing that has me stumped here is why does the learned route not show up as external?
RouterB#show ip eigrp top
IP-EIGRP Topology Table for AS(104)/ID(12.45.21.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - Reply status

P 10.10.10.0/30, 1 successors, FD is 1
         via Redistributed (1/0)
P 10.45.21.0/24, 1 successors, FD is 2195456
         via Redistributed (2195456/0)
P 12.45.21.0/24, 1 successors, FD is 281600
         via Connected, Ethernet0/0

Not sure but this method has a lot more redistribution going on. Little more confusing to me because a route gets redistributed twice.
There is no place like 127.0.0.1 BUT 209.62.5.3 is my 127.0.0.1 away from 127.0.0.1!

Comments

  • networker050184networker050184 Mod Posts: 11,962 Mod
    Hey good stuff. I decided to play with it a little yesterday myself also. The three AS method did seem a little to much. I don't really see advantage of adding an extra AS just to redistribute. If you already have three AS then I can see the point, but not if you only have two. Great post!
    An expert is a man who has made all the mistakes which can be made.
Sign In or Register to comment.