RRAS and ICS

alharlandalharland Member Posts: 35 ■■□□□□□□□□
Hey All,

I am currently trying to setup RRAS on my Windows Server 2003 SP1 DC, which formally had ICS running on a LAN connection. When I try to configure RRAS I get an error stating that I need to disable ICS, and it doesn't let me proceed.

From what I can tell, ICS is no longer running. I don't have the sharing section on the advanced tab on the network connection to disable there anymore for some reason? But, I have disabled the ICS service.

Does anybody have any ideas as to the cause of the problem? I really am stuck here.

Adam.

Comments

  • royalroyal Member Posts: 3,353
    It's because of a stale registry key. When you install SP1, I hear it'll remove the option to disable ICS in the Network Properties. When you disable ICS, it won't reset the registry for that NIC saying it's not using ICS anymore. Because of this, RRAS will still see ICS as enabled. You could typically uninstall SP1, then take care of the ICS issue, or you can go to the following registry key and do the following:

    HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess

    Check for a DWORD, "ConfigurationFlags"
    Make sure it's set as 1

    If you don't see "ConfigurationFlags," create it and set the decimal value to 1

    If it's still not working, try re-enabling ICS and then disabling it again. You should not have to reboot.
    “For success, attitude is equally as important as ability.” - Harry F. Banks
  • jbaellojbaello Member Posts: 1,192
    Damn Royal you the "MAN"
  • alharlandalharland Member Posts: 35 ■■□□□□□□□□
    Thanks a lot. I just tried that and it worked first time. I was really confused as to why this wasn't working.

    I didn't even install SP1 recently, it was already installed.

    Thanks again.

    Adam.
  • royalroyal Member Posts: 3,353
    No problem, glad it worked!
    “For success, attitude is equally as important as ability.” - Harry F. Banks
  • alharlandalharland Member Posts: 35 ■■□□□□□□□□
    I have one problem with this fix though. I can't run the 'Configure And Enable Routing And Remote Access' wizard on the server, which provides me with a bit of a problem completing the exercises in the MS Press book. Any ideas how to resolve this?

    All help or advice greatly appreciated.

    Adam.
Sign In or Register to comment.