Help needed quick, can't start a service ***RESOLVED***

binarysoulbinarysoul Member Posts: 993
This is a real-world problem. Running Win2k3 Standard

We run an a specialized software and now it doesn't start. Upont trying to start the service, I get a message saying "After starting the server, the service hung in start-pending status".

I've removed and re-added the serive to the registry using the SC command. No result.

Server rebooted, no result. Tried changing it to manual and disabled, no result.

Queiried the server using SC command, it just says it failed starting.

I googled the error, no luck. Any help? icon_sad.gif

Comments

  • Silver BulletSilver Bullet Member Posts: 676
    Is said service a Windows Service or a Service that is part of the "Specialized Software"?

    From your description, it sounds like it is part of the software that you have loaded. If that is the case then you most likely will need to contact the provider of said Software. Or post the Software and Service you are having a problem with and maybe someone has experience with it.
  • Silver BulletSilver Bullet Member Posts: 676
    Does the Service Properties show any Services that it is dependent on? If so, are those services started?

    Really need more info on the Service.
  • binarysoulbinarysoul Member Posts: 993
    There are no dependencies, the serive is called policycenter, it's a Packeteer centralized software. There is a command utility within the software that allows you to add, remove, start and stop the service, I've tried them all, no go.
  • Silver BulletSilver Bullet Member Posts: 676
    Just some quick things I found were that this software will not run if IIS or SNMP serivces are running on the server.

    Their site seems to have a lot of docmentation but I would contact them if you followed their docs on setting it up and it still doesn't work.

    Maybe someone else has more insight on this software.

    Good Luck
  • blargoeblargoe Self-Described Huguenot NC, USAMember Posts: 4,174 ■■■■■■■■■□
    IT guy since 12/00

    Recent: 11/2019 - RHCSA (RHEL 7); 2/2019 - Updated VCP to 6.5 (just a few days before VMware discontinued the re-cert policy...)
    Working on: RHCE/Ansible
    Future: Probably continued Red Hat Immersion, Possibly VCAP Design, or maybe a completely different path. Depends on job demands...
  • binarysoulbinarysoul Member Posts: 993
    Thanks guys for the quick replies :) I was able to fix the issue as I found a doc on their site.

    "This problem is caused by the Windows 2003-SP1 Data Execution Protection (DEP)
    function. Avoid this problem by configuring the DEP feature to ignore/exclude the
    PtPolicyCenter.exe service from its operation."

    I just followed it and my app is up and running :)

    But I'm curious what this DEP is all about? Any thoughts?
  • seuss_ssuesseuss_ssues Member Posts: 629
    Its always best to try googling and checking the manufacturers site for docs.

    here is some info on dep

    http://support.microsoft.com/kb/875352
  • binarysoulbinarysoul Member Posts: 993
    Thanks seuss_ssues.

    I was just tired to google anything anymore
Sign In or Register to comment.