EIGRP - Configuring a Router

gabrielbtoledogabrielbtoledo Member Posts: 217
I have a question about how to configure a router using EIGRP.
On my book says:

Router(config)#router eigrp 100
Router(config-router)#network 10.0.0.0
> Specifies which network to advertise in EIGRP
.
.
.
.
.
Then on the other page says:

Router(config-router)#network 10.0.0.0 0.255.255.255 ----> Identifies which interfaces or networks to include in EIGRP. Interfaces must be configured with addresses that fall within the wildcard mask range of the network statement. A network mask can also be used here.


Now, what does the first command does exactly?
A+ Certified - Network+ - MCP (70-290)
MCSA - CCNA - Security+ (soon)

Comments

  • NetstudentNetstudent Member Posts: 1,693 ■■■□□□□□□□
    The first specifies the entire classfull range of 10.0.0.0

    So does the second, but with a Wildcard mask.


    You could have used a different wildcard mask to cover a smaller piece of the entire classfull portion.

    I have noticed in a lab environment that EIGRP doesn't like wildcard masks very much. Had some problems creating adjancenies with the wildcard masks.
    There is no place like 127.0.0.1 BUT 209.62.5.3 is my 127.0.0.1 away from 127.0.0.1!
  • gabrielbtoledogabrielbtoledo Member Posts: 217
    Well, EIGRP is a classless protocol, so I don't have to put classfull networks.
    So, the first command is in case I want to put a classfull network and the second when I want to put a classless one?
    A+ Certified - Network+ - MCP (70-290)
    MCSA - CCNA - Security+ (soon)
  • NetstudentNetstudent Member Posts: 1,693 ■■■□□□□□□□
    sorry I didn't mean you had to use classfull networks. I was just explaining that
    network 10.0.0.0 would cover all interfaces that were in the range of 10.0.0.0 - 10.255.255.255 .
    Network 10.0.0.0 0.255.255.255 does the same thing.

    It doesn't matter too much whether you are using classfull or classless addressing. This only tells which interfaces to start sending out EIGRP updates.
    There is no place like 127.0.0.1 BUT 209.62.5.3 is my 127.0.0.1 away from 127.0.0.1!
  • keenonkeenon Member Posts: 1,922 ■■■■□□□□□□
    Well, EIGRP is a classless protocol, so I don't have to put classfull networks.
    So, the first command is in case I want to put a classfull network and the second when I want to put a classless one?

    well eigrp will only act classless with the "no auto-summary" command under the routing process, you can add the wild card masks if you only want to run it specifically from a single interface and not all the interfaces on that router.

    your first command tells the router which interfaces to include in the routing process and to share from.

    normally you would use the "no auto-summary" first before adding networks under the process
    Become the stainless steel sharp knife in a drawer full of rusty spoons
  • gabrielbtoledogabrielbtoledo Member Posts: 217
    Yes, I know about the "no auto-summary" command, but I am still a little confused.
    Could somebody write down how would you configure a router using EIGRP? Just the part where you enter in global configuration mode. I want to visualize what commands you use and which order. Thanks.

    EDIT:
    Would it be:
    router eigrp 100
    no auto-summary
    eigrp log-neighbor-changes
    network 172.16.0.0
    A+ Certified - Network+ - MCP (70-290)
    MCSA - CCNA - Security+ (soon)
  • dtlokeedtlokee Member Posts: 2,378 ■■■■□□□□□□
    The problem you may encounter when configuring EIGRP is you may have 2 interfaces that fall in the same Classful network, but you only want to configure one of them to run EIGRP.

    10.1.0.0/24
    R1
    10.2.0.0/24

    Let's say we only wanted to run EIGRP on the 10.1.0.0/24 subnet and not the 10.2.0.0/24 subnet. The "network 10.0.0.0" command won't do this for us, we need to use a wildcard mask to accomplish the goal. "network 10.1.0.0 0.0.0.255" will get the job done, basically it says to match the first 2 octets of the provided network address and ignore the last 2 (the ones with the 255 in them).

    Also keep in mind the network statement does not control the subnet address that is advertised by the router, it only tells the router what interfaces to run the routing protocol on. In the previous example I could have used the "network 10.1.0.0 0.0.255.255" command to enable EIGRP on the interface connected to the 10.1.0.0/24 subnet but it would still advertise the subnet as 10.1.0.0/24 regardless of the network statement provided. (also we would need the no auto-summary command if we were crossing classful networks in out IP addressing space)
    The only easy day was yesterday!
  • NetstudentNetstudent Member Posts: 1,693 ■■■□□□□□□□
    enable
    conf t
    router eigrp 10
    no auto-sum
    network 10.0.0.0



    If you had IP's 10.1.1.1/24 10.1.2.1/24 10.1.3.1/24 and you only wanted EIGRP to advertise on one of those interfaces and not all of them.


    enable
    conf t
    router eigrp 10
    no auto-sum
    Network 10.1.2.0 0.0.0.255
    There is no place like 127.0.0.1 BUT 209.62.5.3 is my 127.0.0.1 away from 127.0.0.1!
  • gabrielbtoledogabrielbtoledo Member Posts: 217
    keenon wrote:
    your first command tells the router which interfaces to include in the routing process and to share from.
    So, EIGRP is not like RIP when you put the network you want to advertise instead of putting the interface that will advertise in IEGRP?
    A+ Certified - Network+ - MCP (70-290)
    MCSA - CCNA - Security+ (soon)
  • r_durantr_durant Member Posts: 486 ■■■□□□□□□□
    keenon wrote:
    your first command tells the router which interfaces to include in the routing process and to share from.
    So, EIGRP is not like RIP when you put the network you want to advertise instead of putting the interface that will advertise in IEGRP?

    Remember RIP is classful...well, at least v1 is, so when the command is applied it will encompass all the subnets in the classful range...with EIGRP there's more flexibility...
    CCNA (Expired...), MCSE, CWNA, BSc Computer Science
    Working on renewing CCNA!
  • gabrielbtoledogabrielbtoledo Member Posts: 217
    r_durant: Thanks, but my question now is...

    RIP - input networks that you want to be advertised.
    EIGRP - input interfaces that will advertise.

    That is my question.
    A+ Certified - Network+ - MCP (70-290)
    MCSA - CCNA - Security+ (soon)
  • NeonNoodleNeonNoodle Member Posts: 92 ■■□□□□□□□□
    r_durant: Thanks, but my question now is...

    RIP - input networks that you want to be advertised.
    EIGRP - input interfaces that will advertise.

    That is my question.

    Let me take a stab (in the dark) at this. Let's say you have two interfaces configured with the following IP addresses: 10.1.2.1/24 and 10.1.1.1/24. Suppose you only want to advertise one of the routes, say, 10.1.1.0/24, and you don't want to advertise 10.1.2.0/24. If you are using RIPv1 to route, well you have no choice but to advertise both because RIP is classful. (Type in 'network 10.1.1.0' and then do a 'show running-config' and see what's there.) If you are routing using EIGRP, then you can advertise the 10.1.1.0/24 network only--by using the 'network 10.1.1.0 0.0.0.255' statement since the wildcard mask indicates that 10.1.2.1/24 won't be a match.

    To answer your question more directly: you don't advertise interfaces, you advertise routes. CIDR allows you to be more specific in which routes you want to advertise. That's why RIPv1 and IGRP are 'going the way of the dodo'.
    I recognize the lion by his paw.
    --Jacob Bernoulli
  • r_durantr_durant Member Posts: 486 ■■■□□□□□□□
    Well, this is how I look at it...and it seems similar to how some of the others explained

    I personally, wouldn't say that with EIGRP you input interfaces that would advertise, but if you have two or more interfaces (physical or otherwise) that would fall in the same classful network, but are subnetted and you only wanted to advertise one subnet, I would use Netstudent's example....
    If you had IP's 10.1.1.1/24 10.1.2.1/24 10.1.3.1/24 and you only wanted EIGRP to advertise on one of those interfaces and not all of them.

    enable
    conf t
    router eigrp 10
    no auto-sum
    Network 10.1.2.0 0.0.0.255

    And this would only advertise the 10.1.2.0 subnet and not the other 2.

    I guess it maybe a matter of interpretation...

    What i'm saying is that i wouldn't refer to it by the interface, because you can also have sub-interfaces on one physical interface...so i look at it from the subnet point of view

    Your interpretation may not be wrong, and i'm not saying it is, but i'd say be careful with how u refer to them...

    I'm not sure if you understand where i'm coming from....
    CCNA (Expired...), MCSE, CWNA, BSc Computer Science
    Working on renewing CCNA!
  • dtlokeedtlokee Member Posts: 2,378 ■■■■□□□□□□
    The behavior of the network command for all IGPs (RIP, EIGRP, OSPF, et al) is to specify what interfaces we want to send and receive updates on. It has no bearing on what address and mask is advertised regardless of the protocol.
    Interface E0
     ip address 10.1.1.1 255.255.255.0
    !
    Interface E1
     ip address 10.2.1.1 255.255.255.0
    

    Assuming that is the configuration for the router interfaces, there are a number of combinations that we can use to tell the router to send updates through the interface.
    router eigrp 10
     network 10.0.0.0
    
    --- or ---
    
    router eigrp 10
     network 0.0.0.0 255.255.255.255
    
    --- or ----
    
    router eigrp 10
     network 10.1.1.0 0.0.0.255
     network 10.2.1.0 0.0.0.255
    
    ---- or (my favorite) ----
    
    rotuer eigrp 10
     network 10.1.1.1 0.0.0.0
     network 10.2.1.1 0.0.0.0
    

    So which one is correct? they all are. They all do the same thing, tell the router to send updates through both int E0 and E1, and to advertise the subnets 10.1.1.0/24 and 10.2.1.0/24. Keep in mind the network command does not tellthe router what to advertise, just which interfaces to advertise.

    Also there's some confusion about auto-summary here. Since all router interfaces are int the major network 10.0.0.0 it is not needed in this example. It's generally a good idea to disable it anyhow, but you must understand why. If the router had interfaces connected to more than one major network it would be needed, but in this case it's not.
    The only easy day was yesterday!
  • gabrielbtoledogabrielbtoledo Member Posts: 217
    dtlokee wrote:
    The behavior of the network command for all IGPs (RIP, EIGRP, OSPF, et al) is to specify what interfaces we want to send and receive updates on. It has no bearing on what address and mask is advertised regardless of the protocol.

    Thanks, that was the answer I was looking for. So, I wasn't too crazy about my theory.
    When I said to input the interfaces that will advertise, I meant to say... input the interfaces (networks=ip addresses configured to the interface) that will send and receive advertisement (updates). I just didn't know how to express myself.
    dtlokee wrote:
    Interface E0
     ip address 10.1.1.1 255.255.255.0
    !
    Interface E1
     ip address 10.2.1.1 255.255.255.0
    

    Assuming that is the configuration for the router interfaces, there are a number of combinations that we can use to tell the router to send updates through the interface.
    router eigrp 10
     network 10.0.0.0
    
    --- or ---
    
    router eigrp 10
     network 0.0.0.0 255.255.255.255
    
    --- or ----
    
    router eigrp 10
     network 10.1.1.0 0.0.0.255
     network 10.2.1.0 0.0.0.255
    
    ---- or (my favorite) ----
    
    rotuer eigrp 10
     network 10.1.1.1 0.0.0.0
     network 10.2.1.1 0.0.0.0
    

    So which one is correct? they all are. They all do the same thing, tell the router to send updates through both int E0 and E1, and to advertise the subnets 10.1.1.0/24 and 10.2.1.0/24. Keep in mind the network command does not tellthe router what to advertise, just which interfaces to advertise.

    Also there's some confusion about auto-summary here. Since all router interfaces are int the major network 10.0.0.0 it is not needed in this example. It's generally a good idea to disable it anyhow, but you must understand why. If the router had interfaces connected to more than one major network it would be needed, but in this case it's not.

    So, when you input the network address (we talking about EIGRP) to be advertised and you don't specify the mask or wild card mask, we are meaning the network as a whole (classful), however if we want to advertise a subnetwork, then we would input the mask or wild card mask, right?
    Also, in your last example:
    network 10.1.1.1 0.0.0.0
    network 10.2.1.1 0.0.0.0
    We use this way when we want an exactly match, right?
    A+ Certified - Network+ - MCP (70-290)
    MCSA - CCNA - Security+ (soon)
  • dtlokeedtlokee Member Posts: 2,378 ■■■■□□□□□□

    So, when you input the network address (we talking about EIGRP) to be advertised and you don't specify the mask or wild card mask, we are meaning the network as a whole (classful), however if we want to advertise a subnetwork, then we would input the mask or wild card mask, right?

    When you leave out the wildcard mask it will default to using the major classful network to identify what interfaces will send updates. This may match more interfaces than you require, so you have 2 options. Option 1 is to use a wildcard mask to limit the match to only the required interfaces, or disable EIGRP packets on the ones you don't need EIGRP using the passive-interface command. Again, the network command has no bearing on what is advertised, major network, subnetwork... what is advertised comes from the interface IP and subnet mask. The network command only tells the router what interfaces to include in EIGRP
    Also, in your last example:
    network 10.1.1.1 0.0.0.0
    network 10.2.1.1 0.0.0.0
    We use this way when we want an exactly match, right?
    [/quote]

    Yes this will match the only the interfaces with the IP address 10.1.1.1 and 10.2.1.1, all other interfaces will not be matched.
    The only easy day was yesterday!
  • r_durantr_durant Member Posts: 486 ■■■□□□□□□□
    dtlokee...so my question now is... :D

    Am I wrong in the way i look at it? I understand fully what you explained, but i just look at it from the subnet and not the interface.

    The way i see it, an interface will have an address, so that goes without saying...it's tied to the interface already...so if i want to advertise subnet x, it's already on that specific interface??

    Maybe it's just how i interpret it or try to explain it, but i understand how and why it's done...
    CCNA (Expired...), MCSE, CWNA, BSc Computer Science
    Working on renewing CCNA!
  • rjbarlowrjbarlow Member Posts: 411
    For my learning in order to "cut" one interface from advertise the routes in EIGRP is possible to issue the "router(config-router)#passive-interface <interface>", that in EIGRP means that the specified interface not send and not learn routes.
    But if is possible to use wildcard mask with the "network" command in EIGRP I think it follow the rules of the wildcardmask too.
    Pork 3
    Maindrian's music

    WIP: 70-236, 70-293 and MCSE.
  • gabrielbtoledogabrielbtoledo Member Posts: 217
    r_durant wrote:
    dtlokee...so my question now is... :D

    Am I wrong in the way i look at it? I understand fully what you explained, but i just look at it from the subnet and not the interface.

    The way i see it, an interface will have an address, so that goes without saying...it's tied to the interface already...so if i want to advertise subnet x, it's already on that specific interface??

    Maybe it's just how i interpret it or try to explain it, but i understand how and why it's done...
    I just kept hitting the same key because my book says interface and not network. That is why I want to understand the official concept.
    My mistake what the concept of advertising was different from RIP to EIGRP.
    In RIP I thought you would input the networks you want to advertise and with EIGRP you would input the interfaces you want to send and receive the advertisements (not sure if is the right terminology).
    Anyway, now I understand the concept and it doesn't matter the protocol, you will always input the interfaces you want to advertise.
    My other mistake was not know that you can configure EIGRP with the network command without mask or wild card mask.

    Thanks a bunch.
    A+ Certified - Network+ - MCP (70-290)
    MCSA - CCNA - Security+ (soon)
  • r_durantr_durant Member Posts: 486 ■■■□□□□□□□
    rjbarlow wrote:
    For my learning in order to "cut" one interface from advertise the routes in EIGRP is possible to issue the "router(config-router)#passive-interface <interface>", that in EIGRP means that the specified interface not send and not learn routes.
    But if is possible to use wildcard mask with the "network" command in EIGRP I think it follow the rules of the wildcardmask too.

    Isn't there something about the passive-interface still being learnt by the other routers, even though the interface itself does not advertise or learn routes??
    CCNA (Expired...), MCSE, CWNA, BSc Computer Science
    Working on renewing CCNA!
  • NetstudentNetstudent Member Posts: 1,693 ■■■□□□□□□□
    IN RIP a passive interface revieves routes but does not advertise them. In EIGRP, a passive interface niether sends or recieves updates. An Adjacency cannot be formed in EIGRP with passive interfaces.
    There is no place like 127.0.0.1 BUT 209.62.5.3 is my 127.0.0.1 away from 127.0.0.1!
  • r_durantr_durant Member Posts: 486 ■■■□□□□□□□
    Ah ok...i knew i read or heard about it, i just mixed up the two... :)
    CCNA (Expired...), MCSE, CWNA, BSc Computer Science
    Working on renewing CCNA!
  • rjbarlowrjbarlow Member Posts: 411
    I add that in OSPF if You don't match the specific IP address of the interface You want to active to the routing protocol through the command:

    router(config-router)#network <ip address> <wilcardmask> area x

    that interface stay inactive.
    Thus I think so also for EIGRP. I think when You use the wilcard mask You have to match the specific ip address of the interface, while in the routing protocols that do not permit wildcard mask statements, the "network" command is not needed to match exactly the ip address of the interface, but is sufficient it is in its range, considered a classful subnet mask.
    Pork 3
    Maindrian's music

    WIP: 70-236, 70-293 and MCSE.
Sign In or Register to comment.