EIGRP problem
m0rpheus
Member Posts: 26 ■□□□□□□□□□
in CCNA & CCENT
Hey guys, I have the following problem. Here is my brief lab setup:
[Internet] ---- [DSL modem] (192.168.1.1) ---- (E0 192.168.1.44) [2514] (E1 10.1.2.1) ---- (10.1.2.2) [PC]
From the 2514 I can ping the DSL router and behind (public hosts). But from the PC I can only ping as far as 192.168.1.44. When I try 192.168.1.1 it times out. Here is my sh run. If anyone can tell me what the problem is I would really appreciate it. I spent hours on this problem.
Current configuration : 927 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname r2514
!
enable secret 5 $1$4Jlz$fWUpLwqzgOnr/gwOwaRwasgRvf
!
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
description Connected to Internet
ip address dhcp
ip nat outside
!
interface Ethernet1
Connected to PC
ip address 10.1.2.1 255.255.255.0
ip nat inside
!
interface Serial0
description Connected to r2503 via Serial
ip address 10.1.1.2 255.255.255.0
ip nat inside
encapsulation ppp
no fair-queue
clockrate 64000
!
interface Serial1
no ip address
shutdown
!
router eigrp 1
network 10.0.0.0
network 192.168.1.0
auto-summary
no eigrp log-neighbor-changes
!
ip nat inside source list 1 interface Ethernet0 overload
ip classless
no ip http server
[Internet] ---- [DSL modem] (192.168.1.1) ---- (E0 192.168.1.44) [2514] (E1 10.1.2.1) ---- (10.1.2.2) [PC]
From the 2514 I can ping the DSL router and behind (public hosts). But from the PC I can only ping as far as 192.168.1.44. When I try 192.168.1.1 it times out. Here is my sh run. If anyone can tell me what the problem is I would really appreciate it. I spent hours on this problem.
Current configuration : 927 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname r2514
!
enable secret 5 $1$4Jlz$fWUpLwqzgOnr/gwOwaRwasgRvf
!
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
description Connected to Internet
ip address dhcp
ip nat outside
!
interface Ethernet1
Connected to PC
ip address 10.1.2.1 255.255.255.0
ip nat inside
!
interface Serial0
description Connected to r2503 via Serial
ip address 10.1.1.2 255.255.255.0
ip nat inside
encapsulation ppp
no fair-queue
clockrate 64000
!
interface Serial1
no ip address
shutdown
!
router eigrp 1
network 10.0.0.0
network 192.168.1.0
auto-summary
no eigrp log-neighbor-changes
!
ip nat inside source list 1 interface Ethernet0 overload
ip classless
no ip http server
You can if you think you can
Comments
-
Netstudent Member Posts: 1,693 ■■■□□□□□□□Where is your access-list for NAT? you are overloading E0 with a source list 1, but I don't see an ACL in the config. try adding this to the config:
access-list 1 permit ip 10.1.2.0 0.0.0.255
E1 10.1.2.1) ---- (10.1.2.2) [PC]There is no place like 127.0.0.1 BUT 209.62.5.3 is my 127.0.0.1 away from 127.0.0.1! -
m0rpheus Member Posts: 26 ■□□□□□□□□□NetStudent, thanks! I totally forgot to set up the ACL
I was suspecting the problem to be in the routing protocol so I wasn't even looking for the ACL.You can if you think you can -
Netstudent Member Posts: 1,693 ■■■□□□□□□□no worries man. Why do you think I am sitting here on a Saturday night? besides the fact that I am a computer nerd. NAT can be tricky especially when you first start to work with it.There is no place like 127.0.0.1 BUT 209.62.5.3 is my 127.0.0.1 away from 127.0.0.1!
-
Cessation Member Posts: 326m0rpheus wrote:NetStudent, thanks! I totally forgot to set up the ACL
I was suspecting the problem to be in the routing protocol so I wasn't even looking for the ACL.
This was Great!
This helped me out too.
Although I havent just yet got to EIGRP I was not even thinking about the ACL.
Outside the box thinking..A+, MCP(270,290), CCNA 2008.
Working back on my CCNA and then possibly CCNP.