BGP CASE STUDY problem, help

CGDreamCGDream Member Posts: 14 ■□□□□□□□□□
my ISP configuration is this :
ISP1A#show run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname ISP1A
!
!
ip subnet-zero
!
!
!
interface Ethernet0
ip address 200.0.3.1 255.255.255.0
no ip directed-broadcast
!
interface Ethernet1
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0
ip address 200.0.2.2 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
!
interface Serial1
ip address 200.0.1.2 255.255.255.0
no ip directed-broadcast
!
router bgp 100
no synchronization
network 200.0.3.0
neighbor 200.0.1.1 remote-as 200
neighbor 200.0.2.1 remote-as 200
!
ip classless
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end

and my Sanjose 3 configuration is this:
Sanjose3#show run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Sanjose3
!
!
ip subnet-zero
!
!
!
interface Loopback0
no ip address
no ip directed-broadcast
!
interface Ethernet0
ip address 172.16.0.2 255.255.255.252
no ip directed-broadcast
!
interface Serial0
ip address 200.0.2.1 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
clockrate 56000
!
interface Serial1
ip address 200.0.1.1 255.255.255.0
no ip directed-broadcast
clockrate 56000
!
router ospf 1
network 172.16.0.0 0.0.0.3 area 0
default-information originate always
!
router bgp 200
no synchronization
network 172.16.0.0 mask 255.255.255.252
neighbor 200.0.1.2 remote-as 100
neighbor 200.0.2.2 remote-as 100
!
ip classless
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end

my OSPF areas which are connected to Sanjose3 cannot ping ISP. eaven all my areas can ping each other.

so what did i miss ??????

Comments

  • techman-aka-Formattechman-aka-Format Inactive Imported Users Posts: 59 ■■□□□□□□□□
    hey CG, it looks like you have some issues. o.k. I think Im gonna need a little more info. are you multihoming youre ISP? if so then all you need to put in the ISP configs is the bgp compare med command, which will mutlihome the ISP. plus dont see youre metric statements either. cause when youre mutlihoming two ISP links you have to specify the metrics. (set metric #) remember youre only running BGP on the outside, the internal network runs OSPF. Ill need to see the rest of youre OSPF configs. it looks like you only have one area configured for OSPF, and that's the backbone. where is youre NAT configs? plus remember when advertising a default route using the internal protocol, the comand should go on the ASBR, or firewall router. and I didnt see any summarization. if you have more than one area running OSPF and have loopbacks, then you have to summarize those networks into the core. I hope this helps, Ill have more info for you tomorrow CG, techman
    information belongs to the public! hack the planet!
Sign In or Register to comment.