Options

problem setting up rip

sprinkl3ssprinkl3s Member Posts: 92 ■■□□□□□□□□
I am using the sybex virtual lab, and for some reason its only letting me setup one network to broadcast the net info. it worked fine for me yesterday, but here is what i have.
router2(config)#router rip
router2(config-router)#net 172.16.11.0
router2(config-router)#net 172.16.20.0
router2(config-router)#exit
%SYS-5-CONFIG_I: Configured from console by console
router2#sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router2
!
!
!
!
interface Ethernet0
ip address 172.16.11.1 255.255.255.0
!
interface Serial0
ip address 172.16.20.1 255.255.255.0
!
!
interface Serial1
no ip address
!
shutdown
!
router rip 
 network 172.16.20.0
!
no ip classless 
!
!
line con 0
line aux 0
line vty 0 4
end

router2#
[/code]

Comments

  • Options
    NetstudentNetstudent Member Posts: 1,693 ■■■□□□□□□□
    What is the output for show ip prot? Looks like a bug.
    There is no place like 127.0.0.1 BUT 209.62.5.3 is my 127.0.0.1 away from 127.0.0.1!
  • Options
    sprinkl3ssprinkl3s Member Posts: 92 ■■□□□□□□□□
    here is what i get from sh ip prot
    router2#sh ip prot
    
    Routing Protocol is "rip"
      Sending updates every 30 seconds, next due in 25 seconds
      Invalid after 180 seconds, hold down 180, flushed after 240
      Outgoing update filter list for all interfaces is not set
      Incoming update filter list for all interfaces is not set
      Redistributing: rip
      Default version control: send version 1, receive any version
        Interface        Send  Recv   Key-chain
        Ethernet0        1     1 2
        Serial0          1     1 2
      Routing for Networks:
     172.16.20.0
    Routing Information Sources:
    Gateway        Distance         Last Update
    172.16.20.2      120            00:00:03
    Distance: (default is 120)
    
  • Options
    bighornsheepbighornsheep Member Posts: 1,506
    After "router rip" you also need "version 2", it's version 1 by default, and it will not send subnet mask information.
    Jack of all trades, master of none
  • Options
    sprinkl3ssprinkl3s Member Posts: 92 ■■□□□□□□□□
    haven't gone that far yet, i believe thats part of the next lesson. but could that be related to whats going on here?
  • Options
    bighornsheepbighornsheep Member Posts: 1,506
    Yes, because you are using 172.16.x.x IP addresses, RIPv1 will use the default subnet mask of 255.255.0.0 for the two subnets, but in fact, your two subnets are 172.16.11.0 and 172.16.20.0 with mask of 255.255.255.0, in RIPv1, it will simply advertise the subnets in the network 172.16.0.0.

    Do a 'no router rip' to clear your RIP settings, do a 'router rip' again, and then type 'version 2' and then type your network 172.16.11.0 and 172.16.20.0, actually, I think if you just type network 172.16.0.0, it will find your two subnets automatically.

    Good luck.
    Jack of all trades, master of none
  • Options
    sprinkl3ssprinkl3s Member Posts: 92 ■■□□□□□□□□
    when i do this i get the following:
    router2(config)#router rip
    router2(config-router)#version 2
                           ^
    
    % Invalid input detected at '^' marker.
    
    router2(config-router)#
    
  • Options
    bighornsheepbighornsheep Member Posts: 1,506
    That's really weird, I've never seen that before....let's try something else, in your interface configuration (both interfaces), try
    "ip rip send version 1 2"
    Jack of all trades, master of none
  • Options
    sprinkl3ssprinkl3s Member Posts: 92 ■■□□□□□□□□
    when i do this i get:
    router2#copy run start
    Building configuration...
    
    [OK]
    router2#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    router2(config)#int e0
    router2(config-if)#ip rip send version 1 2
                          ^
    
    % Invalid input detected at '^' marker.
    

    wonder if its because the sim is messed up
  • Options
    bighornsheepbighornsheep Member Posts: 1,506
    oh my....I totally missed out the whole thing about "sybex virtual lab".....there should be a chart of features with your simulator, check to see if RIPv2 is there, if not, you will have to change your IP addresses to something else. 172.16.0.0 and 172.17.0.0 for example.

    Unfortunately, that's the sad truth with simulators, they just don't cut it sometimes...geez, it's just RIPv2 we're talking about...I'm glad I spent the extra dough on real hardware.
    Jack of all trades, master of none
  • Options
    sprinkl3ssprinkl3s Member Posts: 92 ■■□□□□□□□□
    i plan on scoping ebay shortly when i have some money, its amazing how much 9 month old kids cost these days lol...
  • Options
    NetstudentNetstudent Member Posts: 1,693 ■■■□□□□□□□
    Yes, because you are using 172.16.x.x IP addresses, RIPv1 will use the default subnet mask of 255.255.0.0 for the two subnets, but in fact, your two subnets are 172.16.11.0 and 172.16.20.0 with mask of 255.255.255.0, in RIPv1, it will simply advertise the subnets in the network 172.16.0.0.

    Do a 'no router rip' to clear your RIP settings, do a 'router rip' again, and then type 'version 2' and then type your network 172.16.11.0 and 172.16.20.0, actually, I think if you just type network 172.16.0.0, it will find your two subnets automatically.

    Good luck.

    RIPv1 will only auto summarize at another major classful network boundry. Meaning he can use 255.255.255.0 for his networks and they will not be auto summarized as long as he continues to use 172.16.0.0 as the major classful network. When he begins to implement another network like 172.15.0.0, then 172.16.20.0 will summarize to 172.16.0.0. So i do not think RIPv1 is the problem. The recieving router that recieves the routing update will assume that each major network has the same subnet mask in the update as it's local interface. This "assuming behavior" is caused from not sending a subnet mask. as long as he uses /24 across the entire network of 172.16.0.0, he should be fine.

    So having said that, I still think it is a bug because you should be routing for the other network and it should be in your running-config.
    There is no place like 127.0.0.1 BUT 209.62.5.3 is my 127.0.0.1 away from 127.0.0.1!
  • Options
    dtlokeedtlokee Member Posts: 2,378 ■■■■□□□□□□
    Netstudent wrote:
    Yes, because you are using 172.16.x.x IP addresses, RIPv1 will use the default subnet mask of 255.255.0.0 for the two subnets, but in fact, your two subnets are 172.16.11.0 and 172.16.20.0 with mask of 255.255.255.0, in RIPv1, it will simply advertise the subnets in the network 172.16.0.0.

    Do a 'no router rip' to clear your RIP settings, do a 'router rip' again, and then type 'version 2' and then type your network 172.16.11.0 and 172.16.20.0, actually, I think if you just type network 172.16.0.0, it will find your two subnets automatically.

    Good luck.

    RIPv1 will only auto summarize at another major classful network boundry. Meaning he can use 255.255.255.0 for his networks and they will not be auto summarized as long as he continues to use 172.16.0.0 as the major classful network. When he begins to implement another network like 172.15.0.0, then 172.16.20.0 will summarize to 172.16.0.0. So i do not think RIPv1 is the problem. The recieving router that recieves the routing update will assume that each major network has the same subnet mask in the update as it's local interface. This "assuming behavior" is caused from not sending a subnet mask. as long as he uses /24 across the entire network of 172.16.0.0, he should be fine.

    So having said that, I still think it is a bug because you should be routing for the other network and it should be in your running-config.

    Bah, bad Netstudent icon_wink.gif

    The network command for RIP is always classful, if you type in "network 172.16.10.0" it will become "network 172.16.0.0" in the running config. If you did "network 172.16.10.0" and "network 172.16.20.0" in since they are both subents of the same classful network they bouth truncate to "network 172.16.0.0" hence the output in you see.
    The only easy day was yesterday!
  • Options
    NetstudentNetstudent Member Posts: 1,693 ■■■□□□□□□□
    Well maybe I'm thinking of the actual routing updates then. So truncation and auto-summarization are two different things. I was referring to auto-summarization behavior on the network. Maybe I'm just flat out wrong. icon_lol.gif hopefully not!

    I realize he should have done network 172.16.0.0, but I still do not see the truncated classful network in the running-config.
    There is no place like 127.0.0.1 BUT 209.62.5.3 is my 127.0.0.1 away from 127.0.0.1!
  • Options
    dtlokeedtlokee Member Posts: 2,378 ■■■■□□□□□□
    Auto summary is only done when the router is going to advertise a subnet of one classful network out an interface that has an address in a different classful network, like 172.16.20.0/24 advertised out an interface with the IP 192.168.100.1 would result in the router advertising 172.16.0.0/16 instead of the 172.16.20.0/24 subnet
    The only easy day was yesterday!
  • Options
    NetstudentNetstudent Member Posts: 1,693 ■■■□□□□□□□
    Well thats kinda what I was trying to get across. icon_confused.gif :P
    There is no place like 127.0.0.1 BUT 209.62.5.3 is my 127.0.0.1 away from 127.0.0.1!
  • Options
    sprinkl3ssprinkl3s Member Posts: 92 ■■□□□□□□□□
    ok, can i get a cisco newbie explanation on what yall are talkin about... lol.

    What i'm getting out of this is that i should be using a /16 (default for class b) mask instead of the /24 mask that the sybex book has me doin?
  • Options
    GregDGregD Member Posts: 25 ■□□□□□□□□□
    sprinkl3s wrote:
    ok, can i get a cisco newbie explanation on what yall are talkin about... lol.

    What i'm getting out of this is that i should be using a /16 (default for class b) mask instead of the /24 mask that the sybex book has me doin?
    It looks like the simulator is bugged. It should show network 172.16.0.0 in the running config - not 172.16.20.0

    As dtlokee said, the network command in rip is classful - meaning if you type in network 172.16.whatever.whatever, it should truncate it to 172.16.0.0 - and would, on a real router. For some reason, according to the sh run you posted, it has 172.16.20.0 as the network.

    Try typing in network 172.16.0.0 in the rip config and see what happens.
    CCNA - Complete
    CCNP - BCMSN, ONT Complete.

    Up Next - ISCW, BSCI
  • Options
    bighornsheepbighornsheep Member Posts: 1,506
    GregD wrote:
    Try typing in network 172.16.0.0 in the rip config and see what happens.

    It doesn't matter, RIP (v1 AND v2) are both technically classful, but v2 will send subnet mask information with the advertisements, his problem is that he's using subnets beyond the standard subnet mask which requires subnet mask information to be sent, which his simulator does not support because it only has RIPv1.
    sprinkl3s wrote:
    ok, can i get a cisco newbie explanation on what yall are talkin about... lol.

    What i'm getting out of this is that i should be using a /16 (default for class b) mask instead of the /24 mask that the sybex book has me doin?

    Auto summary is kinda like saying, "now you cisco router which costed me xxx amount of money, go ahead and figure out if there's a simpler way to address my networks", it's called the summary address, you can read more about it in your CCNA prep material. Basically, it figures out the network address of the highest order bits in several blocks of IP addresses.

    In what you're trying to right now, like I'd said, try the same configuration you have now, but use default class B addresses and see if it works. ie. 172.16.0.0 and 172.17.0.0 with subnet mask 255.255.0.0

    If you still don't see 'network 172.16.0.0' and 'network 172.17.0.0' in your show running-config, there's something completely messed up with your simulator.
    Jack of all trades, master of none
  • Options
    GregDGregD Member Posts: 25 ■□□□□□□□□□
    GregD wrote:
    Try typing in network 172.16.0.0 in the rip config and see what happens.

    It doesn't matter, RIP (v1 AND v2) are both technically classful, but v2 will send subnet mask information with the advertisements, his problem is that he's using subnets beyond the standard subnet mask which requires subnet mask information to be sent, which his simulator does not support because it only has RIPv1.

    Look at his show run. It has 172.16.20.0 in the network list. It should not show up like that - typing in network 172.16.20.0 should result in the running config showing 172.16.0.0

    The simulator is not truncating it properly.
    CCNA - Complete
    CCNP - BCMSN, ONT Complete.

    Up Next - ISCW, BSCI
  • Options
    dtlokeedtlokee Member Posts: 2,378 ■■■■□□□□□□

    It doesn't matter, RIP (v1 AND v2) are both technically classful, but v2 will send subnet mask information with the advertisements, his problem is that he's using subnets beyond the standard subnet mask which requires subnet mask information to be sent, which his simulator does not support because it only has RIPv1.

    RIP v2 is classless, not classful. By definition a classless protocol is one that carries the mask in the update. The network command expects a classful network address, if you provide a subnet, it will truncate it to the classful boundry. Also to force RIPv2 to be completely support classless operation you need to use the "no auto-summary" router configuration mode command, otherwise it will truncate advertisements to the major network boundry when crossing from one classful network, to another classful network.
    The only easy day was yesterday!
Sign In or Register to comment.