Options

trunking 2900 and 2950

Aquabat [banned]Aquabat [banned] Inactive Imported Users Posts: 299
i must be a retard cause i can't figure this out. using fa0/12 on 2900 and fa0/24 on 2950. both speed 100 and duplex auto , trying to ping from 0.1 on 2950 to 0.2 on 2900

2900(config-if)#
00:34:26: %LINK-4-ERROR: FastEthernet0/12 is experiencing errors

2900:

version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2900
!
enable secret 5 $1$tUhL$uqYWHUeVKAngeO2MrOukp1
enable password cisco1
!
!ip subnet-zero
no ip domain-lookup
!!
interface FastEthernet0/1
switchport access vlan 2
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 2
spanning-tree portfast
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
duplex full
speed 100
switchport mode trunk
!
interface VLAN1
no ip directed-broadcast
no ip route-cache
!
interface VLAN2
ip address 192.168.0.2 255.255.255.0
no ip directed-broadcast
no ip route-cache
shutdown
!
interface VLAN22
no ip directed-broadcast
no ip route-cache
shutdown
!
ip default-gateway 192.168.0.1
!



2950:

version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2950
!
enable secret 5 $1$h9Bq$22IuQ4sNEvuXk.7Zki5B4.
enable password cisco1
!
ip subnet-zero
!
no ip domain-lookup
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
switchport access vlan 2
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 2
spanning-tree portfast
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
speed 100
duplex full
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
switchport mode trunk
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan2
ip address 192.168.0.1 255.255.255.0
no ip route-cache
i herd u leik mudkips lol

Comments

  • Options
    mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    The 2950 only supports dot1q

    The 2900 probably defaults to ISL -- depending on the version of 2900, you might support dot1q encapsulation already, or be able to upgrade to a switch IOS that does.

    You are using a cross-over cable, right?
    :mike: Cisco Certifications -- Collect the Entire Set!
  • Options
    Aquabat [banned]Aquabat [banned] Inactive Imported Users Posts: 299
    yea it's an o-xver, i figuered it might be encap.

    as i recall there is no encap command on 2950 since it's only dot1q. i'll tryt to encap on the 2900. This makes me feel so stupid, lo

    THanks for the help chief
    i herd u leik mudkips lol
  • Options
    r_durantr_durant Member Posts: 486 ■■■□□□□□□□
    Is the VLAN2 interface shutdown that you're trying to ping?

    !
    interface VLAN2
    ip address 192.168.0.2 255.255.255.0
    no ip directed-broadcast
    no ip route-cache
    shutdown
    !
    CCNA (Expired...), MCSE, CWNA, BSc Computer Science
    Working on renewing CCNA!
  • Options
    Aquabat [banned]Aquabat [banned] Inactive Imported Users Posts: 299
    yes that too.

    i run a no shut on my int vlan 2 but it still says administravily shut. even though i no shut it.

    any ideas?
    i herd u leik mudkips lol
  • Options
    networker050184networker050184 Mod Posts: 11,962 Mod
    Try to shut int vlan 1 first then no shut int vlan 2.
    An expert is a man who has made all the mistakes which can be made.
  • Options
    Aquabat [banned]Aquabat [banned] Inactive Imported Users Posts: 299
    i will once i get home. Do you know if the 2900 defaults to IEEE?

    i tihnk my ios is buggin on it also. cause i get the

    encap - incomplete command
    encapsulation - never heard of this command

    output, i hate that. ya know how to tab complete it and it doesn't work. but it still says incomplete command. so annoying icon_redface.gif
    i herd u leik mudkips lol
  • Options
    networker050184networker050184 Mod Posts: 11,962 Mod
    If the switch only supports one type of encapsulation the command is not available.
    An expert is a man who has made all the mistakes which can be made.
  • Options
    sunil_vishnanisunil_vishnani Member Posts: 7 ■□□□□□□□□□
    use
    interface fast 0/12
    "switchport mode trunk
    switchport trunk encapsulating ("dot1q or isl")

    make bot the interface force to full duplex , 100 mb

    Before unshutting vlan 2 make the trunk between both the switch up and create the VLAN2 in vlan database .
    config t
    vlan database
    vlan 2

    Do sh vlan and check if you are able to see vlan 2 created in the output and then unshut the VLAN svi

    Int vlan 2
    no shut

    try this out
  • Options
    mwgoodmwgood Member Posts: 293
    Keep in mind that a layer-2 only switch only supports a single management vlan interface. Typically, this is going to be vlan 1 unless modified.

    Just as a suggestion - you may want to move your switch IPs over to vlan 1 on both sides.

    The 3550 & above would work quite differently.
  • Options
    kafifi13kafifi13 Member Posts: 259
    Aquabat wrote:
    yes that too.

    i run a no shut on my int vlan 2 but it still says administravily shut. even though i no shut it.

    any ideas?

    Interesting. Mine does the same exact thing.
Sign In or Register to comment.