Redistribution config...

rakemrakem Member Posts: 800
hey everyone... i have the following network configured in dynamips:

redistributionnetwork.jpg

I have configured redistribution and everything seems to be working correctly but i just wanted some feedback, to make sure i have configured everything correctly

So as you can see there are three sections of the network all running different routing protocols.
So pretty much everything joins back to R1. So i have R1 running all three protocols, OSPF, RIP and EIGRP.

I have RIP and EIGRP redistributing into OSPF and EIGRP redistributing into RIP, here is the running config on R1:

Building configuration...

Current configuration : 3116 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
!
!
multilink bundle-name authenticated
!
interface FastEthernet0/0
ip address 10.1.28.1 255.255.255.252
duplex half
!
interface Serial1/0
ip address 10.1.21.1 255.255.255.0
ip ospf network non-broadcast
ip ospf priority 2
no fair-queue
serial restart-delay 0
clock rate 64000
!
interface Serial2/0
ip address 10.1.22.1 255.255.255.0
ip ospf network non-broadcast
ip ospf priority 2
serial restart-delay 0
clock rate 64000
!
!
interface Serial3/0
ip address 192.168.1.2 255.255.255.248
encapsulation frame-relay
serial restart-delay 0
frame-relay lmi-type ansi
!
!
router eigrp 20
network 10.1.28.0 0.0.0.3
no auto-summary
!
router ospf 1
log-adjacency-changes
redistribute eigrp 20 metric 150 subnets
redistribute rip metric 200
passive-interface Serial3/0
network 10.1.21.0 0.0.0.255 area 0
network 10.1.22.0 0.0.0.255 area 0
network 10.1.28.0 0.0.0.3 area 6
network 192.168.1.0 0.0.0.3 area 5
neighbor 10.1.22.2
neighbor 10.1.21.2

!
router rip
redistribute eigrp 20 metric 5
network 192.168.1.0
!



all devices have connectivity as i can ping anything from anything. So just wanna make sure that this initial config is the right way to go about redistribution.

The only thing im not to sure on so far is the metric config for redistributed networks. I read that it should be higher than internal routes to avoid any suboptimal routing or potential loops... is this correct?

Any suggestions, comments?
CCIE# 38186
showroute.net

Comments

  • dtlokeedtlokee Member Posts: 2,378 ■■■■□□□□□□
    It seems you are only redistributing between OSPF and RIP, not with EIGRP. The part about the higher metric is correct, you don't want the redistributed routes to become better than the internal route. In your network since you're only redistributing at one point it really doesn't matter waht metric you assign, if you had 2 routers connecting OPSF to RIP and you were redistributing on both, then metric would become more important (along with administrative distance, and using route maps to selectively filter routes)
    The only easy day was yesterday!
  • rakemrakem Member Posts: 800
    dtlokee wrote:
    It seems you are only redistributing between OSPF and RIP, not with EIGRP.

    Would it be necessary to redistribute the other routes into EIGRP? Currently i just have the EIGRP network configured with a default route to R1.
    CCIE# 38186
    showroute.net
  • rossonieri#1rossonieri#1 Member Posts: 799 ■■■□□□□□□□
    hi rakem,

    you can redistribute any to any as many as you like,
    but the rule is still beware of routing-loop, and accidently creating a sub-optimum path -
    just like the one in your picture and your config will create a routing-loop (from R1 stand-point),
    and will create a sub-optimum path if you also want to redistribute ospf into eigrp.

    from R1 --> R5 and R3 --> there should be a passive interface or at least a distribute-list,
    but why you put your passive interface on the FR interface - the one goes to RIP?

    CMIIW.

    cheers.
    the More I know, that is more and More I dont know.
Sign In or Register to comment.