Options

Frame Relay switching between two routers. help pls

GeoDudeGeoDude Member Posts: 5 ■□□□□□□□□□
Hey guys.

I have a problem. I have a Cisco 2511 and Cisco 2503 router. Both have two serial interfaces each. I'm trying to tunnel frame-relay over both of them so i can in effect have a cloud containing 4 serial interfaces.


###############
Cisco2511 (Router A)
(Have included the relevant bits)
###############

frame-relay switching
!
!
!
interface Loopback1
ip address 172.16.1.1 255.255.255.252
!
interface Tunnel1
ip unnumbered Loopback1
tunnel source Ethernet0
tunnel destination 192.168.1.251
!
interface Ethernet0
ip address 192.168.1.252 255.255.255.0
no keepalive
no cdp enable
!
interface Serial0
no ip address
encapsulation frame-relay
no ip mroute-cache
clockrate 2000000
no fair-queue
frame-relay intf-type dce
frame-relay route 101 interface Serial1 102
frame-relay route 103 interface Tunnel1 203
frame-relay route 104 interface Tunnel1 204
!
interface Serial1
no ip address
encapsulation frame-relay
clockrate 2000000
frame-relay intf-type dce
frame-relay route 102 interface Serial0 101
frame-relay route 105 interface Tunnel1 205
frame-relay route 106 interface Tunnel1 206
!
router ospf 1
log-adjacency-changes
network 172.16.1.0 0.0.0.3 area 0
network 192.168.1.0 0.0.0.255 area 0
!



###############
Cisco2503 (Router B)
(Have included the relevant bits)
###############


frame-relay switching
!
!
!
interface Loopback1
ip address 172.16.1.2 255.255.255.252
!
interface Tunnel1
ip unnumbered Loopback1
tunnel source Ethernet0
tunnel destination 192.168.1.252
!
interface Ethernet0
ip address 192.168.1.251 255.255.255.0
no keepalive
!
interface Serial0
no ip address
encapsulation frame-relay
no ip route-cache
no ip mroute-cache
logging event subif-link-status
logging event dlci-status-change
no fair-queue
clockrate 64000
no frame-relay inverse-arp
frame-relay intf-type dce
frame-relay route 201 interface Serial1 202
frame-relay route 203 interface Tunnel1 103
frame-relay route 204 interface Tunnel1 104
!
interface Serial1
no ip address
encapsulation frame-relay
no ip route-cache
no ip mroute-cache
logging event subif-link-status
logging event dlci-status-change
clockrate 64000
no frame-relay inverse-arp
frame-relay intf-type dce
frame-relay route 202 interface Serial0 101
frame-relay route 205 interface Tunnel1 105
frame-relay route 206 interface Tunnel1 106
!

router ospf 1
log-adjacency-changes
network 172.16.1.0 0.0.0.3 area 0
network 192.168.1.0 0.0.0.255 area 0



###############


cisco2501#sh frame-relay route
Input Intf Input Dlci Output Intf Output Dlci Status
Serial0 201 Serial1 202 inactive
Serial0 203 Tunnel1 103 inactive
Serial0 204 Tunnel1 104 inactive
Serial1 202 Serial0 101 inactive
Serial1 205 Tunnel1 105 inactive
Serial1 206 Tunnel1 106 inactive
Tunnel1 103 Serial0 203 inactive
Tunnel1 104 Serial0 204 inactive
Tunnel1 105 Serial1 205 inactive
Tunnel1 106 Serial1 206 inactive



cisco2511#sh frame-relay route
Input Intf Input Dlci Output Intf Output Dlci Status
Serial0 101 Serial1 102 inactive
Serial0 103 Tunnel1 203 inactive
Serial0 104 Tunnel1 204 inactive
Serial1 102 Serial0 101 inactive
Serial1 105 Tunnel1 205 inactive
Serial1 106 Tunnel1 206 inactive
Tunnel1 203 Serial0 103 inactive
Tunnel1 204 Serial0 104 inactive
Tunnel1 205 Serial1 105 inactive
Tunnel1 206 Serial1 106 inactive


Now the problem is I cannot get the frame to come up. Some of the local serial interfaces were active before a reboot but now I cant seem to get them back up and cant get the tunnel ones up. icon_sad.gif Has anyone attempted tunneling frame before and any suggestions?

I really want to get this setup so I don't have to purchase a more expensive router with multiple serial interfaces.

Thanks in advance. icon_cool.gif

Comments

Sign In or Register to comment.