URGENT VLAN help needed~!!!
Bill Kaster
Member Posts: 94 ■■□□□□□□□□
in CCNA & CCENT
I have a couple questions about the following vlan configuration. Sorry for the theatrics in the title, i'm taking the test very soon and i want to have this down like my back of my hand!
switch1:
conf t
vlan 2
name Bill
exit
conf t
int range fa0/1 - 4
switchport access vlan 2
exit
conf t
vlan 3
name Dave
exit
conf t
int range fa0/5 - 0/8
switchport access vlan 3
exit
conf t
int fa0/24
switchport mode trunk
exit
router1:
conf t
int fa0/0
no ip address
no shut
exit
conf t
int fa0/0.2
encapsulation dot1q 2
ip address 192.168.10.1 255.255.255.0
no shut
exit
conf t
int fa0/0.3
encapsulation dot1q 3
ip address 192.168.20.1 255.255.255.0
so if these commands are correct, would I be right in assuming the following -
1- The default gateway on the router subinterface for vlan2 is 192.168.10.1 and all hosts in vlan2 must therefore be in the range 192.168.10.2 - 192.168.10.254.
2- The default gateway on the router subinterface for vlan3 is 192.168.20.1 and all hosts in vlan3 must therefore be in the range 192.168.20.2 - 192.168.20.254.
3- The f0/0 port on my 2620 router is connected to switch1's fa0/24 trunk port and will therefore be capable of allowing inter-vlan communication between vlan2 and vlan3.
cheers to anyone who can help me,I really need it!
switch1:
conf t
vlan 2
name Bill
exit
conf t
int range fa0/1 - 4
switchport access vlan 2
exit
conf t
vlan 3
name Dave
exit
conf t
int range fa0/5 - 0/8
switchport access vlan 3
exit
conf t
int fa0/24
switchport mode trunk
exit
router1:
conf t
int fa0/0
no ip address
no shut
exit
conf t
int fa0/0.2
encapsulation dot1q 2
ip address 192.168.10.1 255.255.255.0
no shut
exit
conf t
int fa0/0.3
encapsulation dot1q 3
ip address 192.168.20.1 255.255.255.0
so if these commands are correct, would I be right in assuming the following -
1- The default gateway on the router subinterface for vlan2 is 192.168.10.1 and all hosts in vlan2 must therefore be in the range 192.168.10.2 - 192.168.10.254.
2- The default gateway on the router subinterface for vlan3 is 192.168.20.1 and all hosts in vlan3 must therefore be in the range 192.168.20.2 - 192.168.20.254.
3- The f0/0 port on my 2620 router is connected to switch1's fa0/24 trunk port and will therefore be capable of allowing inter-vlan communication between vlan2 and vlan3.
cheers to anyone who can help me,I really need it!
Starting my CCNA journey!
Comments
-
Bill Kaster Member Posts: 94 ■■□□□□□□□□ha, ok! So my next question then (bare with me) is is the following corret for setting up vtp between two switches -
switch1:
conf t
vtp mode server
password billisgreat
exit
conf t
int fa0/24
switchport mode trunk
exit
switch2:
conf t
vtp mode client
password billisgreat
conf t
int fa0/24
switchport mode trunk
exit
* So do I even need to set a password on the switch2 client?
* If I use a crossover cable to trunk between those two switches and assuming I set up vlan2 and vlan3 on switch1 as I did in my first post, shouldn't I see vlan2 and vlan3 in switch2 when I do a show vlan brief, since switch1 is in server mode, even if I don't set up a vlan 2 or 3 in switch2 at all?
* Is show vlan brief the best way to make sure the switches are trunking properly?Starting my CCNA journey! -
dtlokee Member Posts: 2,378 ■■■■□□□□□□Yes you need a password on the client if you set one on the server. You did not set a VTP domain name in the config you have shown, and as long as the revision number on the server is higher than the client (show vtp status) the database on the server will overwrite the client.The only easy day was yesterday!
-
Bill Kaster Member Posts: 94 ■■□□□□□□□□Wonderful. Thanks man! ok, two more questions and I'll stop bothering you.
* How do you delete a frame relay map?
* How do you delete vlan settings and subinterface settings?
in other words I want to be able to practice frame relay and vlan configurations over and over again, but I've had trouble deleting them to start over. I'll try "no frame-relay" and the same with vlan but that only partially works. What are the exact commands to wipe your running config clean of any of those settings?Starting my CCNA journey! -
dtlokee Member Posts: 2,378 ■■■■□□□□□□you can remove frame map commands using the "no frame-relay map ip 10.1.1.1 100" command, except those pesky mappings to 0.0.0.0, I attack them by changing the encapsulation to ppp or hdlc then back to frame.
You can remove subinterfaces with the "no" form of the command, but I would also use "no ip address" and "no encapsulation dot1q x" before I remove the subinterfaceThe only easy day was yesterday! -
elvant Member Posts: 56 ■■□□□□□□□□Let me try these.
you can put "no fram map ip a.b.c.d <dlci-no>" to delete the frame map
you do "clear vlan <vlan-no> to delete vlan
you put "no inter sx/x.x" to delete subinterface (need reload to completely delete the subinterface)What is done is done, what yet to be done will be done. While in the process of doing, enjoy it.