DNS question

rewindrewind Member Posts: 40 ■■□□□□□□□□
I have a computer with Server 2003 DNS installed on it. It is ICSing an ISP connection on one interface and connected to a private network on another. Whenenver I do an nslookup on the server itself, it will always use my ISPs server by default. Of course I can use a 'server x.x.x.x' once inside nslookup using my public or private ip address and it will use my local DNS server, but is there a setting somewhere I can use to make the computer always try the local DNS server before the ISPs?

Any help would be appreciated as this is part of a lab I am following and it's driving me a little nutty! :)

Comments

  • dynamikdynamik Banned Posts: 12,314 ■■■■■■■■□□
    I assume the machine you're trying to use nslookup on has the IP of your server and not your ISP's entered for it's DNS server. If that's the case, you might want to check your DNS forwarding options on your DNS server since it seems like it's relaying that to your ISP. I haven't done 291 yet, but I thought I would chime in since no one else has. Maybe it'll give you a place to start.
  • CorySCoryS Member Posts: 208
    This is because you are using your ISPs dns servers for name resolution, check your tcp/ip config, if you switch your primary dns to whatever the ip of your DC (or if you running just dns then just the dns server), then this should work fine.

    Just a note, if you have multiple dns servers and want to test them both you can use the lserver switch when in nslookup to verify on other DNS servers.
    MCSE tests left: 294, 297 |
  • rewindrewind Member Posts: 40 ■■□□□□□□□□
    So I guess I could just statically set the DNS server info to my local IP on the ISP TCP/IP settings and set up forwarders pointing to my ISPs DNS servers on my local DNS Server.

    I guess I was also curious which "interface" (since I have one connected to an ISP and one on a private network) DNS setting is used when you launch nslookup. Cause I do have my local Server statically set in the DNS option on the private NIC. Nslookup always defaults to the ISP connection TCP/IP info.

    Is there a way to make nslookup choose a specific interface by default? I was thinking like a registry setting or something might do the trick...

    *edited
  • dynamikdynamik Banned Posts: 12,314 ■■■■■■■■□□
    Can you give a more detailed description of how you have your computers/interfaces setup? I'm a bit confused (it's a bit late though ;))
  • ClaymooreClaymoore Member Posts: 1,637
    You could try changing the binding order so that the internal interface is higher in the order and will be used first. That should mean its DNS server setting is tried first, which would be your server instead of the ISP's server.
  • rewindrewind Member Posts: 40 ■■□□□□□□□□
    dynamik wrote:
    Can you give a more detailed description of how you have your computers/interfaces setup? I'm a bit confused (it's a bit late though ;))

    Sure thing:

    One computer, two NICs. One NIC is connected to an ISP (PPPoE), the other NIC is connected to a private network.
    The ISP NIC's TCP/IP settings are leased via DHCP. The Private NIC's tcp/ip settings are statically assigned. The Computer is running DNS. The tcp/ip settings on the isp nic use the ISPs dns servers. The private nic is statically configured to use the private nics IP address for it's dns server.

    Claymoore wrote:
    You could try changing the binding order so that the internal interface is higher in the order and will be used first. That should mean its DNS server setting is tried first, which would be your server instead of the ISP's server.

    Thanks, this is a great idea, I will try when I get home! :)
  • dynamikdynamik Banned Posts: 12,314 ■■■■■■■■□□
    Out of curiosity, try disabling the NIC going to your ISP and running the lookup again.

    It could either be something in your DNS forwarding settings or simply that it's directly querying your ISP from that interface.

    Have you tried connecting another computer to this machine and running nslookup from that?
Sign In or Register to comment.