Options

creating VLAN across two switches

binarysoulbinarysoul Member Posts: 993
Let's say I have 3 switches and want to create a VLAN that includes 6 members (2 from each switch) How do I go about that?

Does the IOS running on each switch be the same version?

What if each switch connects a differnet subnet?

Comments

  • Options
    NetstudentNetstudent Member Posts: 1,693 ■■■□□□□□□□
    There are actually a lot of steps. YOu do not need to have matching IOS versions. As long as the feature set includes trunk encapsulation like ISL or dot1q. Do you want to implement router on a stick? Do you want mulitple routers in multiple vlans to load balance? If you are just starting out, you may want to start with a router on a stick.

    YOu will need to create subinterfaces on your router's ethernet port that connects to the switch. If you want 2 VLANS, then I would create 3 subinterfaces for 3 different subnets. 2 subnets for the vlans and another subnet for the management VLAN interface that will house the IP used to ssh or telnet to the switch for management purposes.

    So a router you would do:

    en
    conf t
    int fa0/0.20
    encapsulation dot1q 20
    ip address 192.168.1.1 255.255.255.0
    no shut
    int fa0/0.30
    encap dot1q 30
    ip address 192.168.2.1 255.255.255.0
    no shut
    int fa0/0.40
    encap dot1q 40
    ip address 10.10.10.1 255.255.255.0
    no shut

    That will get the router ready for intervlan routing. There are multiple ways of doing this and this is an oversimplified example.

    Then on the switch you would need to make the interface conected to the router a trunk port becuase mulitple vlans wil be traversing this link.

    en
    conf t
    int fa0/1
    switchport mode trunk
    if a 2900 then "switchport trunk encap dot1q"
    if 2950 then default is dot1q and isl is not supported.

    then you need to create the vlans 20 and 30, Assign ports to those vlans with

    switchport mode access
    switchport access vlan 20

    and make sure you put the machines in the right subnet with the right default gateway.

    then you will need to set a mangement vlan interface. Say we use vlan 40 for this.

    en
    conf t
    int vlan 40
    ip address 10.10.10.2 255.255.255.0
    no shut
    exit
    do ping 10.10.10.1


    This should get you started. IF this if foriegn to you, go back to the books or cisco docs. If you can get one switch and a router and some hosts going with pings then you can move on to mulitple switches by trunking the switches and assigning more vlans to more ports on other switches. in addition, all switches will share the management subnet on interface vlan 40.
    There is no place like 127.0.0.1 BUT 209.62.5.3 is my 127.0.0.1 away from 127.0.0.1!
  • Options
    binarysoulbinarysoul Member Posts: 993
    Thanks Netstudent for putting things in perspective !

    I was reading Todd Lammle's book and the chapter on VLAN goes on and on about how things are done, but I got really confused icon_sad.gif

    Due to some family commitements I've been putting the CCNA exam off (or I should say it has been put off for me without my consent). So now I'm picking up where I left off a few months ago, which was VLAN. I don't have routers or switches at home, but I will see if I can find some at work or at least I will buy a simulator.

    thanks again :)
Sign In or Register to comment.