Options

EIGRP issue... default route?

mikearamamikearama Member Posts: 749
First, our current WAN... we use a Bell provided ATM solution that is very flat. All 9 branches are considered local, and each of the remote sites has their gateway on our core 4500's.

Now then, we've opted to replace the flat ATM WAN with a fully routed Bell provided MPLS solution.

mplsqa5.th.jpg

We've added a 3825 as our "border" router, which connects directly to the Bell CE router (which we have no control over, except that we were able to request they add router eigrp 1 and the attached network commands). At our first remote site, we've installed a 2811 as the border router, also directly connected to the Bell CE.

Here's where it gets interesting... there are more than a half dozen routers inbetween the Bell CE's, plus the CE's. When the remote 2811 is powered up and the network commands are added, the routing table is populated with all of my routes in HO. Everything's there... except the default route for unspecific traffic (ie, internet).

As I understand it, a static route won't work, as it would have to point to the int on the Bell CE, which would then have to have a static route to the next router, etc. Can't happen.

Option 2, a default-network. When I issued ip default-network 192.168.22.248 on the 3825, it gave me an entry in the routers config, but did not share the def-net with the remote 2811.

Option 3, sharing a network to 0.0.0.0 So, on the 3825, I entered: ip route 0.0.0.0 0.0.0.0 g0/1, and under eigrp, network 0.0.0.0 I thought this would cover it, as I stole this directly from the BSCI study guide by Diane Teare. This also wasn't shared with the remote 2811.

I'm at a loss, my fellow techies. Are any of you running a routed WAN and using EIGRP? If so, how are you providing your remote sites with a default path back to your core?

Preciate any insights,
Mike
There are only 10 kinds of people... those who understand binary, and those that don't.

CCIE Studies: Written passed: Jan 21/12 Lab Prep: Hours reading: 385. Hours labbing: 110

Taking a time-out to add the CCVP. Capitalizing on a current IPT pilot project.

Comments

  • Options
    dtlokeedtlokee Member Posts: 2,378 ■■■■□□□□□□
    The ip default-network command will only be shared by EIGRP if it points to a default route that uses an exit interface. Have you tried adding a static route and then redistributing static into EIGRP? I don't fully follow what you're trying to do, but it may work for you.
    The only easy day was yesterday!
  • Options
    nice343nice343 Member Posts: 391
    access-list 1 permit 0.0.0.0
    
    
    
    route-map EIGRP_INTERNET 
    match ip add 1
    
    
    router eigrp 1
    redistribute static route-map EIGRP_INTERNET
    


    remote sites will not see the default route unless it is redistributed. The access-list and the route-map part of this command is optional
    My daily blog about IT and tech stuff
    http://techintuition.com/
  • Options
    mikearamamikearama Member Posts: 749
    So based on both your comments, if on my border 3825 I add a static route (ip route 0.0.0.0 0.0.0.0 192.168.22.254, which is the outside interface of the core), and then use:

    router eigrp 1
    redistribute static

    ... that should do it?

    What I don't understand is what to expect to have happen in the routing table of the remote 2811. Will a static route appear back to the core? or can I just expect the route that's already in the routing table to have an asterix appear beside it?

    Thanks again.
    There are only 10 kinds of people... those who understand binary, and those that don't.

    CCIE Studies: Written passed: Jan 21/12 Lab Prep: Hours reading: 385. Hours labbing: 110

    Taking a time-out to add the CCVP. Capitalizing on a current IPT pilot project.
  • Options
    nice343nice343 Member Posts: 391
    mikearama wrote:
    So based on both your comments, if on my border 3825 I add a static route (ip route 0.0.0.0 0.0.0.0 192.168.22.254, which is the outside interface of the core), and then use:

    router eigrp 1
    redistribute static

    ... that should do it?

    What I don't understand is what to expect to have happen in the routing table of the remote 2811. Will a static route appear back to the core? or can I just expect the route that's already in the routing table to have an asterix appear beside it?

    Thanks again.

    after you add the redistributed static route into eigrp, it will be seen as a static route in the remote router but it will be marked as marked as EX- which means external with an admin distance of 170
    My daily blog about IT and tech stuff
    http://techintuition.com/
  • Options
    dtlokeedtlokee Member Posts: 2,378 ■■■■□□□□□□
    You will need to add a metric to the redistribute command, EIGRP defaults to a metric of 0 which is not understood

    redistribute static metric 1000 1000 255 1 1500

    the values don't reall matter unless you are redistributing a static route at multiple points.
    The only easy day was yesterday!
  • Options
    mikearamamikearama Member Posts: 749
    I really appreciate the conversation guys... thanks.

    To follow up:

    @ nice... so the route will show up as an external eigrp route. This doesn't necessarily make it the default route, though, right? So once it's in the routing table of the remote 2811, what do I have to enter to put the asterix beside it? Is the fact that it was created (on my 3825) using the 0.0.0.0 0.0.0.0 address enough to accomplish this?

    @ dt... how about this:

    int g0/1
    ip summary-address eigrp 1 192.168.22.254 255

    where the 255 at the end is the route cost. Wouldn't that prevent is from being used locally on the 3825, but allow it to be shared in the eigrp updates to the remote routers?
    There are only 10 kinds of people... those who understand binary, and those that don't.

    CCIE Studies: Written passed: Jan 21/12 Lab Prep: Hours reading: 385. Hours labbing: 110

    Taking a time-out to add the CCVP. Capitalizing on a current IPT pilot project.
  • Options
    nice343nice343 Member Posts: 391
    mikearama wrote:
    I really appreciate the conversation guys... thanks.

    To follow up:

    @ nice... so the route will show up as an external eigrp route. This doesn't necessarily make it the default route, though, right? So once it's in the routing table of the remote 2811, what do I have to enter to put the asterix beside it? Is the fact that it was created (on my 3825) using the 0.0.0.0 0.0.0.0 address enough to accomplish this?

    @ dt... how about this:

    int g0/1
    ip summary-address eigrp 1 192.168.22.254 255

    where the 255 at the end is the route cost. Wouldn't that prevent is from being used locally on the 3825, but allow it to be shared in the eigrp updates to the remote routers?

    once you redistribute the static route the remote router should know where to foward unknown packets. You should be able to connect to wherever the default route points to internet?
    My daily blog about IT and tech stuff
    http://techintuition.com/
  • Options
    networker050184networker050184 Mod Posts: 11,962 Mod
    Hey Mike, I don't know if you are still having this issue of a EIGRP default route over MPLS VPN, but I came across this problem today and I thought of this thread. The solution I used to propogate the default route was the ip default-network command. Ensure your remote routers have a route to the network. If the default network is your link to the ISP ensure that interface is passive so you are not sending your routing updates to everyone. As you probably noticed redistributing of the static route didn't work (at least I couldn't get it to work). Sorry so late!
    An expert is a man who has made all the mistakes which can be made.
Sign In or Register to comment.