Options

bgp updates and route sharing between neighbors + config Que

aueddonlineaueddonline Member Posts: 611 ■■□□□□□□□□
ok so i'm having difficulty getting this simple concept into my tiny brain icon_confused.gif

do BGP routers only share routes that are in their BGP table to neighbor that match the network statement?

do BGP routers only share routes that are in their route table to neighbor that match the network statement?

is there a case when routes are advertised to neighbors automatically without the routes matching a neighbors statement?

do routes only get advertised to neighbors when a network statment is configured?

If anyone out there has a sentence that sums all this up I would real love to read it, cheers
What's another word for Thesaurus?

Comments

  • Options
    aueddonlineaueddonline Member Posts: 611 ■■□□□□□□□□
    ok i've found this:

    "When used with EGP and BGP, network specifies an IP prefix to be advertised. For each prefix specified with the command, BGP looks into the routing table. If an entry in the table exactly matches the network prefix, that prefix is entered into the BGP table and advertised."


    But does this mean that even routes that were learnt via neighbors have to be matched by a network command on the router for it to advertise those routes out?

    or does the network command only need to match routes that orginate at the BGP speaker?
    What's another word for Thesaurus?
  • Options
    networker050184networker050184 Mod Posts: 11,962 Mod
    You only need the network statement for localy originated routes. Routes learned from neighbors will be advertised to other neighbors. Just remeber BGP does not advertise routes learned from iBGP peers to other iBGP peers.
    An expert is a man who has made all the mistakes which can be made.
  • Options
    dtlokeedtlokee Member Posts: 2,378 ■■■■□□□□□□
    Once a route is advertised into the BGP table it will be carried to other BGP peers (provided it is a valid route, synchronization, valid nex hop....). The network command in BGP is used to advertise a route from the IGP (basically the local routing table) into BGP and once in BGP it will do as stated above. When you use the network command there MUST a matching prefix in the local routing table before BGP will advertise the route (both the prefix and mask must match). Other ways to originate a rout into BGP include redistribution and aggragate addresses. There used to be a limitation of 255 network commands on a router under the BGP process but that has been removed.
    The only easy day was yesterday!
  • Options
    aueddonlineaueddonline Member Posts: 611 ■■□□□□□□□□
    cheers guys that pain in my head has disapeared :D
    What's another word for Thesaurus?
  • Options
    aueddonlineaueddonline Member Posts: 611 ■■□□□□□□□□
    ok so I set up a little lab , i've got 4 routers in AS 6500 and one in AS 500, R1 is on the border and has and establisted relationship with R5 (AS 500).

    R1 connects to R3 and R2 which then both connect to R4 (imagine a square shape)

    i'm running OSPF on all the routers in AS 6500 and all adjacentcies are full.
    BGP is running on R1 and R4 and what i want to do is have them peer each other. so this is what I got.

    R1 config
    router ospf 1
    log-adjacency-changes
    redistribute bgp 6500
    network 1.1.1.1 0.0.0.0 area 0
    network 10.0.0.0 0.0.0.255 area 0
    network 10.0.1.0 0.0.0.255 area 0
    !
    router bgp 6500
    no synchronization
    bgp log-neighbor-changes
    neighbor ibgp_peers peer-group
    neighbor ibgp_peers remote-as 6500
    neighbor ibgp_peers next-hop-self
    neighbor 4.4.4.4 peer-group ibgp_peers
    neighbor 10.0.4.2 remote-as 500
    no auto-summary
    !
    ip route 5.5.5.5 255.255.255.255 10.0.4.2

    r4 config

    router ospf 1
    log-adjacency-changes
    network 4.4.4.4 0.0.0.0 area 0
    network 10.0.3.0 0.0.0.255 area 0
    network 10.0.4.0 0.0.0.255 area 0
    !
    router bgp 6500
    no synchronization
    bgp log-neighbor-changes
    neighbor 1.1.1.1 remote-as 6500
    no auto-summary

    Note aswell that I have tired the 'clear ip bgp *'command and that the loopback interface that are configured are included in the ospf network command, hope i've explained that one ok.

    here's a 'debug ip bgp events readout on R4 to

    *Mar 4 12:01:37.748: BGP: Regular scanner event timer
    *Mar 4 12:01:37.748: BGP: Import timer expired. Walking from 1 to 1
    *Mar 4 12:01:52.748: BGP: Regular scanner event timer
    *Mar 4 12:01:52.748: BGP: Performing BGP general scanning
    *Mar 4 12:01:52.748: BGP(0): scanning IPv4 Unicast routing tables
    *Mar 4 12:01:52.748: BGP(IPv4 Unicast): Performing BGP Nexthop scanning for general scan
    *Mar 4 12:01:52.748: BGP(0): Future scanner version: 42, current scanner version: 41
    *Mar 4 12:01:52.748: BGP(2): scanning VPNv4 Unicast routing tables
    *Mar 4 12:01:52.748: BGP(VPNv4 Unicast): Performing BGP Nexthop scanning for general scan
    *Mar 4 12:01:52.748: BGP(2): Future scanner version: 44, current scanner version: 43
    *Mar 4 12:01:52.748: BGP(4): scanning IPv4 Multicast routing tables
    *Mar 4 12:01:52.752: BGP(IPv4 Multicast): Performing BGP Nexthop scanning for general scan
    *Mar 4 12:01:52.752: BGP(4): Future scanner version: 44, current scanner version: 43
    *Mar 4 12:01:52.752: BGP(6): scanning NSAP Unicast routing tables
    *Mar 4 12:01:52.752: BGP(NSAP Unicast): Performing BGP Nexthop scanning for general scan
    *Mar 4 12:01:52.752: BGP(6): Future scanner version: 44, current scanner version: 43
    r4#
    *Mar 4 12:02:07.825: BGP: Regular scanner event timer
    *Mar 4 12:02:07.825: BGP: Import timer expired. Walking from 1 to 1


    [/url]
    What's another word for Thesaurus?
  • Options
    networker050184networker050184 Mod Posts: 11,962 Mod
    You need add the update source to your configs. By default the router will use the outgoing interface. Since you have them peered with loopbacks you need the updates sent from the loopback address so the other router will recognize who the update is from.
    An expert is a man who has made all the mistakes which can be made.
  • Options
    aueddonlineaueddonline Member Posts: 611 ■■□□□□□□□□
    yeah you were right, it was the update-source i missed out, neighbor came staight up icon_redface.gif
    What's another word for Thesaurus?
Sign In or Register to comment.