DSL Router With External Modem - Static IP

rdtechrdtech Member Posts: 23 ■□□□□□□□□□
one in my vpn location I'am using cisco router config with dynamic ip address

can anyone help me to config this router using static ip address using verizon modem

Thank You
:)
ROOSEVD

Comments

  • nice343nice343 Member Posts: 391
    IF you are receving dynamic IP from Verizon the only way that can be changed is if you talk to them that you want to make it a static. No configuration will make that Public Ip a static till you talk to Verizon
    My daily blog about IT and tech stuff
    http://techintuition.com/
  • rdtechrdtech Member Posts: 23 ■□□□□□□□□□
    I need to config the cisco router with static ip address
    I do have the ip and default gateway address

    before I was using cable modem using dynamic ip
    ROOSEVD
  • dtlokeedtlokee Member Posts: 2,378 ■■■■□□□□□□
    Is this what you're looking for?

    interface fa0/0 ! whatever interface id
    ip address 10.1.1.1 255.255.255.0
    !
    ip route 0.0.0.0 0.0.0.0 1.2.3.4 ! replace the 1.2.3.4 with your default gateway.
    The only easy day was yesterday!
  • rdtechrdtech Member Posts: 23 ■□□□□□□□□□
    How to remove the dhcp client from the interface
    thank you
    ROOSEVD
  • dtlokeedtlokee Member Posts: 2,378 ■■■■□□□□□□
    Use the "ip address" command to configure the static IP address and it will remove th command automatically, or you can use the "no ip address dhcp" command but you will not have an IP address at that point.

    You may want to explore the implications of what you're doing a little more, do you have an ACL in place to provide securty of some type as well as a NAT configuration to allow your hosts access to the Internet? I only ask because chainging an IP address is basc compared to these other tasks.
    The only easy day was yesterday!
  • nice343nice343 Member Posts: 391
    a any cisco router which is receiving an Ip from a dhcp is configured as
    inter f0/0
    ip address dhcp
    

    if you want the interface to stop receiving ip dynamically just go into the interface and type
    no ip address dhcp
    
    My daily blog about IT and tech stuff
    http://techintuition.com/
  • rdtechrdtech Member Posts: 23 ■□□□□□□□□□
    I had a comcast cable modem hook up to the cisco router Ethernet port, the modem is doing Dhcp
    and the router config with nat and vpn.

    I need to change the dynamic ip address to static Ip address by using a verizion Modem

    Thank you
    ROOSEVD
  • rdtechrdtech Member Posts: 23 ■□□□□□□□□□
    I have AcL and NAT config inside the router

    Thank you for your help
    ROOSEVD
  • rdtechrdtech Member Posts: 23 ■□□□□□□□□□
    Site01#sh run
    Building configuration...

    Current configuration : 1827 bytes
    !
    version 12.3
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname site01
    !
    enable secret 5 eyuiioqooadldaldada./
    !
    no aaa new-model
    ip subnet-zero
    !
    !
    ip audit notify log
    ip audit po max-events 100
    no ftp-server write-enable
    !
    !
    !
    !
    crypto isakmp policy 1
    hash md5
    authentication pre-share
    crypto isakmp key 0 cr4456002 address 23.4.7.66
    !
    !
    crypto ipsec transform-set pix-set esp-des esp-md5-hmac
    crypto ipsec df-bit clear
    !
    crypto map pix 10 ipsec-isakmp
    set peer 23.4.7.66
    set transform-set pix-set
    match address 101
    !
    no crypto engine accelerator
    !
    !
    !
    interface Ethernet0
    ip address 192.168.212.254 255.255.240.0
    ip nat inside
    no cdp enable
    hold-queue 32 in
    !
    interface Ethernet1
    ip address dhcp client-id Ethernet1
    ip nat outside
    duplex auto
    no cdp enable
    crypto map pix
    !
    interface FastEthernet1
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet2
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet3
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet4
    no ip address
    duplex auto
    speed auto
    !
    ip nat inside source route-map nonat interface Ethernet1 overload
    ip classless
    ip http server
    no ip http secure-server
    !
    access-list 23 permit 192.168.0.0 0.0.255.255
    access-list 23 permit 70.75.68.128 0.0.0.x
    access-list 101 permit ip 192.168.224.0 0.0.15.255 172.16.0.0 0.0.15.255
    access-list 110 deny ip 192.168.224.0 0.0.15.255 172.16.0.0 0.0.15.255
    access-list 110 permit ip 192.168.224.0 0.0.15.255 any
    no cdp run
    route-map nonat permit 10
    match ip address 110
    !
    !
    line con 0
    exec-timeout 120 0
    no modem enable
    stopbits 1
    line aux 0
    line vty 0 4
    access-class 23 in
    exec-timeout 120 0
    password 7 566666
    login
    !
    scheduler max-task-time 5000
    !
    end
    ROOSEVD
  • mgeorgemgeorge Member Posts: 774 ■■■□□□□□□□
    What kind of router/ios ?

    Well from the looks of the configuration you are using the dsl modem to perform the PPPoE dialer.

    You may want to consider bringing the pppoe dialer to the router and configure the modem as a bridge only. The the dialerX interface to the ethernet port which the modem is attached. This would give you more grainular control over the pppoe dialer. mtu, timeouts, security, etc...

    If verizon is anything like AT&T, they will provide you your static ip via dhcp as well. So if you do choose to configure the pppoe dialer on the router, configure it to "ip address negotiated" and you will receive the static ip address they provided you via dhcp. With the dialer set to persistant, it will attempt reconnection immediately after a session is dropped. With ya typical dsl modem/router box, they have a grace period of 5 seconds.

    the PPPoE dialer is only supported in 12.3 ip plus or greater. you can check via feature navigator

    You may want to check with your modem and make sure it is not providing a private ip address when using "ip address dhcp" on your cisco router, if this is the case, then your traffic is getting nat'ted twice and will cause ipsec problems.

    Hope this points you in the right direction icon_lol.gif
    There is no place like 127.0.0.1
  • vjsousavjsousa Member Posts: 24 ■□□□□□□□□□
    The modem type or the ISP doesn't matter. The modem is just a bridging device and doesn't perfor m routing.

    What type of Cisco router? I have a PIX at home and I used the following configuration for a static IP address:

    ip address outside x.x.x.x 255.255.255.0
    ip address inside 192.168.1.1 255.255.255.0

    route outside 0.0.0.0 0.0.0.0 next hop (default gateway)
    Vinny
  • mgeorgemgeorge Member Posts: 774 ■■■□□□□□□□
    vjsousa wrote:
    The modem type or the ISP doesn't matter. The modem is just a bridging device and doesn't perfor m routing.

    What type of Cisco router? I have a PIX at home and I used the following configuration for a static IP address:

    Most of the dsl modems now days perform EVERYTHING; wireless, dhcp, nat, routing, firewall services and more.

    All modems provided by Bellsouth/ATT, Quest, Windstream Communications will perform NAT at the modem its self and provide private dhcp addresses by default. (Unless it's configured to bridge)

    Clearly from the configurarion provided, this is a router not a firewall. As you see the router is running 12.3 (firewalls dont run 12.3)

    Although you are given a static ip address, this static ip address is typically issued via DHCP with most dsl providers, static IP's via DHCP are bound to your username. So upon authentication and dhcp request, you will receive the static ip(s) you've been alloted.
    There is no place like 127.0.0.1
  • rdtechrdtech Member Posts: 23 ■□□□□□□□□□
    Thank you to all of you I got it to work

    Below is the config I got from Dtlokee:

    :)

    interface fa0/0 ! whatever interface id
    ip address 10.1.1.1 255.255.255.0
    !
    ip route 0.0.0.0 0.0.0.0 1.2.3.4 !

    replace the 1.2.3.4 with your default gateway.
    ROOSEVD
  • dtlokeedtlokee Member Posts: 2,378 ■■■■□□□□□□
    mgeorge27 wrote:
    As you see the router is running 12.3 (firewalls dont run 12.3)

    12.3 has an IOS FW version.
    The only easy day was yesterday!
  • mgeorgemgeorge Member Posts: 774 ■■■□□□□□□□
    I meant as a firewall app :P pix or asa, netscreen etc... ^_^

    almost time for the game!!! supposed to be 3 degree's at kick off!!!
    There is no place like 127.0.0.1
Sign In or Register to comment.