I need to config the cisco router with static ip address

rdtechrdtech Member Posts: 23 ■□□□□□□□□□
I need to config the cisco router with static ip address
I do have the ip and default gateway address

before I was using cable modem using dynamic ip
Thank You

Thi is the configuration



Site01#sh run
Building configuration...

Current configuration : 1827 bytes
!
version 12.3
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname site01
!
enable secret 5 eyuiioqooadldaldada./
!
no aaa new-model
ip subnet-zero
!
!
ip audit notify log
ip audit po max-events 100
no ftp-server write-enable
!
!
!
!
crypto isakmp policy 1
hash md5
authentication pre-share
crypto isakmp key 0 cr4456002 address 23.4.7.66
!
!
crypto ipsec transform-set pix-set esp-des esp-md5-hmac
crypto ipsec df-bit clear
!
crypto map pix 10 ipsec-isakmp
set peer 23.4.7.66
set transform-set pix-set
match address 101
!
no crypto engine accelerator
!
!
!
interface Ethernet0
ip address 192.168.212.254 255.255.240.0
ip nat inside
no cdp enable
hold-queue 32 in
!
interface Ethernet1
ip address dhcp client-id Ethernet1
ip nat outside
duplex auto
no cdp enable
crypto map pix
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
ip nat inside source route-map nonat interface Ethernet1 overload
ip classless
ip http server
no ip http secure-server
!
access-list 23 permit 192.168.0.0 0.0.255.255
access-list 23 permit 70.75.68.128 0.0.0.x
access-list 101 permit ip 192.168.224.0 0.0.15.255 172.16.0.0 0.0.15.255
access-list 110 deny ip 192.168.224.0 0.0.15.255 172.16.0.0 0.0.15.255
access-list 110 permit ip 192.168.224.0 0.0.15.255 any
no cdp run
route-map nonat permit 10
match ip address 110
!
!
line con 0
exec-timeout 120 0
no modem enable
stopbits 1
line aux 0
line vty 0 4
access-class 23 in
exec-timeout 120 0
password 7 566666
login
!
scheduler max-task-time 5000
!
end
ROOSEVD

Comments

  • eleguaelegua Member Posts: 282
    Hi,

    Just change this:
    interface Ethernet1
    ip address dhcp

    for:
    interface Ethernet1 
    ip address X.X.X.X Y.Y.Y.Y  ---> X's is the ip address and Y's--> is your mask.
    no shut
    
    Hope this help. icon_wink.gificon_wink.gif
  • rdtechrdtech Member Posts: 23 ■□□□□□□□□□
    Thank you for your help. I got it to work
    Below is the config I got from Dtlokee:
    :D

    interface fa0/0 ! whatever interface id
    ip address 10.1.1.1 255.255.255.0
    !
    ip route 0.0.0.0 0.0.0.0 1.2.3.4 !

    replace the 1.2.3.4 with your default gateway.
    ROOSEVD
Sign In or Register to comment.