VTP Pruning Test

callmeallcallmeall Posts: 13Member ■□□□□□□□□□
2000406139174698741_rs.jpg
CCIE 2008

Comments

  • callmeallcallmeall Posts: 13Member ■□□□□□□□□□

    Hi, everyone, here is what I found my testing result on the issue of “VTP Pruning”

    I have builded a simple diagram looks like this:

    2000406139174698741_rs.jpg

    On R1:
    interface Ethernet0/0
    description which is directly connected to Sw1 F 0/1
    ip address 1.1.1.1 255.255.255.0
    no shutdown

    On R2:interface Ethernet0/0
    description which is directly connected to Sw1 F 0/2
    ip address 2.2.2.2 255.255.255.0
    no shutdown

    On R3:
    interface Ethernet0/1
    description which is directly connected to Sw2 F 0/3
    ip address 2.2.2.3 255.255.255.0
    no shutdown

    On R4:
    interface Ethernet0/1
    description which is directly connected to Sw2 F 0/4
    ip address 1.1.1.4 255.255.255.0
    no shutdown

    My Sw1:
    Vtp domain VTP_PRUNING
    Vlan 11 name SITE_1
    Vlan 12 name SITE_2
    Vlan 100 name VLAN_100
    Vlan 200 name VLAN_200
    !
    interface FastEthernet0/1
    switchport access vlan 12
    switchport mode access
    !
    interface FastEthernet0/2
    switchport access vlan 13
    switchport mode access

    My Sw2:
    interface FastEthernet0/3
    switchport access vlan 13
    switchport mode access
    !
    interface FastEthernet0/4
    switchport access vlan 12
    switchport mode access

    as you can see, the idea is to make R1 (1.1.1.1) ping R4 (1.1.1.4) via VLAN 12 and R2 (2.2.2.2) ping-able to R3 (2.2.2.3) via VLAN 13…

    Pay a closer attention to the following info:

    Before I enable “vtp pruning”:

    Sw1#show interfaces fastEthernet 0/23 trunk

    Port Mode Encapsulation Status Native vlan
    Fa0/23 desirable n-isl trunking 1

    Port Vlans allowed on trunk
    Fa0/23 1-4094

    Port Vlans allowed and active in management domain
    Fa0/23 1,12-13,100,200

    Port Vlans in spanning tree forwarding state and not pruned
    Fa0/23 1,12-13,100,200

    Sw2#show interfaces fastEthernet 0/23 trunk

    Port Mode Encapsulation Status Native vlan
    Fa0/23 desirable n-isl trunking 1

    Port Vlans allowed on trunk
    Fa0/23 1-4094

    Port Vlans allowed and active in management domain
    Fa0/23 1,12-13,100,200

    Port Vlans in spanning tree forwarding state and not pruned
    Fa0/23 1,12-13,100,200

    So far, NOTHING has pruned, that’s because I havn’t enable them yet. By default, the vtp pruning feature is disabled.

    I then use “vtp pruning” to enabled on Sw1 and though BPDU packets, Sw2 will enable “vtp pruning” as well.

    Now see the results again as the followings:

    Sw1# show interfaces fastEthernet 0/23 trunk

    Port Mode Encapsulation Status Native vlan
    Fa0/23 desirable n-isl trunking 1

    Port Vlans allowed on trunk
    Fa0/23 1-4094

    Port Vlans allowed and active in management domain
    Fa0/23 1,12-13,100,200

    Port Vlans in spanning tree forwarding state and not pruned
    Fa0/23 1,12-13

    And this sub-command as well:
    Sw1#show interfaces fastEthernet 0/23 pruning

    Port Vlans pruned for lack of request by neighbor
    Fa0/23 100,200

    Port Vlan traffic requested of neighbor
    Fa0/23 1,12-13

    Cheers,

    P.S (in fact, dtlokee is correct, you can see the vtp pruning result with "show interface fa0/1 trunk" command, and I was thinking to use “show interface f 0/23 pruning” command. They are the samething anyways.

    The result is showing me exactly what I want to see, and it’s so simple, but I guess sometimes, I just can’t 100% just memorize it according to the text book, I just have to proof it on my own, I don’t know, that’s just me.

    Alright, I am out.

    Have a nice day guys.
    CCIE 2008
Sign In or Register to comment.