Loopback ) int
gaby_978
Member Posts: 222
in CCNA & CCENT
I am configuring a loopback0 int in both of my 2600 series router. I think i have the configs right. But i cant ping from one loopback int to the other. I try to add a static route but i get the following error:
router1(config-if)#ip route 160.0.0.2 255.255.255.252 Serial0/0
%Inconsistent address and mask
I tried under the global config mode as well as under the int itself. These are my baasic configs:
Router1
interface Serial0/0
description wan connection1
ip address 10.10.10.1 255.255.255.252
encapsulation ppp
clock rate 64000
interface Serial0/1
description wan connection2
ip address 172.0.0.2 255.255.255.252
encapsulation ppp
clock rate 64000
interface Loopback0
description loopback int
ip address 160.0.0.1 255.255.255.252
end
Router2
interface Serial0/0
description wan connection1
ip address 10.10.10.2 255.255.255.252
encapsulation ppp
interface Serial0/1
description wan connection2
ip address 172.0.0.1 255.255.255.252
encapsulation ppp
interface Loopback0
description loopback int
ip address 160.0.0.2 255.255.255.252
end
Please point me in the right direction.
Thank you
router1(config-if)#ip route 160.0.0.2 255.255.255.252 Serial0/0
%Inconsistent address and mask
I tried under the global config mode as well as under the int itself. These are my baasic configs:
Router1
interface Serial0/0
description wan connection1
ip address 10.10.10.1 255.255.255.252
encapsulation ppp
clock rate 64000
interface Serial0/1
description wan connection2
ip address 172.0.0.2 255.255.255.252
encapsulation ppp
clock rate 64000
interface Loopback0
description loopback int
ip address 160.0.0.1 255.255.255.252
end
Router2
interface Serial0/0
description wan connection1
ip address 10.10.10.2 255.255.255.252
encapsulation ppp
interface Serial0/1
description wan connection2
ip address 172.0.0.1 255.255.255.252
encapsulation ppp
interface Loopback0
description loopback int
ip address 160.0.0.2 255.255.255.252
end
Please point me in the right direction.
Thank you
"If you spend too much time thinking about a thing,
you'll never get it done"
you'll never get it done"
Comments
-
dtlokee Member Posts: 2,378 ■■■■□□□□□□The host portion of the destination subnet of the ip route command must be all "0" in binary or you will get the "inconsistent address and mask" error. Try "ip route 160.0.0.0 255.255.255.252 serial 0/0"The only easy day was yesterday!
-
gaby_978 Member Posts: 222The host portion of the destination subnet of the ip route command must be all "0" in binary or you will get the "inconsistent address and mask" error. Try "ip route 160.0.0.0 255.255.255.252 serial 0/0"
ok i tried it and it took it with no errors however i am still unable to ping between them."If you spend too much time thinking about a thing,
you'll never get it done" -
dtlokee Member Posts: 2,378 ■■■■□□□□□□I didn't look at the configs beyond the error you had. Your other problem is you put both loopbacks on the same subnet when they are different broadcast domains. Change the loopback on your Router2 to 160.0.0.5 255.255.255.252, then add a static rotue on R1 "ip route 160.0.0.4 255.255.255.252 serial 0/0" and on R2 "ip route 160.1.0.0 255.255.255.252 serial 0/0" that should work.The only easy day was yesterday!
-
gaby_978 Member Posts: 222Change the loopback on your Router2 to 160.0.0.5 255.255.255.252, then add a static rotue on R1 "ip route 160.0.0.4 255.255.255.252 serial 0/0" and on R2 "ip route 160.1.0.0 255.255.255.252 serial 0/0" that should work.
Hey thank you that works. Appreciate the help"If you spend too much time thinking about a thing,
you'll never get it done"