Understanding QoS basic.
anis
Member Posts: 34 ■□□□□□□□□□
Dear all,
I am trying to catch hold of QoS. Well, right now I am using a stand alone 3550 Switch for practice. Right now my plan is not to trust anything on this switch. For this:
I implemented mls qos on the switch.
I have classified four groups named high(voice), critical (company defined critical applications), moderate (http, smtp, pop3), all (all other). And gave them four dscp values like i) ef , ii) af3 iii) af4 iv) default.
Now, I need to know two things:
1. Does the above configuration set the traffic into four groups accurately. If not, what else should I do create four queues according to this configuration?
2. I want to allow 40% traffice to the first queue (considering that 4 queue's has been configured) and rest of the queues will each get 20%. Now, which command will be used here to do that.
Thank you.
I am trying to catch hold of QoS. Well, right now I am using a stand alone 3550 Switch for practice. Right now my plan is not to trust anything on this switch. For this:
I implemented mls qos on the switch.
I have classified four groups named high(voice), critical (company defined critical applications), moderate (http, smtp, pop3), all (all other). And gave them four dscp values like i) ef , ii) af3 iii) af4 iv) default.
Now, I need to know two things:
1. Does the above configuration set the traffic into four groups accurately. If not, what else should I do create four queues according to this configuration?
2. I want to allow 40% traffice to the first queue (considering that 4 queue's has been configured) and rest of the queues will each get 20%. Now, which command will be used here to do that.
Thank you.
Comments
-
EdTheLad Member Posts: 2,111 ■■■■□□□□□□What about COS, ar you only interested in DSCP?
For the voice you will use the priority command, the other 3 queues will use bandwidth.
I would create more queues where possible.Networking, sometimes i love it, mostly i hate it.Its all about the $$$$ -
anis Member Posts: 34 ■□□□□□□□□□Being a starter, i am just going on with dscp. Well, I am confused about whether priority and bandwidth commands allowed in 3550 switch. If allowed, can you plz put the gross sample command for that?
-
EdTheLad Member Posts: 2,111 ■■■■□□□□□□Nope, i think its time you started reading.You can find the 3550 config guide on cisco.com.Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
-
anis Member Posts: 34 ■□□□□□□□□□Thanks for your recommentation. Well, I have a router (no qos configured) connected to internet cloud which is connected down to my switch (3560).
I am planning the following configuration on the switch:
mls qos
class-map match-all map_critical
match access-group name acl_critical
class-map match-all map_medium
match access-group name acl_medium
class-map match-all map_average
match access-group name acl_average
policy-map test_qos
class map_critical
police 50000000 1000000 exceed-action drop
set dscp ef
class map_medium
police 25000000 1000000 exceed-action drop
set dscp cs3
class map_average
police 25000000 1000000 exceed-action drop
set dscp default
interface FastEthernet0/2
description Test QoS implementation
service-policy input test_qos
ip access-list extended acl_average
permit ip any any
ip access-list extended acl_critical
permit tcp any any eq www
permit tcp any any eq smtp
permit tcp any any eq pop3
ip access-list extended acl_medium
permit ip 192.168.44.0 0.0.0.255 any
My plan here is to get three queues and give them different priorities through dscp values. So, could you please comment on this to help me polish my basic concepts.
If i implement this straight to the switch, will there be any impact or i need something else to make it operational? -
tech-airman Member Posts: 953anis wrote:Dear all,
I am trying to catch hold of QoS. Well, right now I am using a stand alone 3550 Switch for practice. Right now my plan is not to trust anything on this switch. For this:
I implemented mls qos on the switch.
I have classified four groups named high(voice), critical (company defined critical applications), moderate (http, smtp, pop3), all (all other). And gave them four dscp values like i) ef , ii) af3 iii) af4 iv) default.
Now, I need to know two things:
1. Does the above configuration set the traffic into four groups accurately. If not, what else should I do create four queues according to this configuration?
2. I want to allow 40% traffice to the first queue (considering that 4 queue's has been configured) and rest of the queues will each get 20%. Now, which command will be used here to do that.
Thank you.
anis,
Have a look at the following link.
Link:- Quality of Service (QoS) - http://www.cisco.com/univercd/cc/td/doc/cisintwk/ito_doc/qos.htm
-
dtlokee Member Posts: 2,378 ■■■■□□□□□□Are you trying to apply the queueing on the router or the switch?The only easy day was yesterday!
-
dtlokee Member Posts: 2,378 ■■■■□□□□□□The 3560 supports 4 output queues, are you planning on mapping your DSCP values to these queues?The only easy day was yesterday!
-
anis Member Posts: 34 ■□□□□□□□□□Infact I am confused about a few things:
1. As you can see, I have created 3 classes instead of four through 3 simple ACLs (Does it make any sense?) though it supports 4 classes.
2. I have created policy only through DSCP (as I thought switches only deal with layer 2 frames not packets), one of the above posts says that I need to take care about COS as well. Why is that?
3. 3 or 4 whatever, does my configuration attempt creates 3 queues or I have to do anything to make the queue?
4. Do you recommend any tips for output queue configuration?
5. It would be great if i could get a sample config file for 3560 switch. -
mikej412 Member Posts: 10,086 ■■■■■■■■■■For QoS, you can start with Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.4. The table of contents on this page in itself is a good outline of the QoS topics.
For the 3560 Switch QoS, you'd want to read Configuring QoS section of the Catalyst 3560 Switch Software Configuration Guide. You may want to check the Cisco Documentation and see if there is a more specific version that matches your exact IOS version -- but any reasonably current version doc should be fine.
Internetwork Expert offers some on-line seminars, and the October V-Seminar "CCIE Catalyst QoS" is available Free online at http://classroom.internetworkexpert.com/p95576427/:mike: Cisco Certifications -- Collect the Entire Set!