Installing VMserver VMTools on CENTOS v5.x

PashPash Posts: 1,601Member ■■■■■□□□□□
Step 1
yum install gcc kernel-devel
uname -r             # running kernel

& Then
rpm -q kernel-devel  # installed kernel headers

Make sure your kernel headers match (if not do next part).
yum -y upgrade kernel kernel-devel
reboot

For reference find out where your kernel headers are:-
ls -d /usr/src/kernels/$(uname -r)*/include

Step 2

Right click on your VM guest and click install VMtools (it won't start the installation prompt like in a Windows Guest). It's important you do this or there will be no cdrom to mount.
mount /dev/cdrom /mnt/

Note: It's better to see which version of VMtools you have now mounted so browse to your /mnt drive:-
cd /mnt
ls
su -

Note: Make a note of your VMware tools Tarball version!
tar -C /tmp -zxvf /mnt/VMwareTools-x.x.x-xxxxx.tar.gz
umount /mnt
cd /tmp/vmware-tools-distrib
./vmware-install.pl

Follow everything through with the selected defaults.

Step 3

Now in VM server version 1.0.4 there is an issues with starting Xserver upon rebooting and you still wont be able to select a higher res for display or get the mouse functionality of vmtools.

So I borrowed this xorg.conf from KevinG of the vmware communities that he posted.
# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "XWorkAround"
InputDevice "Mouse[0]" "CorePointer"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse[0]"
Driver "vmmouse"
Option "Device" "/dev/input/mice"
Option "Name" "VMware Point Device"
EndSection

Section "InputDevice"
Identifier "XWorkAround"
Driver "void"
EndSection

Section "Monitor"
Identifier "vmware"
VendorName "VMware, Inc"
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 1.0 - 10000.0
VertRefresh 1.0 - 10000.0
EndSection

Section "Device"
Identifier "VMware SVGA"
Driver "vmware"
EndSection

Section "Screen"

# Don't specify DefaultColorDepth unless you know what you're
# doing. It will override the driver's preferences which can
# cause the X server not to run if the host doesn't support the
# depth.
Identifier "Screen0"
Device "VMware SVGA"
Monitor "vmware"
DefaultDepth 24
SubSection "Display"

# VGA mode: better left untouched
Viewport 0 0
Depth 4
Modes "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
Modes "1024x768"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
Modes "1024x768"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "832x624" "800x600" "720x400" "640x480" "640x400" "640x350"
EndSubSection
EndSection

Rename your /etc/X11/xorg.conf file to something like oldxorg.conf and then create a new file called xorg.conf and paste the above text into it.

Perform a reboot and bobs your uncle full vmtool functionality with no issues.

Cheers,
DevOps Engineer and Security Champion. https://blog.pash.by - I am trying to find my writing style, so please bear with me.
Sign In or Register to comment.