QoS output!
anis
Member Posts: 34 ■□□□□□□□□□
Well, as per the QoS configuration guide for cisco catalyst 3560 switch the basic configuration steps are like:
classification
policing
mark
queueing & scheduling
Queueing & Scheduling
(1)
(2)
(3)
(4-ingress)
(5-egress)
To try this:
Step 1.
I simply created several class-maps traffic each defined by ACL for different types of traffic (as I am not trusting anything)
Step 2/3.
I marked each class-map with a suitable DSCP value. (cos value will be derieved from the global DSCP-COS mapping)
Step 4
I configured the the two ingress queues with mls qos srr-queue input (threshold, dscp-map, cos-map, buffer, bandwidth).
Step 5
I configured the the four egress queues with mls qos srr-queue output (threshold, dscp-map, cos-map, buffer, bandwidth)
Well, i need comment on my understanding of my configuration steps.
Infact after configuring accroding to the steps, the follwoing output (i put different types of traffic on that port) is confusing me:
sw#show policy-map interface fa0/2
FastEthernet0/2
Service-policy input: test_qos
Class-map: map_critical (match-all)
0 packets, 0 bytes
offered rate 0 bps, drop rate 0 bps
Match: access-group name acl_critical
Class-map: map_medium (match-all)
0 packets, 0 bytes
offered rate 0 bps, drop rate 0 bps
Match: access-group name acl_medium
Class-map: map_average (match-all)
0 packets, 0 bytes
offered rate 0 bps, drop rate 0 bps
Match: access-group name acl_average
Class-map: class-default (match-any)
0 packets, 0 bytes
offered rate 0 bps, drop rate 0 bps
Match: any
0 packets, 0 bytes
rate 0 bps
classification
policing
mark
queueing & scheduling
Queueing & Scheduling
(1)
(2)
(3)
(4-ingress)
(5-egress)
To try this:
Step 1.
I simply created several class-maps traffic each defined by ACL for different types of traffic (as I am not trusting anything)
Step 2/3.
I marked each class-map with a suitable DSCP value. (cos value will be derieved from the global DSCP-COS mapping)
Step 4
I configured the the two ingress queues with mls qos srr-queue input (threshold, dscp-map, cos-map, buffer, bandwidth).
Step 5
I configured the the four egress queues with mls qos srr-queue output (threshold, dscp-map, cos-map, buffer, bandwidth)
Well, i need comment on my understanding of my configuration steps.
Infact after configuring accroding to the steps, the follwoing output (i put different types of traffic on that port) is confusing me:
sw#show policy-map interface fa0/2
FastEthernet0/2
Service-policy input: test_qos
Class-map: map_critical (match-all)
0 packets, 0 bytes
offered rate 0 bps, drop rate 0 bps
Match: access-group name acl_critical
Class-map: map_medium (match-all)
0 packets, 0 bytes
offered rate 0 bps, drop rate 0 bps
Match: access-group name acl_medium
Class-map: map_average (match-all)
0 packets, 0 bytes
offered rate 0 bps, drop rate 0 bps
Match: access-group name acl_average
Class-map: class-default (match-any)
0 packets, 0 bytes
offered rate 0 bps, drop rate 0 bps
Match: any
0 packets, 0 bytes
rate 0 bps
Comments
-
dtlokee Member Posts: 2,378 ■■■■□□□□□□It maybe a small detail but did you enable mls qos globally on the switch?The only easy day was yesterday!
-
anis Member Posts: 34 ■□□□□□□□□□Classification:
class-map match-all map_critical
match access-group name acl_critical
class-map match-all map_medium
match access-group name acl_medium
class-map match-all map_average
match access-group name acl_average
!
!
Marking:
policy-map test_qos
class map_critical
set dscp ef
class map_medium
set dscp cs3
class map_average
set dscp default
class class-default
set dscp default
!
!
Interface settings:
interface FastEthernet0/1
no switchport
ip address 192.168.44.115 255.255.255.0
!
interface FastEthernet0/2
description Test Qos Implementation
switchport mode dynamic desirable
service-policy input test_qos
!
interface FastEthernet0/3
description Test Qos Implementation
switchport mode dynamic desirable
service-policy input test_qos
Access-Lists:
ip access-list extended acl_average
permit ip 192.168.44.0 0.0.0.255 any
ip access-list extended acl_criticals
permit tcp any any eq www
permit tcp any any eq smtp
permit tcp any any eq pop3
permit tcp any any eq 5000
permit tcp any any eq 5222
permit tcp any any eq 1024
permit tcp any any eq 5002
permit tcp any any eq 5003
permit tcp any any eq 5004
permit tcp any any eq 5005
permit tcp any any eq 5006
permit tcp any any eq 5007
permit tcp any any eq 5008
permit tcp any any eq 5009
permit tcp any any eq 5010
permit tcp any any eq domain
ip access-list extended acl_medium
permit tcp any any eq 5050
permit tcp any any eq 5100
permit tcp any any eq 6891
permit tcp any any eq 6892
permit tcp any any eq 6893
permit tcp any any eq 6894
permit tcp any any eq 6895
permit tcp any any eq 6896
permit tcp any any eq 6897
permit tcp any any eq 6898
permit tcp any any eq 6899
permit tcp any any eq 6900
Queueing and scheduling: I basically followed the auto qos settings:
mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2 1
mls qos srr-queue input cos-map queue 1 threshold 3 0
mls qos srr-queue input cos-map queue 2 threshold 1 2
mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3 3 5
mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3 32
mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2 33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2 49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2 57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3 40 41 42 43 44 45 46 47
Output:
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 2 4
mls qos srr-queue output cos-map queue 4 threshold 2 1
mls qos srr-queue output cos-map queue 4 threshold 3 0
mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1 8
mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos -
mikej412 Member Posts: 10,086 ■■■■■■■■■■anis wrote:I am looking for anykind of instructin based on this problem.:mike: Cisco Certifications -- Collect the Entire Set!