frame-relay which one?

itdaddyitdaddy Senior MemberMember Posts: 2,089 ■■■■□□□□□□
Hello Cisco Gurus!

I am studying for CCNA and I am studying frame-relay.

I have some questions but want to ask them in true or false statements.
If what I am saying is false. Please tell me and explain. Thanks so much!

1. When using frame-relay map ip or frame-relay interface-dlci, it doesnt matter
which command to use as long as you create a pvc with your command.

2. I have tried mix and matching frame-relay commands, and they all work as long
as you configure your mappings.

3. When using the command no frame-relay inverse-arp, and using the frame-relay map ip command, you have to include the broadcast command to allow for RIP updates to work.

4. You can only create Point-to-point and multipoint interfaces with subinterfaces only.
They do not work with basic physcial serial interfaces.

5. You do not need RIP enable or any routing protocol when createing PVCs, pings work just fine
once frame-relay commands and DLCIs are setup correct.

Comments

  • NetstudentNetstudent Member Posts: 1,693 ■■■□□□□□□□
    itdaddy wrote:
    Hello Cisco Gurus!

    I am studying for CCNA and I am studying frame-relay.

    I have some questions but want to ask them in true or false statements.
    If what I am saying is false. Please tell me and explain. Thanks so much!

    1. When using frame-relay map ip or frame-relay interface-dlci, it doesnt matter
    which command to use as long as you create a pvc with your command.

    2. I have tried mix and matching frame-relay commands, and they all work as long
    as you configure your mappings.

    3. When using the command no frame-relay inverse-arp, and using the frame-relay map ip command, you have to include the broadcast command to allow for RIP updates to work.

    4. You can only create Point-to-point and multipoint interfaces with subinterfaces only.
    They do not work with basic physcial serial interfaces.

    5. You do not need RIP enable or any routing protocol when createing PVCs, pings work just fine
    once frame-relay commands and DLCIs are setup correct.


    1. YOu must use the frame map command if you turn Inverse-ARP off. IARP does the mapping for you.

    3. yes becuase RIPv1 uses broadcasts.

    4 You can create frame circuits on a physical interface if you want, but it's not good practice. You could run into split horizon issues. But if you use the physical interface then you don;t have to issue the frame-relay interface-dlci command becuase the physical inteface will hear it via LMI messages.

    5. Right no need for a routing protocol to establish point-to-point to multipoint connections. You would need a route to get to a subnet that is not directly connected though. So if you had a hub and spoke of p-t-p circuits, then you would need routes for site to site comm, whether it be static, dynamic, or default routes.
    There is no place like 127.0.0.1 BUT 209.62.5.3 is my 127.0.0.1 away from 127.0.0.1!
  • Paul BozPaul Boz Member Posts: 2,620 ■■■■■■■■□□
    itdaddy wrote:

    1. When using frame-relay map ip or frame-relay interface-dlci, it doesnt matter
    which command to use as long as you create a pvc with your command.

    2. I have tried mix and matching frame-relay commands, and they all work as long
    as you configure your mappings.

    3. When using the command no frame-relay inverse-arp, and using the frame-relay map ip command, you have to include the broadcast command to allow for RIP updates to work.

    4. You can only create Point-to-point and multipoint interfaces with subinterfaces only.
    They do not work with basic physcial serial interfaces.

    5. You do not need RIP enable or any routing protocol when createing PVCs, pings work just fine
    once frame-relay commands and DLCIs are setup correct.

    1.) Basically. Sometimes it's wiser to use map statements but usually it's a pain in the butt and doesn't scale.

    2.) Remember that there are three fundamental concepts to frame relay.

    A. Set encapsulation
    B. Create one interface per subnet
    C. Associate DLCI's with sub interfaces

    As long as you remain within the general design concepts of frame relay you're good to go. Different combinations of commands generally results in different configuration options. That's the beauty of frame relay. There are a dozen ways to do everything which is great for admins who like to tune.

    3.) I haven't messed with RIP in a while but for RIP V1 that's right. If you use RIP V2 you can use neighbor statements which nul having to use the broadcast keyword.

    4.) False. You don't need to use sub interfaces for point to point frame relay. Here is a sample configuration:
    Corporate:
    Router>enable
    Router#config t
    Router(config)#hostname Corp
    Corp(config)#interface serial 0
    Corp(config-if)#encapsulation frame-relay
    Corp(config-if)#ip address 10.1.1.1 255.255.255.0
    Corp(config-if)#frame-relay interface-dlci 100
    Corp(config-if)#frame-relay lmi-type cisco
    Corp(config-if)#no shutdown
    Corp(config-if)#exit
    Corp(config)#exit
    Corp#

    Branch:
    Router>enable
    Router#config t
    Router(config)#hostname Branch
    Branch(config)#interface serial 0
    Branch(config-if)#encapsulation frame-relay
    Branch(config-if)#ip address 10.1.1.2 255.255.255.0
    Branch(config-if)#frame-relay interface-dlci 101
    Branch(config-if)#frame-relay lmi-type cisco
    Branch(config-if)#no shutdown
    Branch(config-if)#exit
    Branch(config)#exit
    Branch#

    As you can see in this example, there are no sub interfaces used but the connection works fine.

    5.) True. You do not have to have a dynamic routing protocol set up or even static routes to be able to ping between routers on the same subnet.

    Here's a sh run int s2/0 from a quick lab I did for you.
    R1
    !
    interface Serial2/0
    ip address 172.16.0.1 255.255.255.0
    encapsulation frame-relay
    serial restart-delay 0
    frame-relay interface-dlci 102
    end

    R2
    !
    interface Serial2/0
    ip address 172.16.0.2 255.255.255.0
    encapsulation frame-relay
    serial restart-delay 0
    frame-relay interface-dlci 201
    end

    Observe that the network 172.16.0.0/24 is not in the below routing table:
    Gateway of last resort is 10.0.0.1 to network 0.0.0.0

    1.0.0.0/32 is subnetted, 1 subnets
    O 1.1.1.1 [110/2] via 192.168.254.2, 00:03:59, FastEthernet0/0
    2.0.0.0/32 is subnetted, 1 subnets
    C 2.2.2.2 is directly connected, Loopback2222
    4.0.0.0/32 is subnetted, 1 subnets
    S 4.4.4.4 [1/0] via 10.0.0.1
    172.16.0.0/32 is subnetted, 2 subnets
    O IA 172.16.3.1 [110/2] via 192.168.254.2, 00:03:59, FastEthernet0/0
    O IA 172.16.2.1 [110/2] via 192.168.254.2, 00:03:59, FastEthernet0/0
    10.0.0.0/30 is subnetted, 1 subnets
    C 10.0.0.0 is directly connected, Serial1/0
    192.168.254.0/30 is subnetted, 2 subnets
    O IA 192.168.254.4 [110/2] via 192.168.254.2, 00:03:59, FastEthernet0/0
    C 192.168.254.0 is directly connected, FastEthernet0/0
    C 192.168.1.0/24 is directly connected, Loopback0
    S* 0.0.0.0/0 [1/0] via 10.0.0.1

    yet the ping results work fine:
    R1#ping 172.16.0.2

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.0.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 24/54/108 ms

    I hope that helps.
    CCNP | CCIP | CCDP | CCNA, CCDA
    CCNA Security | GSEC |GCFW | GCIH | GCIA
    [email protected]
    http://twitter.com/paul_bosworth
    Blog: http://www.infosiege.net/
  • itdaddyitdaddy Senior Member Member Posts: 2,089 ■■■■□□□□□□
    thanks so much for all of your clarifications. Amazing how frame relay you can have so many variations but there are basic rules. thanks a lot!


    thanks Netstudent; very nice explains!

    Paul boz:
    so you are telling me that a point-to-point doesnt have to have the command
    point-to-point after it. so on a physical "if" you dont need p-t-p command
    and it is still a point to point???

    thanks
    great stuff!
  • kryollakryolla Member Posts: 785
    I think the physical interface is multipoint and the sub int is point to point or multipoint. You can verify it with sh fram-relay map. You only need a routing protocol to route traffic off the subnet
    Studying for CCIE and drinking Home Brew
  • dtlokeedtlokee Member Posts: 2,378 ■■■■□□□□□□
    I think what Paul was trying to show is if you only use a single PVC on the interface it will seem like a point to point connection, but there could be additional configuraiton required to make it fully behae like one when it comes to things like routing protocols. Your best bet is to create point to point subinterfaces.
    The only easy day was yesterday!
  • itdaddyitdaddy Senior Member Member Posts: 2,089 ■■■■□□□□□□
    thanks guys sounds great! i see i see. thanks ;)
Sign In or Register to comment.