Frame Relay switching(in the cloud)

oRis1024oRis1024 Member Posts: 9 ■□□□□□□□□□
Hey guys, i hope somebody can help me. I have a question about Frame Relay. All the books i've consulted don't explain much on how DLCIs are used in the Frame Relay cloud. That is how the FR Switches use them to route frames..
I'm including an image to make asking questions easier.

fr.jpg

So the gray circles are routers, the boxes are Frame Relay switches. R1 is the hub, R2 and R3 are the spokes. Now, if i understood correctly the DLCIs would look similar to the ones shown above.

What i'm not sure about is this:

1. Are DLCIs configured in pairs(what i have on the picture, 102-102, 78-78 ), or can they be different for one segment? (e.g. the green link between R1 and switch A, does it have to have the same DLCI on both ends?)

if they could be different on the ends of the same link i just don't see how the switch can route frames to their destinations..

2. If another location(a spoke) was added to switch C, the service provider would have to map the route for it on all three switches using new DLCIs, right?

I hope somebody can clarify this for me, thanks in advance![/img][/i]

Comments

  • mgeorgemgeorge Member Posts: 774 ■■■□□□□□□□
    Well to answer your first question, no the DLCI number has no relevence to how the mappings
    work. You map the DLCI number to an Interface. DLCI numbers can be the same on both ends.
    or different such as 102 to 201 (which signifies that dlci 102 will go from router 1 to 2, most of
    the isp's do it this way so the customer does not get confused.

    Also I'm guessing you want to know how frame relay traverses the internal isp network if you
    have a node in new york and a node in san francisco and a crapload of routers in between?
    You could use tunnel interfaces.

    Instead of using an outgoing serial interface in your frame route map use a tunnel interface

    So example for Router1 to Router2;
    Router A config
    Serial interface connected to Router1
    frame-relay route 102 interface Tunnel0 201

    interface Tunnel0
    tunnel source FastEthernet0/0 (interface which the traffic goes out)
    tunnel destination 10.0.0.2 (The destination of the terminating end)

    Router C config
    Serial interface connected to Router2
    frame-relay route 201 interface Tunnel0 102

    interface Tunnel0
    tunnel source FastEthernet0/0 (interface which the traffic goes out)
    tunnel destination 10.0.0.1 (The destination of the terminating end)

    Once the tunnel interface is up between both A and C (the traffic can traverse the internal network
    however it likes, this also provides redundancy internally if a few links on the inside cloud go
    down) You will be able to use the frame interface-dlci 102 on r1 and frame interface-dlci 201
    on router 2 and the routers will be able to ping each other.

    Try this out and let me know how it works for ya.
    There is no place like 127.0.0.1
  • Paul BozPaul Boz Member Posts: 2,620 ■■■■■■■■□□
    There are two primary methods of configuring frame relay switching.
    >frame-relay switching
    >int s0/0
    >no ip address
    >encap frame-relay
    >clockrate [clockrate goes here]
    >frame-relay interface-type DCE
    >frame-relay route 102 interface s1/0 201
    >no shut

    You can condense the configuration using the following command:
    >connect [name] serial1/0 102 serial 2/0 201

    I'm mostly familiar with connecting circuits via widebanks and the PSTN from within the cloud but whenever I have to work with circuits built within Cisco equipment I use the latter config command.

    It may also help you to read this article by Chris Bryant. I used it when I was working on my CCNA to work out some frame relay problems. Its a guide for how to configure a low-end Cisco router as a lab frame relay switch. Just reading the configs should clue you in.

    http://www.thebryantadvantage.com/Frame%20Relay%20Switch.htm

    Lastly, here's a good book by Cisco on frame relay options if you want further reading.

    http://www.ciscopress.com/articles/article.asp?p=170741&seqNum=7
    CCNP | CCIP | CCDP | CCNA, CCDA
    CCNA Security | GSEC |GCFW | GCIH | GCIA
    [email protected]
    http://twitter.com/paul_bosworth
    Blog: http://www.infosiege.net/
  • EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    oRis1024 wrote:
    Hey guys, i hope somebody can help me. I have a question about Frame Relay. All the books i've consulted don't explain much on how DLCIs are used in the Frame Relay cloud. That is how the FR Switches use them to route frames..
    I'm including an image to make asking questions easier.

    fr.jpg

    So the gray circles are routers, the boxes are Frame Relay switches. R1 is the hub, R2 and R3 are the spokes. Now, if i understood correctly the DLCIs would look similar to the ones shown above.

    What i'm not sure about is this:

    1. Are DLCIs configured in pairs(what i have on the picture, 102-102, 78-78 ), or can they be different for one segment? (e.g. the green link between R1 and switch A, does it have to have the same DLCI on both ends?)

    if they could be different on the ends of the same link i just don't see how the switch can route frames to their destinations..

    2. If another location(a spoke) was added to switch C, the service provider would have to map the route for it on all three switches using new DLCIs, right?

    I hope somebody can clarify this for me, thanks in advance![/img][/i]

    You need to look at what frame relay actually is, look at its header.The header is comprised mostly of the dlci bits.Looking at it in its most simplest form, its a frame of data with a dlci address.Router1 has an application which is configured to send frames with a dlci 102, this is received on the physical interface x of switchA, if a frame relay connection with dlci 102 has not been configured on switchA phyical port x,SwitchA will drop the frames received.If you have previously made a connection on switchA as in this case between port x dlci 102 and port y dlci 78, traffic arriving on port x with a dlci 102 will be mapped to port y 78,so on arrival the frame will be unencapsulated i.e. frame relay header checked and removed, frame relay switching table checked to see where dlci 102 port x maps, switch table lookup will result in dlci 78 being added to the frame-relay header and the frame sent out interface y.Same exact sequence happens all the way through the frame-relay switching core,until finally a frame with dlci 201 arrives at router2.
    I'm pretty sure you dont care about tunnelling frame-relay through an ip core as its an outdated technique, overlay networking is being replaced by mpls.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • oRis1024oRis1024 Member Posts: 9 ■□□□□□□□□□
    Okay, so if i understood correctly(thanks y'all for your replies), the setup can look like this(as far as DLCIs go):

    fr2.jpg

    But i guess what doesn't settle in my head is that when Router1 sends out a frame it puts its local DLCI in the header, not the destination DLCI or the switch's. Is that right? In that case the switching table of sw1 would look like this:
    Switch 1
    -----------------------------------------------------
    | IN PORT | IN DLCI | OUT PORT | OUT DLCI |
    |----------------------------------------------------
    |    X    |   102   |    Y     |   32     |
    |    X    |   53    |    Y     |   20     |
    |    Y    |   98    |    X     |   41     |
    |    Y    |   73    |    X     |   68     |
    -----------------------------------------------------
    
    So if a frame [DLCI 102] arrived on the X port of Switch1, Switch1 would strip the header, get the 102 from it, look up "porticon_mad.gif, DLCI 102", encapsulate with a new header(DLCI 32) and forward it out of interface Y.. Is that how it travels?
    If that's so, one other question.. All these PVCs(e.g. red and green) are point-to-point then? That is, there is only one path and one destination a Frame Relay frame can travel?

    P.S. Also, the Router1 would be receiving frames with DLCIs 41 and 68 then, right?
    Thank you all. (as for the tunnels, i'll definitely see how they work later, but not until i figure this out - i think i start getting it though))
  • Paul BozPaul Boz Member Posts: 2,620 ■■■■■■■■□□
    Here is a simpler example that has one frame relay switch between two routers.

    frs.PNG

    Here is an example configuration for one of the frame relay switch's interfaces.
    FRS(config)#frame-relay switching
    FRS(config)#int s0/0
    FRS(config-if)#no ip address
    FRS(config-if)#encap frame-relay
    FRS(config-if)#clockrate 1500000
    FRS(config-if)#frame-relay intf-type dce
    FRS(config-if)#frame-relay route 102 interface serial0/1 201
    FRS(config-if)#no shut

    Pay attention to the "frame-relay route" statements. Just like a routing table entry, you can read it logically.

    "If a frame with DLCI 102 comes into interface s0/0 (the interface which the configuration is on) it needs to go out interface serial 0/1 with a new DLCI of 201."

    You also need to keep in mind that the DLCI has to be the same for the link, so for the link between R1 and the FRS, the DLCI is 102. Both the DTE interface of R1 and the DCE interface of the FRS will use the same DLCI. The FRS is the only place where the actual DLCI changes, and that is because the FRS connects different segments.

    Here is an example of the "show frame route" command as issued on the FRS to show you what the mappings look like.
    FRS#show frame route
    Input Intf            Input Dlci             Output Intf          Output Dlci             Status
    Serial 0/0            102                    Serial 0/1           201                     active
    serial 0/1            201                    Serial 0/0           102                     active
    

    I hope that clarifies your question a bit further.
    CCNP | CCIP | CCDP | CCNA, CCDA
    CCNA Security | GSEC |GCFW | GCIH | GCIA
    [email protected]
    http://twitter.com/paul_bosworth
    Blog: http://www.infosiege.net/
  • oRis1024oRis1024 Member Posts: 9 ■□□□□□□□□□
    Paul Boz wrote:
    the DLCI has to be the same for the link
    That's all i needed to know :) For some reason everybody starts explaining the whole configuration process. Plus, the way EVERY book/website explains it, is that DLCI is only of LOCAL SIGNIFICANCE. Well, turns out it's not local to the router(the first thing that comes to mind) but to the local loop(both ends of the segment). I often come across this kind of ambiguities. Books leave out too much "in the cloud" imo.

    Well, i got it now. Thanks to all for the replies! :D
  • ixg123ixg123 Member Posts: 15 ■□□□□□□□□□
    To avoid any confusion, what you always have to bear in mind is that once something is on the fiber/coax there isn't any way that it can be changed until it is terminated at the other end. As a result, if you transmit on DLCI 123 the device that terminates your connection will receive your data with a header of DLCI 123. The DLCI number can change many times between your end points, but cannot change over a point-to-point connection.

    It's an important behaviour to bear in mind as exactly the same applies for MPLS labels, ATM VPI/VCI, SONET KLM as well as FR DLCI.

    To clarify something though, as written above, it is possible that you will see diagrams with different DLCIs detailed at the end of each link - in exactly the same way that you created the "summary" diagram. The reason for this is that although you only show a single connection between nodes, it is used to represent both transmit and receive ... and there is absolutely no reason why the numbers would have to match. As explained earlier (especially in books/labs) it is common for the connection from R1 to R3 to be given a DLCI something like 123, whilst the connection from R3 to R1 is assigned a DLCI of 321. The numbers used on the diagrams are generally the DLCI number used to transmit ... hence the "mismatch".
  • ptlinvaptlinva Member Posts: 125
    There are two primary methods of configuring frame relay switching.

    Quote:
    >frame-relay switching
    >int s0/0
    >no ip address
    >encap frame-relay
    >clockrate [clockrate goes here]
    >frame-relay interface-type DCE
    >frame-relay route 102 interface s1/0 201
    >no shut
    You can condense the configuration using the following command:

    Quote:
    >connect [name] serial1/0 102 serial 2/0 201
    I'm mostly familiar with connecting circuits via widebanks and the PSTN from within the cloud but whenever I have to work with circuits built within Cisco equipment I use the latter config command.

    ===================

    I know this is an OLD thread, so I appreciate your patience.

    Do these two commands (in RED above) accomplish the same thing?

    It seems that "connect" command is done at the conf t level while the "frame-relay route" is applied at the interface level.

    Funtionality wise, do they accomplish the same thing?

    It's probably me, but the "connect" command seemed to click with my coconut. However, I just wanted to find out if there were any other differences (functionality wise) that I should be aware of...

    Thanks in advance for time and consideration.

    Your friend in Virginia,
    Paul L.
Sign In or Register to comment.