Frame relay subinterface problem
kadshah
Member Posts: 388 ■■■□□□□□□□
in CCNA & CCENT
I have a frame relay network (hub & spoke) with point to point subinterfaces
to avoid the split horizon issue with RIP v2.
When I ping from router 1 to router 2 or 3 serial int I get an output like
this .!.! or !.!. I remember reading about this output somewhere but don't
remember where. Can someone explain what this means?
When I ping from from router 1 to router 2 or 3 loopback int it works fine.
Could you please take a look at the output below and see where I screwed up.
R1-2501#sh frame-relay map
Serial1.123 (up): point-to-point dlci, dlci 101(0x65,0x1850), broadcast
status defined, active
Serial1.124 (up): point-to-point dlci, dlci 200(0xC8,0x3080), broadcast
status defined, active
R2_2501#sh frame-relay map
Serial0 (up): ip 10.10.12.8 dlci 100(0x64,0x1840), static,
broadcast,
CISCO, status defined, active
R3-2610#sh frame-relay map
Serial0/0 (up): ip 10.10.12.7 dlci 201(0xC9,0x3090), static,
broadcast,
CISCO, status defined, active
R1-2501#sh run
Building configuration...
Current configuration : 1018 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname R1-2501
!
enable secret 5 $1$hN2/$KhEXAMi3HmguBmG59dAOj/
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0
no ip address
!
interface Serial0
no ip address
clockrate 64000
!
interface Serial1
no ip address
encapsulation frame-relay
no frame-relay inverse-arp
frame-relay lmi-type ansi
!
interface Serial1.123 point-to-point
ip address 10.10.12.8 255.255.255.240
frame-relay interface-dlci 101
!
interface Serial1.124 point-to-point
ip address 10.10.12.7 255.255.255.240
frame-relay interface-dlci 200
!
router rip
version 2
network 1.0.0.0
network 10.0.0.0
no auto-summary
!
ip classless
ip http server
!
!
line con 0
exec-timeout 0 0
password 7 141C13010D52797A70
logging synchronous
login
line aux 0
line vty 0 4
password 7 09474F03185344435F
login
!
end
R2_2501#sh run
Building configuration...
Current configuration : 1022 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname R2_2501
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
no ip route-cache
no ip mroute-cache
!
interface Ethernet0
no ip address
no ip route-cache
no ip mroute-cache
!
interface Serial0
ip address 10.10.12.3 255.255.255.240
encapsulation frame-relay
no ip route-cache
no ip mroute-cache
frame-relay map ip 10.10.12.8 100 broadcast
no frame-relay inverse-arp
frame-relay lmi-type ansi
!
interface Serial1
no ip address
no ip route-cache
no ip mroute-cache
!
router rip
version 2
network 2.0.0.0
network 10.0.0.0
no auto-summary
!
ip classless
no ip http server
!
!
line con 0
exec-timeout 0 0
password 7 09474F03185344435F
logging synchronous
line aux 0
transport input all
line vty 0 4
password 7 082A4D44084F564646
login
!
end
R3-2610#sh run
Building configuration...
Current configuration : 902 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R3-2610
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$laCT$LcgpXwGsOZr.Qf9.j5txJ0
!
no aaa new-model
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Ethernet0/0
no ip address
half-duplex
!
interface Serial0/0
ip address 10.10.12.4 255.255.255.240
encapsulation frame-relay
frame-relay map ip 10.10.12.7 201 broadcast
no frame-relay inverse-arp
frame-relay lmi-type ansi
!
router rip
version 2
network 3.0.0.0
network 10.0.0.0
no auto-summary
!
!
no ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
line con 0
password 7 130E16180A5A577B7F
login
line aux 0
line vty 0 4
exec-timeout 0 0
password 7 09474F03185344435F
logging synchronous
login
!
!
end
to avoid the split horizon issue with RIP v2.
When I ping from router 1 to router 2 or 3 serial int I get an output like
this .!.! or !.!. I remember reading about this output somewhere but don't
remember where. Can someone explain what this means?
When I ping from from router 1 to router 2 or 3 loopback int it works fine.
Could you please take a look at the output below and see where I screwed up.
R1-2501#sh frame-relay map
Serial1.123 (up): point-to-point dlci, dlci 101(0x65,0x1850), broadcast
status defined, active
Serial1.124 (up): point-to-point dlci, dlci 200(0xC8,0x3080), broadcast
status defined, active
R2_2501#sh frame-relay map
Serial0 (up): ip 10.10.12.8 dlci 100(0x64,0x1840), static,
broadcast,
CISCO, status defined, active
R3-2610#sh frame-relay map
Serial0/0 (up): ip 10.10.12.7 dlci 201(0xC9,0x3090), static,
broadcast,
CISCO, status defined, active
R1-2501#sh run
Building configuration...
Current configuration : 1018 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname R1-2501
!
enable secret 5 $1$hN2/$KhEXAMi3HmguBmG59dAOj/
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0
no ip address
!
interface Serial0
no ip address
clockrate 64000
!
interface Serial1
no ip address
encapsulation frame-relay
no frame-relay inverse-arp
frame-relay lmi-type ansi
!
interface Serial1.123 point-to-point
ip address 10.10.12.8 255.255.255.240
frame-relay interface-dlci 101
!
interface Serial1.124 point-to-point
ip address 10.10.12.7 255.255.255.240
frame-relay interface-dlci 200
!
router rip
version 2
network 1.0.0.0
network 10.0.0.0
no auto-summary
!
ip classless
ip http server
!
!
line con 0
exec-timeout 0 0
password 7 141C13010D52797A70
logging synchronous
login
line aux 0
line vty 0 4
password 7 09474F03185344435F
login
!
end
R2_2501#sh run
Building configuration...
Current configuration : 1022 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname R2_2501
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
no ip route-cache
no ip mroute-cache
!
interface Ethernet0
no ip address
no ip route-cache
no ip mroute-cache
!
interface Serial0
ip address 10.10.12.3 255.255.255.240
encapsulation frame-relay
no ip route-cache
no ip mroute-cache
frame-relay map ip 10.10.12.8 100 broadcast
no frame-relay inverse-arp
frame-relay lmi-type ansi
!
interface Serial1
no ip address
no ip route-cache
no ip mroute-cache
!
router rip
version 2
network 2.0.0.0
network 10.0.0.0
no auto-summary
!
ip classless
no ip http server
!
!
line con 0
exec-timeout 0 0
password 7 09474F03185344435F
logging synchronous
line aux 0
transport input all
line vty 0 4
password 7 082A4D44084F564646
login
!
end
R3-2610#sh run
Building configuration...
Current configuration : 902 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R3-2610
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$laCT$LcgpXwGsOZr.Qf9.j5txJ0
!
no aaa new-model
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Ethernet0/0
no ip address
half-duplex
!
interface Serial0/0
ip address 10.10.12.4 255.255.255.240
encapsulation frame-relay
frame-relay map ip 10.10.12.7 201 broadcast
no frame-relay inverse-arp
frame-relay lmi-type ansi
!
router rip
version 2
network 3.0.0.0
network 10.0.0.0
no auto-summary
!
!
no ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
line con 0
password 7 130E16180A5A577B7F
login
line aux 0
line vty 0 4
exec-timeout 0 0
password 7 09474F03185344435F
logging synchronous
login
!
!
end
Comments
-
darkuser Member Posts: 620 ■■■□□□□□□□your config looks fine to me
every other packet is dropped by the frame
try some debugs .....
debug ip icmp
debug frame packet
" " whatever
is this a lab link?rm -rf / -
kadshah Member Posts: 388 ■■■□□□□□□□everything looks good except for the ignore v2.
still haven't figure out why this is working.
R1-2501#debug ip rip events
RIP event debugging is on
R1-2501#
00:21:04: RIP: received v2 update from 10.10.12.4 on Serial1.124
00:21:04: RIP: Update contains 2 routes
R1-2501#no debug all
00:21:11: RIP: sending v2 update to 224.0.0.9 via Loopback0 (1.1.1.1)
00:21:11: RIP: Update contains 3 routes
00:21:11: RIP: Update queued
00:21:11: RIP: sending v2 update to 224.0.0.9 via Serial1.123 (10.10.12.
00:21:11: RIP: Update contains 2 routes
00:21:11: RIP: Update queued
00:21:11: RIP: sending v2 update to 224.0.0.9 via Serial1.124 (10.10.12.7)
00:21:11: RIP: Update contains 2 routes
00:21:11: RIP: Update queued
00:21:11: RIP: Update sent via Loopback0
00:21:11: RIP: Update sent via Serial1.123
00:21:11: RIP: Update sent via Serial1.124
00:21:11: RIP: ignored v2 packet from 1.1.1.1 (sourced from one of our addresses
R1-2501#debug ip rip databaseRIP database events debugging is on
R1-2501#
00:21:55: RIP-DB: network_update with 2.2.2.2/32 succeeds00:21:55: RIP-DB: adding 2.2.2.2/32 (metric 1) via 10.10.12.3 on Serial1.123 to
RIP database
R1-2501#
00:21:58: RIP-DB: network_update with 3.3.3.3/32 succeeds00:21:58: RIP-DB: adding 3.3.3.3/32 (metric 1) via 10.10.12.4 on Serial1.124 to
RIP database -
Netstudent Member Posts: 1,693 ■■■□□□□□□□Your config does not look fine to me.
your using the same subnet for both p-t-p links and RIP is round robin load balancing across them. Then your dropping a packet that goes out the wrong PVC.
with a 28 bit mask, your range will be from 10.10.12.1 - 10.10.12.14 in that single network.
YOu need to change the IP subnet for one of the point-to-point links. like maybe 10.10.12.16 255.255.255.252
this will give you 12.17 and 12.18 to use for the link.
If you found this config somewhere else, then they are probably trying to get you to practice a multipoint config. IN that case they would be in the same subnet, but the frame configs would be on a multipoint subinterface not a point-to-point.
Subnetting is the foundation of IP internetworking and the CCNA. You have to nail that before you move into other things. Thats why subnetting is chapter 2 and frame relay is chapter 10.There is no place like 127.0.0.1 BUT 209.62.5.3 is my 127.0.0.1 away from 127.0.0.1! -
kadshah Member Posts: 388 ■■■□□□□□□□Thanks! I must have been very tired last week cause I noticed all my mistakes today after taking a break for two days. I reconfigured the ip address and everything worked like a charm. Here's the output for anyone who is intrested.
Subinterfaces and frame relay configuration
R3-2610#sh frame-relay map
Serial0/0 (up): ip 172.12.123.5 dlci 201(0xC9,0x3090), static,
broadcast,
CISCO, status defined, active
R3-2610#sh run
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Ethernet0/0
no ip address
half-duplex
!
interface Serial0/0
ip address 172.12.123.6 255.255.255.252
encapsulation frame-relay
frame-relay map ip 172.12.123.5 201 broadcast
no frame-relay inverse-arp
!
router rip
version 2
network 3.0.0.0
network 172.12.0.0
no auto-summary
R1-2501#sh frame-relay map
Serial1.3 (up): point-to-point dlci, dlci 200(0xC8,0x3080), broadcast
status defined, active
Serial1.2 (up): point-to-point dlci, dlci 101(0x65,0x1850), broadcast
status defined, active
R1-2501#sh run
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0
no ip address
!
interface Serial0
no ip address
clockrate 64000
!
interface Serial1
no ip address
encapsulation frame-relay
no frame-relay inverse-arp
!
interface Serial1.2 point-to-point
ip address 172.12.123.1 255.255.255.252
frame-relay interface-dlci 101
!
interface Serial1.3 point-to-point
ip address 172.12.123.5 255.255.255.252
frame-relay interface-dlci 200
!
router rip
version 2
network 1.0.0.0
network 172.12.0.0
no auto-summary
R2_2501#sh frame-relay map
Serial0 (up): ip 172.12.123.1 dlci 100(0x64,0x1840), static,
broadcast,
CISCO, status defined, active
R2_2501#sh run
interface Loopback0
ip address 2.2.2.2 255.255.255.255
no ip route-cache
no ip mroute-cache
!
interface Ethernet0
no ip address
no ip route-cache
no ip mroute-cache
!
interface Serial0
ip address 172.12.123.2 255.255.255.252
encapsulation frame-relay
no ip route-cache
no ip mroute-cache
frame-relay map ip 172.12.123.1 100 broadcast
no frame-relay inverse-arp
!
interface Serial1
no ip address
no ip route-cache
no ip mroute-cache
!
router rip
version 2
network 2.0.0.0
network 172.12.0.0
no auto-summary
!
[/b] -
Netstudent Member Posts: 1,693 ■■■□□□□□□□cool...sometimes it's better to foul it up and learn from that.There is no place like 127.0.0.1 BUT 209.62.5.3 is my 127.0.0.1 away from 127.0.0.1!